Kodi Community Forum

Full Version: --enable-external-ffmpeg FAILS?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
What is the solution to have xbmc find an external ffmpeg library in eden? I have tried everything possible on google and here and I still get the same result. I saw the patch posted here http://trac.xbmc.org/ticket/11734 but it fails. Here is my ffmpeg details?

ffmpeg version N-32429-ge5e0580, Copyright © 2000-2011 the FFmpeg developers
built on Sep 9 2011 19:38:33 with gcc 4.4.3
configuration: --prefix=/usr --enable-shared --disable-crystalhd**
libavutil 51. 16. 0 / 51. 16. 0
libavcodec 53. 13. 0 / 53. 13. 0
libavformat 53. 12. 0 / 53. 12. 0
libavdevice 53. 3. 0 / 53. 3. 0
libavfilter 2. 39. 0 / 2. 39. 0
libswscale 2. 1. 0 / 2. 1. 0

**crystalhd broken in current ffmpeg**

checking for FFMPEG... no

configure: error: Could not find a required library. Please see the README for your platform.
From my limited experience (i.e. trying to beat XBMC into using external FFMPEG myself - no, I haven't succeeded, but I'm getting further than you!), is everything in the right place? Any --prefix directives confusing anything, any sparks of light from ldconfig -p?

I had all sorts of knots tied until I uninstalled the repo version of FFMPEG and then did the make install of the git version. FFMPEG now works okay, and XBMC's configure can find it - won't make, though, due to multiple definitions, but that's just the latest problem in a long line...
Just tried it here - it's the --prefix directive that buggers it up for me: I get the "checking for FFMPEG... no" message then as well.

Leaving it as the default and XBMC can find it.

For info, I did have some ghosts hanging around after a couple of compilations, so I needed a make uninstall and make distclean before I rebuilt without the options.

As an aside, let me know how you get on if you can, please... I'm trying to build XBMC against external ffmpeg and hitting problems all over (e.g. libplist dependencies because of the new AirPlay functions), but I haven't cracked it all yet.

EDIT

Ignore that, I think I'm lying to you - my XBMC compile is now failing with the same error whether or not I compile FFMPEG with either of --prefix or --enable-shared. So I'll need to do some more digging to see (a) what XBMC is looking for as part of its check, (b) whether or not that's installed anywhere, and © if so, where. It may be a change in FFMPEG.