Kodi Community Forum

Full Version: TVHeadend user accounts with XBMC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm currently using xbmc-pvr odk48 with the latest TVHeadend PPA for Lars, I see fairly regularly XBMC disconnect from TVHeadend with the notification popup saying 'TVHeadend disconnected: access denied' then instantly afterwards I see 'TVHeadened: Connected'
I see this most with EPG updates just after starting XBMC, but occasionally I get it while watching TV.

So this got me wondering (since I run 4 XBMC clients in my house) are we supposed to use a seperate tvheadend user for each instance of XBMC?

Currently all 4 clients connect with the same username and password so I wonder if it causes the issue or it's something else entirely? Smile

Clients are a mixture of wired and wireless through a gigabit switch - I see the issue on all clients.
I'll need a full debug log
I've just had the error while debug logging was on, shortly after xbmc started I got the popup, while the EPG was updating, then it instantly re-connected and carried on..

The log was 9mb so I've zipped and put on my dropbox as a public file; http://dl.dropbox.com/u/6618363/xbmc%20log.zip

Let me know if you need anything else that could be of use.

Lars, does this looks like a real issue that I should put into Trac or a red herring in my setup ?

I don't want to clutter up trac if this isn't a real problem :p
Can anyone else confirm they see this behaviour?

I still see it in beta 1 and I've even switched a client to pulse eight openelec and also reinstalled the entire server os and changed to the latest tvheadend package from the pulse eight ppa.
I can reproduce this when I run xbmc within gdb, and I suspect that stuff in libTcpSocket / libPlatform to be the cause. that needs serious cleaning before Eden-pvr is final
Great thanks for the feedback dushmaniac, glad to hear its not something specific with my setup.
Do you want me to make this as a ticket somewhere,or do you already have a record of the issue now you've looked into it?
there's a ticket about it.
Great thanks for all your hard work! :-)