Kodi Community Forum

Full Version: Win7 latest XBMC all video blank
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all
The title pretty much says it all.

I have Win7 Home Premium with an NVida GeForce 310 and have just installed the latest version of XBMC for Windows.

I have tried the Iplayer, Catchup TV and normal (file) video playback and all just give black video output.

The playback controls are at the top of the screen OK, but the playback counter doesn't move. either - ie. It stays at zero.

Videos play normaly through windows and the iPlayer and CatchupTV sites play fine through the browser.

Does anyone have any ideas please?
from the main xbmc menu, go to SETTINGS, VIDEO Settings... Your solution is likely to be an adjustment here. I recently played with some of those and was unable to play video with my changes. (Yes I was fixing things that were not broken). When I reverted them back everything was fine again.
If unsure what to do with the settings come back and tell us what your current settings there are. From there, someone can point out what to adjust.
Also include some more specific info on your hardware setup. Need to know what your hardware is to match the settings accordingly. What type of display, What type of video processor, etc.
Thanks for the reply:

On System-Settings -> Video Output I have:

Display mode - Full Screen #1
Resolution - 19080 1020
Use fullscreen............. - No
Blank ............. - No
Vertical blank sync - Always enabled

The callibration test appears to work OK

The hardware is:

Monitor - LGE2240 - Analog
Adaptor - NVidia GeForce 310
Driver - NVIDIA - 8.17.11.9778

I've tried running windowed and it makes no difference - if that's any help

All the best
Check the sound settings. If you're using normal stereo sound check you have speakers or headphones connected. Windows 7 disables the sound if there are no speakers or headphones connected, and this can interfere with video playback.

If it still doesn't work we'll need to see a debug log. Enable debug logging from System settings, System, Debugging, and restart XBMC. Attempt to play a video then close XBMC again.

Open the debug log by pressing Windows-R and in the Run dialog type:

"%appdata%\xbmc\xbmc.log"

(including the quotes). Click OK and the log should open in Notepad. Copy and paste the log into http://pastebin.com/ and post the link it gives you here.

JR
And I thought that I was too old to learn anything new!

Plugged speakers in and all works fine.

Many thanks for such a concise answer.