Kodi Community Forum

Full Version: 24p audio out of sync, been like this for a year
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi! I've been using xbmc for about a year+ and i've loved every second of the application. For the most time my HTPC ran fine, but around 10% of the movies were so out of sync they ruined the experience. I switched from 64bit to 32bit linux when I kept getting refresh rate crashes due to the 64 bit kernel or xbmc, don't remember which one to fault.

After watching a few movies on my brothers w7 htpcbox, I just realised why accept something that's not working as it should? I had my brother bring his HTPC next to mine. We all watched inception at the same time, and sure enough my movie is slightly out of sync, but on his system (same FILE) it runs flawlessly.

The out of sync isn't that bad, but it's very noticeable compared to this system running windows 7.

Why is this happening?

How can I solve this issue?




Here's a few files, if you want anything else, please let me know.

Thank You

xbmc log: http://paste.pocoo.org/show/487859/

Code:
p -Qi xbmc
Password:
Name           : xbmc
Version        : 10.1-9


Code:
specs:

AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
NVIDIA GPU GeForce 210 (GT218)
4GB Ram

Code:
uname -a
Linux HTPCBOX 3.0-ARCH #1 SMP PREEMPT Tue Aug 30 07:32:23 UTC 2011 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ AuthenticAMD GNU/Linux
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 260.19.21  ([email protected])  Thu Nov  4 21:47:28 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "LG Electronics LG TV"
    ModelName      "LG 46LD550N"
    HorizSync       30.0 - 83.0
    VertRefresh     58.0 - 62.0
    Option         "DPMS"
    Option "ExactModeTimingsDVI" "TRUE"
     Modeline "[email protected]" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
     Modeline "[email protected]" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
     Modeline "[email protected]" 74.16  1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync

EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    Modes #"[email protected]"# #"[email protected]"# #"[email protected]"#    
EndSubSection
Option "FlatPanelProperties" "Scaling = Native" # make sure the gpu does not scale and loose performance
Option "DynamicTwinView" "False" # disable or you'll get tearing
Option "TripleBuffer" "0" # disable or xbmc will segfault with smoothvideo
Option "NoLogo" "True" # skip logo!
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection
Are you playing the audio through your TV's speakers or going through a surround sound receiver? If you are, what kind of cables are you using? HDMI, optical/coax?

I have my HTPC connected both directly to my TV using HDMI for 2 channel audio when I dont feel like turning on the surround sound, and through an optical digtial connection to my Onkyo receiver.

Whenever I want to toggle between the two, I have to change the audio settings from within the movie to either Analog (for the TV) or Optical for the receiver.

When I have it in Analog mode for my TV, the audio is perfect, when I would play it through my receiver, there would be a delay. Initially, I adjusted the time delay within XBMC, but doing this caused the audio through the receiver to be correct, but if I switched back to analog, Id have to change it back to +0.

I discovered that my Onkyo reciever has an audio delay setting as well, so I set it to 10 milliseconds and that got it perfectly synced.

So now, regardless if I am listening to audio through my TV's speakers or through my receiver, the audio is correctly synced.
constrictor Wrote:Are you playing the audio through your TV's speakers or going through a surround sound receiver? If you are, what kind of cables are you using? HDMI, optical/coax?

Hi!

I'm running my audio through a pioneer reciever using optical since the pioneer doesn't have HDMI. For video the TV is hooked up to my HTPC using an HDMI cable.

Quote:I have my HTPC connected both directly to my TV using HDMI for 2 channel audio when I dont feel like turning on the surround sound, and through an optical digtial connection to my Onkyo receiver.

Whenever I want to toggle between the two, I have to change the audio settings from within the movie to either Analog (for the TV) or Optical for the receiver.

When I have it in Analog mode for my TV, the audio is perfect, when I would play it through my receiver, there would be a delay. Initially, I adjusted the time delay within XBMC, but doing this caused the audio through the receiver to be correct, but if I switched back to analog, Id have to change it back to +0.

I discovered that my Onkyo reciever has an audio delay setting as well, so I set it to 10 milliseconds and that got it perfectly synced.

So now, regardless if I am listening to audio through my TV's speakers or through my receiver, the audio is correctly synced.

That's very interesting. I haven't thought about the reciever causing an actual delay. But you see I also use the very same sound system when i'm using my laptop for gaming and there's no delay there. Same goes when I play HD movies using mediaplayer classic on windows 7, no delays what so ever.

Of course I could start mixing with the time delay but really that's not a good solution in my experience.

Also doesn't this mean I have to manually adjust each millisecond for each new movie with various sync issues?

I can't switch to analog on my system, I only have Digital 5.1.

Thanks for sharing your setup and recomendations Smile
I guess this post answers a question I had, if Linux has the 24p audio sync issue just as the Windows version does. And I'm guessing it does.

I've been using a Windows version in a 32bit Win 7 for over a year now. I've been having the annoying problem of 24p audio being out of sync. I usually have to set my offset slider to the left about 100ms-200ms. Most if not all other non-24p content needs no audio offset. It appears to be an inherent bug in XBMC's "24p" audio decoding engine, or video decoding engine. Hopefully some year the AudioEngine build will be merged into current builds and fix all these issues. But a Team-XBMC Member said it didn't make it into the Eden build. Sad

I was thinking about reformatting from Win 7 to Linux just to get the audio sync to work properly, but it appears I'll be sticking with what I have for now. Maybe I'll reformat to 64bit 7 when Eden comes out.

Some other info:
http://forum.xbmc.org/showthread.php?tid=80247

http://forum.xbmc.org/showthread.php?tid=96916

http://trac.xbmc.org/ticket/5755