Kodi Community Forum

Full Version: 11.10 XBMC fullscreen UI now jittery?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I updated to 11.10 today... well as usual, that was a bit of a mistake. Using the latest nvidia-current-updates on GT240.

Prior everything was smooth as silk, but now the xbmc UI is jittery only in fullscreen mode. When I run it maximized in a window it runs perfectly smooth and I can't figure out what the difference is. The even odder thing is video playback is perfect, it's just the XBMC UI.

I ran in debug and verified nothing odd was happening to the refresh rates, it's locked at 60hz in both windowed and fullscreen. I played with the compiz settings (fullscreen redirect, etc.) to no avail. I even decided to go ahead and change over to the xbmc unstable ppa from stable and all is still fine except the jittery UI persists.

Any ideas? Thanks!
Did you try in unity2d? You can select it as the session on the login screen(lightdm)
Completely disable compiz and try again.
MidnightWatcher Wrote:Completely disable compiz and try again.

I'm sure this will work, but obviously I'd like to keep Compiz and Unity3D enabled... there must be some workaround I haven't thought of yet.
binaryjay Wrote:I'm sure this will work, but obviously I'd like to keep Compiz and Unity3D enabled
Why? Are you running XBMC on a desktop computer rather than a HTPC?

You could make a simple shell script to disable compiz, run XBMC, then start compiz back up, maybe? Something like

Code:
#!/bin/bash
metacity --replace
sleep 2
xbmc
compiz-gtk --replace

That might work.
binaryjay Wrote:I'm sure this will work, but obviously I'd like to keep Compiz and Unity3D enabled... there must be some workaround I haven't thought of yet.

have a look at this

http://wiki.xbmc.org/index.php?title=XBM..._with_XBMC
binaryjay Wrote:I'm sure this will work, but obviously I'd like to keep Compiz and Unity3D enabled... there must be some workaround I haven't thought of yet.
There is no workaround to having both running at the same time. If you must have Compiz and Unity3D working the script idea is about your only recourse to having things be somewhat seamless.
I've found that disabling composite and running Unity2D is the only thing that works to get both a smooth XBMC UI *and* tear-free video playback.

Running composite enabled and Unity2D nets a smooth UI but tearing video playback.

Running composite enabled and regular Unity nets jittery UI and tear-free video so long as unredirect full screen is enabled and all of the other usual vsync fussing about.

Yep, seems like you just can't win. The jittery UI is much more bearable than the tearing but both bother me enough that I am just leaving composite disabled and Unity2D since 95% of that machines use is XBMC anyway. The weird thing is that with Ubuntu 11.04, I had Composite Enabled, Unity 3D and XBMC all working fine in harmony without any UI or tearing issues... so I don't know what the heck happened or is different now.
Check the first workaround in http://forum.xbmc.org/showthread.php?tid=98108
Performance should be identical to not using compiz at all, at least when XBMC is fullscreen.
bobo1on1 Wrote:Check the first workaround in http://forum.xbmc.org/showthread.php?tid=98108
Performance should be identical to not using compiz at all, at least when XBMC is fullscreen.

Yep, that option is checked and it makes video playback not tear but the UI still jitters funnily and is not smooth for example when scrolling the main menu. Funny thing is, when running XBMC in a window it is smooth again but as soon as it goes full screen the jitteryness returns. No amount of mucking about with compiz settings has made it smooth without composite completely disabled.
The behavior hasn't changed through a few nvidia driver updates, compiz updates, kernel updates and many nightlies. I'm surprised I'm the only person with this problem - but it is very... odd.

Everything works fine in Unity2D (no tearing video and smooth XBMC ui) so it's not a big deal, well except for the fact that lately it seems like xbmc itself wants to randomly crash more running in unity2d than 3d.
I have a similar problem that is likely to be related. Using xbmc on either my desktop or my dedicated HTPC, both with VDPAU but with the fancy UI stuff all turned off (I'm using xfce and have composite explicitly disabled), the UI is smooth as silk when I first load xbmc, but after playing a single video the UI becomes sluggish, maybe updating 8-10 times per second.

Quitting xbmc and reloading it resolves the issue. If I'm using windowed mode on my desktop maximized to one Xinerama screen, unmaximizing and then remaximizing while playing the video seems to correlate with the UI being smooth after subsequently stopping the video, though doing this in the UI after stopping the video seems to have no effect.

Ubuntu 11.10
Either fullscreen (HTPC) or windowed (desktop)
I tried running XBMC in Unity (not 2D) again recently and to my surprise the problem from my OP is solved without me changing any configuration. I guess I have to thank somebody out there who has changed something that made this go away.