Kodi Community Forum

Full Version: Video speeds up depending on audio format!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've dug out a very old system from the loft to use in another room (althon 3000xp & nvidia fx 5500 on a km 400 pro MB Huh)

Its running ubuntu 10.10 with the last supported drivers from nvidia (173.14.31).& a nightly build compiled today (01/11/11).

Playing a video with dolby 5.1 or ac3 or aac is a rock solid 25fps as it should be. Playing a video with mpeg2 audio is anywhere between 30 & 45fps!

Have tried all vertical blank options in xbmc & the graphics driver panel aswell. compiled xbmc without vdpau because the fx 5500 doesn't support it.

Music mp3's etc.. play fine (no speed up)

Audio options in xbmc are set to: analog,2.0,boost downmix & device is Defaults(alsa).

Output in ubuntu is set to: analog stereo output
audio HW:AC 97 Audio

any help would be great....
The problem is that the videos are in a samplerate that your soundcard doesn't support, try setting the audio device to "plug:default" in xbmc.
Just tried plug:default in xbmc & it's added a few fps! (peaked now at 48fps)

looking at the debug log i get.
14:54:20 T:2899569520 DEBUG: CALSADirectSound::Initialize - frame count:512, packet count:16, buffer size:8192
14:54:20 T:2899569520 DEBUG: CALSADirectSound::Initialize - Channels: 2 - SampleRate: 48000 - SampleBit: 16 - Resample false - IsMusic false - IsPassthrough false - audioDevice: plug:default
14:54:20 T:2899569520 DEBUG: CDVDPlayerAudio:: synctype set to 0: clock feedback
14:54:20 T:2899569520 ERROR: GetDelay - snd_pcm_delay, alsa error: -5 - Input/output error
14:54:20 T:2899569520 DEBUG: CDVDPlayerAudio:: Discontinuity - was:698000759.657333, should be:697560000.333333, error:-440759.324000

can post debug if needed
Update: adding.

doesn't work either

pressing "O" still tells me the sample rate is 48000khz
Please turn on debug logging in XBMC and post a full debug log.
Pastebin as requested http://pastebin.com/XBZX9cLL
It looks like you have the deinterlacer on, which doubles the fps, try turning it off or use a deinterlace method that doesn't double fps.
Thanks bobo1on1, spot on the money!!!! I Hate uk tv standards why cant we have progressive instead!

Thanks again, 25fps all sorted