Kodi Community Forum

Full Version: 2 audio cards in LIVE
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I have the following problem:
I have 2 sound cards in the PC, one embedded (INTEL HDA) and one in a PCI slot (C-Media CMI-8768).
I want to use the CMedia card.

But sometimes during the boot XBMC-LIVE picks the Intel card.
(I can check this because if I plug a headphone in the Intel plug there is sound, and no sound in the C-Media card)

So I have to reboot in order to have the system to pick the correct sound card.

Is there a way to force the system to pick always the C-Media card?

Code:
[email protected]:~$ dmesg | grep "Intel"
[    0.000000]   Intel GenuineIntel
[    0.004235] Performance Events: Core2 events, Intel PMU driver.
[    0.077417] CPU0: Intel(R) Core(TM)2 CPU          4300  @ 1.80GHz stepping 02
[    0.164079] CPU1: Intel(R) Core(TM)2 CPU          4300  @ 1.80GHz stepping 02
[   13.083788] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[   13.083844] HDA Intel 0000:00:1b.0: irq 28 for MSI/MSI-X
[   13.083872] HDA Intel 0000:00:1b.0: setting latency timer to 64
[email protected]:~$ dmesg | grep "C-Media"
[   13.123550] C-Media PCI 0000:0a:0a.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[email protected]:~$

XBMC LIVE 10.1
Intel Core 2 - 1GB
NVidia Graphics Card
there is a way in ALSA to force a card to be assigned a specific number. but i have forgotten how.

or, can you disable the intel one in the BIOS?

helpful eh!
Hi
If the sound device is the HDMI one on the nvidia video
You can change the index alsa uses for your install cards
google alsa-base.conf for more info or check here
http://alsa.opensrc.org/MultipleCards

type in at a terminal window
less /proc/asound/modules
to find out the correct sound card naming and order Wink
(hit q to exit)

You can also blacklist any sound devices you dont want the system to use

type in
sudo nano /etc/modprobe.d/blacklist.conf
then at the very bottom of the list type in
blacklist then the name of the device you got when you typed in less /proc/asound/modules
on my system to kill the hdmi sound device it was
blacklist snd_hda_intel

Wozza
Wozza_au Wrote:Hi
If the sound device is the HDMI one on the nvidia video
You can change the index alsa uses for your install cards
google alsa-base.conf for more info or check here
http://alsa.opensrc.org/MultipleCards

type in at a terminal window
less /proc/asound/modules
to find out the correct sound card naming and order Wink
(hit q to exit)

You can also blacklist any sound devices you dont want the system to use

type in
sudo nano /etc/modprobe.d/blacklist.conf
then at the very bottom of the list type in
blacklist then the name of the device you got when you typed in less /proc/asound/modules
on my system to kill the hdmi sound device it was
blacklist snd_hda_intel

Wozza

Excellent tip.
Will try later and get back with the result.

Thanks again.