Kodi Community Forum

Full Version: Xbmc + Tvheadend + USB dvb elgato eye tv
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, im tryng to use a DVB Stick-elgato Eye TV with XBMC, but in TVHeadend dont result the DVB hardware Sad
No TV adapter.
The usb dvb is correctly connected and this is the result of LSUSB:

Bus 002 Device 002: ID 0cf3:3002 Atheros Communications, Inc.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0fd9:002c
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If i try:

dmesg

after:

sudo modprobe dvb-usb-dib0700

this is the result:

[ 12.085262] domain 1: span 0,2 level MC
[ 12.085268] groups: 0,2 (cpu_power = 1178)
[ 12.085276] domain 2: span 0-3 level CPU
[ 12.085282] groups: 0,2 (cpu_power = 1178) 1,3 (cpu_power = 1178)
[ 12.085295] CPU3 attaching sched-domain:
[ 12.085300] domain 0: span 1,3 level SIBLING
[ 12.085305] groups: 3 (cpu_power = 589) 1 (cpu_power = 589)
[ 12.085317] domain 1: span 1,3 level MC
[ 12.085322] groups: 1,3 (cpu_power = 1178)
[ 12.085331] domain 2: span 0-3 level CPU
[ 12.085336] groups: 1,3 (cpu_power = 1178) 0,2 (cpu_power = 1178)
[ 17.084036] eth0: no IPv6 routers present
[ 66.732827] dib0700: loaded with support for 13 different device-types
[ 66.732938] usbcore: registered new interface driver dvb_usb_dib0700


I have already put the firmware in /lib/firmware and added the user HTS on Group Video with:

sudo wget http://kernellabs.com/firmware/dib0700/d...00-1.20.fw
and:
sudo adduser hts video

Any idea Why Tvheadend dont see my Tv adapter?

Please I need Help.. Thank Mau. By

P.s. dont appear /dev/dvb

I forget im using XBC live installed on HD and using console via Putty in ssh.
Any idea? Smile
Hi . .!

Some news . . i have find more instrunctions in :http://webcache.googleusercontent.com/se...ent=ubuntu

Where is explained the way for work Elgato dvb eye tv v2.
But for me is still not working No Angry
I tried the v4l-dvb-as102 driver.

Any help Please?
if there is nothing in /dev/dvb then the stick might not be being registered as a dvb device.
The lsusb you posted doesn't mention anything about what sort of device it is. When i plug my (different brand) dvb-t usb stick in it says something like "found dvb-t device".

What modules are loaded? Do a 'lsmod'
Off the top of my head i had dvb-core, dvb-usb and dvb-af9015 (the chipset of my stick)
Thanks bryan!
This is my lsmod result:

dvb_usb_dib0700 114669 0
dib7000p 39109 1 dvb_usb_dib0700
dib0090 33392 1 dvb_usb_dib0700
dib7000m 23415 1 dvb_usb_dib0700
dib0070 18434 1 dvb_usb_dib0700
dvb_usb 24444 1 dvb_usb_dib0700
dib8000 43019 1 dvb_usb_dib0700
dvb_core 110616 3 dib7000p,dvb_usb,dib8000
dib3000mc 23392 1 dvb_usb_dib0700
rc_core 26963 9 rc_dib0700_rc5,ir_lirc_codec,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,ir_nec_decoder,dvb_usb_dib0700,dvb_usb
dibx000_common 14574 5 dvb_usb_dib0700,dib7000p,dib7000m,dib8000,dib3000mc
Don't thank me, I'm out of ideas now.

That's all I did to get mine working, bunged the .fw in /lib/firmware then restart and insert dongle.

I'd wait for other suggestions before trying but it might be worth booting live Ubuntu 11.10 and seeing if it works with the newer kernel 3. You mention you are on live so I assume you have kernel 2.6.xx at the moment.
At least that's non-destructive.

There's definitely nothing in /dev/dvb? Mine didn't show up in tvh due to permissions at one point.

What does the following return:
sudo find / -name dvb
Hi again Bryan, this is the return of sudo find / -name dvb :

Quote:/dev/dvb
/sys/devices/pci0000:00/0000:00:04.1/usb1/1-2/dvb
/sys/class/dvb
/home/mauro/v4l-dvb-as102-2/linux/include/linux/dvb
/home/mauro/v4l-dvb-as102-2/linux/drivers/media/dvb
/home/mauro/v4l-dvb-as102-2/linux/Documentation/DocBook/dvb
/home/mauro/v4l-dvb-as102-2/linux/Documentation/dvb
/home/mauro/v4l-dvb-as102-2/.hg/store/data/linux/include/linux/dvb
/home/mauro/v4l-dvb-as102-2/.hg/store/data/linux/include/dvb
/home/mauro/v4l-dvb-as102-2/.hg/store/data/linux/linux/drivers/media/dvb
/home/mauro/v4l-dvb-as102-2/.hg/store/data/linux/_documentation/video4linux/dvb
/home/mauro/v4l-dvb-as102-2/.hg/store/data/linux/_documentation/dvb
/home/mauro/v4l-dvb-as102-2/.hg/store/data/linux/_documentation/_doc_book/dvb
/home/mauro/v4l-dvb-as102-2/.hg/store/data/linux/drivers/media/dvb
/home/mauro/v4l-dvb-as102-2/.hg/store/data/staging-specs/dvb
/usr/include/linux/dvb
/usr/src/linux-headers-2.6.32-29/include/linux/dvb

The curios thing is in:
Quote:http://webcache.googleusercontent.com/se...ent=ubuntu
]

(from here to down i have tried with my ubuntu desktop 11.10 because in xbmc the command "hg clone . . . not working" and i think if work in desktop maybe will work in xbmc ) Wink


Some people says your elgato dvb dtt v2 is working with v4l-dvb-as102 downloadable with:

Quote:hg clone http://kernellabs.com/hg/~dheitmueller/v4l-dvb-as102-2
cd v4l-dvb-as102-2
make
make install
reboot


this one (with final -2) have already inside the changes in :

Quote:dvb-usb-as102.h:
/* EyeTV DTT deluxe */
#define EYETV_DTT_NAME “EyeTV DTT deluxe”
#define EYETV_DTT_VID 0x0fd9
#define EYETV_DTT_PID 0x002c

Quote:dvb-usb-as102.c:
static struct usb_device_id as102_usb_id_table[] = {
{ USB_DEVICE(AS102_USB_DEVICE_VENDOR_ID, AS102_USB_DEVICE_PID_0001) },
{ USB_DEVICE(PCTV_74E_USB_VID, PCTV_74E_USB_PID) },
{ USB_DEVICE(EYETV_DTT_VID, EYETV_DTT_PID) },
{ } /* Terminating entry */
};

Personal verified.
But when i do:

Quote:cd v4l-dvb-as102-2
make

I see return this error:

Quote:[email protected]:~/v4l-dvb-as102-2$ make
make -C /home/mauro/v4l-dvb-as102-2/v4l
make[1]: ingresso nella directory "/home/mauro/v4l-dvb-as102-2/v4l"
No version yet, using 3.0.0-13-generic
make[1]: uscita dalla directory "/home/mauro/v4l-dvb-as102-2/v4l"
make[1]: ingresso nella directory "/home/mauro/v4l-dvb-as102-2/v4l"
scripts/make_makefile.pl
Updating/Creating .config
Preparing to compile for kernel version 3.0.0

***WARNING:*** You do not have the full kernel sources installed.
This does not prevent you from building the v4l-dvb tree if you have the
kernel headers, but the full kernel source may be required in order to use
make menuconfig / xconfig / qconfig.

If you are experiencing problems building the v4l-dvb tree, please try
building against a vanilla kernel before reporting a bug.

Vanilla kernels are available at http://kernel.org.
On most distros, this will compile a newly downloaded kernel:

cp /boot/config-`uname -r` <your kernel dir>/.config
cd <your kernel dir>
make all modules_install install

Please see your distro's web site for instructions to build a new kernel.

Created default (all yes) .config file
./scripts/make_myconfig.pl
make[1]: uscita dalla directory "/home/mauro/v4l-dvb-as102-2/v4l"
make[1]: ingresso nella directory "/home/mauro/v4l-dvb-as102-2/v4l"
perl scripts/make_config_compat.pl /lib/modules/3.0.0-13-generic/build ./.myconfig ./config-compat.h
creating symbolic links...
ln -sf . oss
make -C firmware prep
make[2]: Entering directory `/home/mauro/v4l-dvb-as102-2/v4l/firmware'
make[2]: Leaving directory `/home/mauro/v4l-dvb-as102-2/v4l/firmware'
make -C firmware
make[2]: Entering directory `/home/mauro/v4l-dvb-as102-2/v4l/firmware'
CC ihex2fw
Generating vicam/firmware.fw
Generating dabusb/firmware.fw
Generating dabusb/bitstream.bin
Generating ttusb-budget/dspbootcode.bin
Generating cpia2/stv0672_vp4.bin
Generating av7110/bootcode.bin
make[2]: Leaving directory `/home/mauro/v4l-dvb-as102-2/v4l/firmware'
Kernel build directory is /lib/modules/3.0.0-13-generic/build
make -C /lib/modules/3.0.0-13-generic/build SUBDIRS=/home/mauro/v4l-dvb-as102-2/v4l CFLAGS="-I../linux/include -D__KERNEL__ -I/include -DEXPORT_SYMTAB" modules
make[2]: Entering directory `/usr/src/linux-headers-3.0.0-13-generic'
CC [M] /home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.o
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c: In function 'load_all_firmwares':
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c:314:2: error: implicit declaration of function 'kzalloc' [-Werror=implicit-function-declaration]
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c:314:13: warning: assignment makes pointer from integer without a cast [enabled by default]
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c:365:21: warning: assignment makes pointer from integer without a cast [enabled by default]
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c: In function 'generic_set_freq':
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c:944:18: error: 'T_DIGITAL_TV' undeclared (first use in this function)
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c:944:18: note: each undeclared identifier is reported only once for each function it appears in
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c: In function 'xc2028_set_params':
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c:1132:5: error: 'T_DIGITAL_TV' undeclared (first use in this function)
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c: In function 'xc2028_attach':
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c:1269:13: warning: assignment makes pointer from integer without a cast [enabled by default]
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c: In function 'xc2028_set_params':
/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.c:1133:1: warning: control reaches end of non-void function [-Wreturn-type]
cc1: some warnings being treated as errors

make[3]: *** [/home/mauro/v4l-dvb-as102-2/v4l/tuner-xc2028.o] Errore 1
make[2]: *** [_module_/home/mauro/v4l-dvb-as102-2/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-3.0.0-13-generic'
make[1]: *** [default] Errore 2
make[1]: uscita dalla directory "/home/mauro/v4l-dvb-as102-2/v4l"
make: *** [all] Errore 2
[email protected]:~/v4l-dvb-as102-2$


If i ignore the error and go with:
Quote:sudo make install

Quote:[email protected]:~/v4l-dvb-as102-2$ sudo make install
[sudo] password for mauro:
make -C /home/mauro/v4l-dvb-as102-2/v4l install
make[1]: ingresso nella directory "/home/mauro/v4l-dvb-as102-2/v4l"
-e
Removing obsolete files from /lib/modules/3.0.0-13-generic/kernel/drivers/media/video:

-e
Removing obsolete files from /lib/modules/3.0.0-13-generic/kernel/drivers/media/dvb/cinergyT2:

-e
Removing obsolete files from /lib/modules/3.0.0-13-generic/kernel/drivers/media/common:

-e
Removing obsolete files from /lib/modules/3.0.0-13-generic/kernel/drivers/media/dvb/frontends:

Installing kernel modules under /lib/modules/3.0.0-13-generic/kernel/drivers/media/:
/sbin/depmod -a 3.0.0-13-generic
make -C firmware install
make[2]: Entering directory `/home/mauro/v4l-dvb-as102-2/v4l/firmware'
Installing firmwares at /lib/firmware: vicam/firmware.fw dabusb/firmware.fw dabusb/bitstream.bin ttusb-budget/dspbootcode.bin cpia2/stv0672_vp4.bin av7110/bootcode.bin
make[2]: Leaving directory `/home/mauro/v4l-dvb-as102-2/v4l/firmware'
make[1]: uscita dalla directory "/home/mauro/v4l-dvb-as102-2/v4l"
[email protected]:~/v4l-dvb-as102-2$

But after Reboot the usb stick not recognized, and i dont know why.
Sorry for this too long PostConfused