Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

i already read that at the moment the XBMC Boblight Addon isn't working on Raspberry Pi.

I would really like to help but i dont know where to start and what to do.

I would really appreciate boblight on raspberry pi.

What is the matter? Is it the omxplayer which can't be "read" from the addon? How about the boblight without the addon via the x11 way? Does this also not work?

Thanks in advance


(2012-10-25, 13:48)Memphiz Wrote: [ -> ]
(2012-10-25, 03:34)wolfgr Wrote: [ -> ]hi guys,i tried to update to latest nightly and when i try to download the libs after starting boblight for the first time,the download window stucks and doesnt do anything.Even that when i restart xbmc the lights flashes ok and ''boblight connected'' popup ok.In reality when video playback boblight isnt working at all.I think something is wrong with the libs ,they didnt download or installed right....can i do it manually?Am i the only one with that problem?If there is no solution how can i fully uninstall and go back to a clean eden?

edit:i use win7.

If the lights are flashing on startup - everything is fine with the lib.

thnx for ur answer,i believe so too so what i did is to format (i was going too anyway) and i fresh install eden and boblight works fine again.When i find some free time i will test my boblight with froyo in more detail to see if i can find what s wrong.

i cant find if someone asked before but what about boblight and android?Tv boxes with android start to become popular and i am thinking (in the very future) to replace my htpc with an android tvbox.

Sry again for writing my post in German.

I wanted to write Memphiz a private massage and i saw that he is from Germany.
So i wrote him a private massage in German. But he canĀ“t recieve private massages because his limit is reached and he doesnt want to get any new private massages, so i just copied the text i wrote in here.

Sorry guys, wont happen again Big Grin
Hey guys,

i got my arduino ready and setup with this http://learn.adafruit.com/adalight-diy-a...e-software. Now i found this guide http://james-lloyd.com/ambilight-project/ could i do it like this or do i need something to know?

I also got my config from here http://sanya.tarhelyszolgaltato.eu. Do i need to install the XBMC boblight addon after i all do this?

Is there any way to get this working with XBMC on the Raspberry Pi (XBian)?

I compiled boblight and everything with succes, and the static lighting mode in the XBMC plugin works OK.
However, in movie mode it only flashes every now and then.

I read that it's because the usual frame capture method in XBMC doesn't work on the Pi. But is there any workaround?
Is there a way to solve this Problem?

(2012-07-20, 12:53)F0x123 Wrote: [ -> ]
(2012-03-30, 10:54)MrHenky Wrote: [ -> ]
(2012-03-29, 16:18)bobo1on1 Wrote: [ -> ]I've seen that before, apparently if you use a different program first to open the com port, and then open it with boblightd it works ok, I suspect it's a problem in cygwin.

You were totally right. I've first used Lightpack to open the com-port. When I started boblight it said, that the port is in use, which makes sense. Closing lightpack and starting boblight again and it worked. Also XBMC is successfully connecting. Since I'm working remote on my computer, I can't tell if the lights were on but hey... it finally seems to be working.

Did you solve this problem? I got the same issue. I have to first open the port via atmowin or the Arduino IDE software and then bobligh works. Otherwise I get this error:

C:\Users\htpc\Downloads\boblight\boblightd>boblightd.exe -c boblight.conf
ERROR: unable to make directory /home/htpc/.boblight/:
No such file or directory
(PrintFlags)                    starting boblightd -c boblight.conf
(CConfig::LoadConfigFromFile)   opening boblight.conf
(CConfig::CheckConfig)          checking config lines
(CConfig::CheckConfig)          config lines valid
(CConfig::BuildConfig)          building config
(CConfig::BuildConfig)          built config successfully
(main)                          starting devices
(CClientsHandler::Process)      opening listening socket on
(CDevice::Process)              ambilight: starting with output "/dev/com3"
(CDevice::Process)              ambilight: setting up
(CDeviceRS232::OpenSerialPort)  ERROR: ambilight: /dev/com3: tcgetattr() Invalid
(CDeviceRS232::OpenSerialPort)  ambilight: /dev/com3 had a non fatal error, it m
ight still work, continuing

What settings in boblight addon gives you best result with ws2801?

I am using atm:
<setting id="bobdisable" value="false" />
<setting id="hostip" value="" />
<setting id="hostport" value="19333" />
<setting id="movie_autospeed" value="0.000000" />
<setting id="movie_interpolation" value="false" />
<setting id="movie_preset" value="0" />
<setting id="movie_saturation" value="4.999998" />
<setting id="movie_speed" value="90.000000" />
<setting id="movie_threshold" value="20.000000" />
<setting id="movie_value" value="4.999998" />
<setting id="musicvideo_autospeed" value="0.000000" />
<setting id="musicvideo_interpolation" value="false" />
<setting id="musicvideo_preset" value="0" />
<setting id="musicvideo_saturation" value="4.999998" />
<setting id="musicvideo_speed" value="100.000000" />
<setting id="musicvideo_threshold" value="10.000000" />
<setting id="musicvideo_value" value="4.999998" />
<setting id="networkaccess" value="false" />
<setting id="other_static_bg" value="false" />
<setting id="other_static_blue" value="225.000000" />
<setting id="other_static_green" value="166.000000" />
<setting id="other_static_red" value="196.000000" />
<setting id="overwrite_cat" value="false" />
<setting id="overwrite_cat_val" value="0" />
<setting id="sep1" value="" />
<setting id="sep2" value="" />
Does anyone have good settings for the color values in boblight.conf when using ws2801 led strings? The colors is to powerful and to much red. I tried to mess around with the settings but it is hard to get it right. And Google is not my friend today.
A few more questions. Is there any good solution for movies that have black bars on either side?
I don't want the lights to be turned on when watching LiveTV. Is it either possible to detect this and don't enable the lights or a easier way with a true one-click on/off button? Opening the settings every time is not easy enough.
After many hours of trying to calibrate the colors i kind of gave up. Thought the problem was with boblight and thought i should try Lightpack instead. But before i did that i tried boblight-X11 instead of this addon.
Wow! What a difference in colors. Now everything looked almost perfect, just a small tweak and it looked amazing.

Why is there such a difference between the colors in the XBMC addon and boblight-X11? And is there any way to get the same colors in the XBMC addon?
The pros with XBMC addons is that it only turns on when playing a movie(hopefully it will be possible to disable with LiveTV some day) and that the addon don't react on subtitles.
Cons, totally wrong colors in many places, dark scenes often get all red.

boblight-X11 has amazing colors, but the lights are on everywhere, and don't handle subtitles good. A get white blinking leds at every subtitle.

Am i doing something wrong or is it just the way it is? Since both use boblight daemon i don't understand how it could be such big difference.

I can get the same colors with boblight-X11 and boblight addon. Post your boblightd.conf to pastebin.com and put the link in here...
Here is my config.

Am i the only one with this problem? Since both the XBMC addon and boblight-X11 is clients to the server boblightd i don't understand what could be wrong. Is the XBMC addon doing calculations in a different way?
nope but imo your settings in the conf file are way off diddled. Ou know that gamma is non linear? Something like that can lead to differences between x11 and addon. Btw addon gets the color values directly from the rendered video. I would reset the gamma and adjust values in the conf and start from scratch if i was you. Only small changes at a time. Try a good test movie with homogen colors (superbad has a nice intro with fullcolor screens at the beginning - ideally for calibration).
I've already tried that, put down almost a whole day when i first installed the lights, changed everything in small steps. And not getting it right after a few hours made me look at other solutions to find out where the problems was. That's when i tried boblight-X11 and it looked good almost instant.

I don't know anything about programming, but how can the settings in the file make a difference between XBMC addon and boblight-X11? Both talk with the boblightd service and use the same values?
Isn't the default value for everything 1, so 1.2 i gamma cant be that extreme?

I will reset the settings to 1 for everything and post pictures. Maybe i could remove the adjust and gamma setting, that would put them to default?
I don't have a good test movie, but that don't matter much, because the differences between XBMC addon and boblight-X11 is so big. It is not hard to see that there is a problem somewhere. And since there is other problems with boblight-X11 i really would like to use the XBMC addon.

If anyone else uses LEDs with ws2801s, please post your color settings. It can't be that big differences between different setups.