Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
1. Will the performance of boblight be better with the frodo build of xbmc?

2. Will setting up the boblight deamon on a separate Linux server increase the htpc performance and reduce the cpu load?

I used openelec with boblight and there 1080p content is running without any framedrops, but unfortunately AMD GPUs are causing LED flickering Sad
Is it possible to turn off the notifications on startup? Also how about not having the colorswirl thing at startup too? They both annoy me greatly!

Cheers.
(2013-01-13, 15:38)smiffy1989 Wrote: [ -> ]Is it possible to turn off the notifications on startup? Also how about not having the colorswirl thing at startup too? They both annoy me greatly!

Cheers.

That would be great.

Since the newer Windwos versions somehow cant access com3 I have to start the old boblight1.3 first so right now I get:
1 swirl from boblight
another swirl from boblight
and a swril from XBMC boblight

Also maybe a delay for the connection check. I get the "not connected" while still loading the skin.
(2013-01-13, 15:38)smiffy1989 Wrote: [ -> ]Is it possible to turn off the notifications on startup? Also how about not having the colorswirl thing at startup too? They both annoy me greatly!

Cheers.

I deleted the sound files that play with the notification as they're too loud and annoy me too. I still get the pop upbbut I can deal with that.
Yeah i hear ya. Will be optional in next version (initial flash + notifications).
(2013-01-15, 12:53)Memphiz Wrote: [ -> ]Yeah i hear ya. Will be optional in next version (initial flash + notifications).

Cool, can't wait Wink
(2013-01-11, 11:50)F0x123 Wrote: [ -> ]1. Will the performance of boblight be better with the frodo build of xbmc?

2. Will setting up the boblight deamon on a separate Linux server increase the htpc performance and reduce the cpu load?

I used openelec with boblight and there 1080p content is running without any framedrops, but unfortunately AMD GPUs are causing LED flickering Sad

Anyone who can help me with my questions? Huh
1. no
2. slightly
@Memphiz,

Thanks for the update, going to test it straight away Wink
(2012-12-30, 22:49)BurningSky Wrote: [ -> ]Hello,
I've tried to compile boblight by following the HowTo in the first post, but it stuck at the configure process. That's the error message I got:
Code:
configure: error: Missing a required header, please install it
I installed all dependencies as described here: http://code.google.com/p/boblight/wiki/Compiling

My OS is Ubuntu 12.10 x86 minimal with XBMC Frodo Nightly.

try:

sudo apt-get install libusb-1.0-0-dev

Thats the one I was missing as well after following the instructions

*edit Oops saw you allready figured that out Wink
Could somebody give me a link to the newest version of boblight compiled for windows?
(2013-01-17, 13:47)timmaeh Wrote: [ -> ]Could somebody give me a link to the newest version of boblight compiled for windows?

Uploaded the latest version here:
http://forum.xbmc.org/showthread.php?tid=151559
Thanks for that!
(2012-05-02, 22:57)amet Wrote: [ -> ]It can be run on OSX as well, here is the boblightd compiled for osx

run it: boblightd -c boblight.conf

boblight.conf , /dev/tty.usbmodem621 will need tweaking depending on what your USB ports look like

You are my hero amet!
I put it in StartupItems and added the required files to make it start as a service.

*does the happy dance*
(2013-01-13, 17:21)TeKo Wrote: [ -> ]
(2013-01-13, 15:38)smiffy1989 Wrote: [ -> ]Is it possible to turn off the notifications on startup? Also how about not having the colorswirl thing at startup too? They both annoy me greatly!

Cheers.

That would be great.

Since the newer Windwos versions somehow cant access com3 I have to start the old boblight1.3 first so right now I get:
1 swirl from boblight
another swirl from boblight
and a swril from XBMC boblight

Also maybe a delay for the connection check. I get the "not connected" while still loading the skin.

I'm not entirely sure why but I get the RGB flash from my arduino, then a failed to connect notification, then the colour swirl and finally the connected notification!

When I get some time I'm going to change the code on the arduino not to do the RGB flash, then with the changes from Memphiz I will just get a nice fade into my static blue Smile

(2013-01-15, 12:53)Memphiz Wrote: [ -> ]Yeah i hear ya. Will be optional in next version (initial flash + notifications).

Awesome Smile