Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
A bit off topic but I was wondering : Is there any official Boblight forum ? Not the addon but boblightd and other client like v4l.
Where we could discuss about new features/improvements/bugs that are not related to the xbmc addon.
Hi everyone.

A few days ago I finally built myself an ambilight clone using boblight, Raspberry Pi and WS2801 pixels (50). Everything is working great except for some random flashes (sometimes white sometimes colored). At first I thought that I had power problems so I replaced PSU, flashes didn't go away. Next I was fiddling with "rate" parameter in boblight configuration, no luck either.

Then I accidentally rewind a section of movie with lots of flashes and flashes repeated in the exact pattern as the first time. So I did it again (videotaped it) and again. The pattern of flashes was exactly the same every time. So I checked another section of movie with flashes and they were repeatable too.

This ruled out problems with Raspberry Pi (or Boblight configuration) and left out only my XBMC with Boblight add-on.

So I started experimenting with add-on. If I use "Slow" preset there are no flashes. If I use "Fast" preset, flashes are frequent. Currently I use custom settings: speed=75, autospeed=0, saturation=1, value=0.9, treshold=16 which produce some flashes but not so often.

I'm using XBMC Frodo (12.2) on Mac mini (2010) with OS X 10.6.8 (w/ all updates). Both mini and RPi are connected to wired 100Mbps network (using fixed IPs). Movies are stored on a NAS drive using SMB shares. DB resides in a MySQL database on NAS. Vertical blank sync is enabled only during video playback.

Does anyone have similar problems? I can post my recordings to YouTube if someone cannot understand what kind of flashes I'm talking about.
Video would probably help.

I have no clue, but Im using Slow, not Mac, no RPi so I probably cant help anyways Wink
Hello again, shcumi2004 , Teko and company.

Yesterday I tested the boblight.conf where I have modified the variable vscan increasing this zone, but I have not luck with this.

The same movie of The hobbit( 40gb BDremux m2ts), doesnt't flash on the leds . Then I think that all the movies that present this problem, I will have to reencode.
But anybody know how to reencode? the exact parameters, and what software to use, pleaseHuh?

One friend , give me the same movie, in other two versions.

One with 2,5GB with 1920x800 , and another with 13.7Gb and 1920x1014 , and both movies of The hobbit works the leds.

Any answer?

And another and last question:
How I can reduce the lag of the leds with the imageHuh Only with the speed portHuh
Thanks again.

There is a white flash 3s into the clip and another colored at 8s.

Some movies (videos) are more prone to this kind of flashes and they mostly appear in dark scenes.

While I was playing with settings I figured out that custom setting of speed=40 virtually eliminates flashes, while speed=100 produces so many flashes that it hurts. Smile
I also did a packet capture on the network just to see what is going on between XBMC and RPi talking to each other. And flashes are present in the data sent from XBMC. So it is definitely something wrong with XBMC plugin (XBMC lights a pixel it shouldn't).
I also tried plugin on another mac (macbook pro w/ 10.8.3) with exactly the same flashes.
Increase the black threshhold in addon settings might help
Hi Memphiz, I hoped you would reply. Smile

I have tried treshold as high as 32 (after that it starts to look weird with quite dark passages) without any success.
The only thing that reduces flashes is speed.

Flashes happen on multiple sources: m4v, mp4, mkv, avi and multicast UDP stream (live TV). And they do happen on bright scenes too, they are just less annoying there, though.
Update: It appears that Windows plugin does not have flashing issues. Only mac plugin does. Unfortunately I do not have Linux machine to test.
its not a boblight issue by default. I run it on osx, ios, linux and windows and don't see any flashes (doing this for a year now...)
(2013-05-29, 23:40)Memphiz Wrote: [ -> ]its not a boblight issue by default.

I'm sorry, I didn't mean that it is a boblight plugin issue by default (I know it may be a decoder, renderer issue, ...). I just wanted to say it is not a Raspberry Pi/boblightd issue.

Nevertheless I performed a "scientific" test. Big Grin I found a video (http://www.spacetelescope.org/static/arc...arth_l.m4v) which is "clean" but produces a lot of flashes. First I tested it with my son's notebook running Win7 w/ XBMC 12.2 and boblight w/ setting of fast. There were some flashes.
Then I run the same video on my mac mini (3 times with different plugin settings - fast, slow and "my" custom). As you can see from the video below there were no flashes with slow setting, barely 2 with custom and a lightning storm with fast setting. Smile Video is unedited except sound was removed.


There is a difference between windows and mac version though. Mac produces way more flashes than windows does at the same settings.
whats your hardware for boblightd and how is it connected.
Those flashes look like an electronic issue imo. Some overspeaking or something. Or a bad soldering somewhere.
Last time I got flashes I fixed it by adding a 1000µF bypass capacitor directly onto the led strip power wires.
It's Raspberry Pi model B rev.2 with WS2801 pixels attached directly to GPIO header. LEDs are powered by 3A PSU and RPi by independent 1A PSU. Ground lines on RPi and LEDs are connected (flashes occur also with just one PSU powering everything). Pixels are straight from Adafruit.

I will try the capacitor. Which end did you solder it on? Close to RPi or the other side or in-between?