Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
HI people.i want to rebuild my setup with digital led strip instead the plain rgb that i now have on my arduino mega.Is this http://www.adafruit.com/products/1376 the right one? i need 3 meters for my 50 inch tv,is there an online cheaper shop to ship here in Greece?
Check out aliexpress. As long as you get ws2801 you should be ok.
thank you, instead of ws2801 can i use ws2811 with adalight?
I think there is a modified version for 2811 but its better to get 2801, just to be sure.
I'm getting an error when i'm running sudo boblightd -f > /dev/null

The error is ERROR: Pibob: (CDeviceSPI::SetupDevice) ERROR: Pibob: Unable to open /dev/spidev0.0: No such file or directory
(CDevice:Tonguerocess) ERROR: Pibob: setting up failed, retrying in 10 seconds.

I had followed the excellent guide at http://pibob.nadnerb.co.uk/software.html.

I guessed it was wrong whit my sudo nano /etc/modprobe.d/raspi-blacklist.conf file. But i dont have that instead another file called fbdev-blacklist.conf which dont have spi-bcm2708 in it. So im really stuck right now so it would be appreciated alot to get some help whit this.

The error means that the SPI device isn't present on your OS.
What OS are you using?
I followed the same guide and it worked flawlessly.
Try using ls /dev/spi* and see what the output is.
Maybe for some reason the SPI device is named something else.
Thank you for the answear Smile

Im using Raspbmc.

The outcome when i typed ls /dev/spi* is "no such file or directory". So im guess the problem lays there, not having any SPI?

I did install evrything today so im guessing everything is the latest version.
The problem is that there is no SPI device.
This is strange as it should have been created unless a newer version of the modified Raspbmc was created lately not including this device.
This of course is highly unlikely.
just to be sure, I bought all the products... digital leds, power adapter, ardiuno uno, etc..
I followed this guide:

The parts on their way, and I don't have them Yet. but just to understand.

I have win7/8 32bit, xbmc 12.2
What I need to install?
I already installed:
1. Arduino IDE
2. Processing IDE
3. and ADALIGHT Zip ( https://github.com/adafruit/Adalight ) and moved the files to the documents folder as describe in the guide.
Those are good? or should I Ignore all those parts?

now, How I Use Boblight? Installing the addon from XBMC is all I Need? or something missing?
and last thing, If i will use this addon, there is option to make the leds work outside xbmc? like in Chrome? ( youtube )

Thank You!

I Found this:
but still, if someone make it clear what I need to install, what order, what config is important and what not? thanks
You only need the Arduino IDE once and Processing IDE not at all.

Just follow the tutorial and when the Adalight is working check the thread in my sig for boblight for Windows.
(2013-06-16, 19:40)Tickla Wrote: [ -> ]The outcome when i typed ls /dev/spi* is "no such file or directory". So im guess the problem lays there, not having any SPI?

You need to edit /etc/modprobe.d/raspi-blacklist.conf

sudo nano /etc/modprobe.d/raspi-blacklist.conf

and comment out

#blacklist spi-bcm2708

I want to try enable/disable boblight addon by remote button, but I don't know how. Someone did it? I used xbmc Frodo version and ubuntu 12.04.

Thanks in avance
This is the script I use in Openelec3.2 to start Boblight, launching it with irexec. The xbmc boblight addon needs to be enabled. The script starts boblightd and boblight-x11 so there is boblight in menus and visualisations, as well as in videos.

# cat .scripts/xbmc-boblightx11.sh
#Script to start stop boblight with irexec

if [ ! "$(pstree |grep -i boblight-X11)" ]


/bin/killall -q boblightd ;
/bin/killall -q boblight-X11 ;
export LD_LIBRARY_PATH=/storage/.xbmc/addons/service.multimedia.boblightd/lib
export DISPLAY=:0
/storage/.xbmc/addons/service.multimedia.boblightd/bin/boblightd -f -c /storage/.config/boblight.conf ;
/usr/bin/xbmc-send --host=localhost --port=9777 --action="PlayerControl(Stop)" ;
/bin/sleep 2 ;
/bin/killall -q xbmc.bin ;
/bin/sleep 3 ;
/storage/.xbmc/addons/service.multimedia.boblightd/bin/boblight-X11 -f -x -o speed=70 -o value=10 -o saturation=1.0 -o threshold=10


/bin/killall -q boblightd ;
/bin/killall -q boblight-X11 ;
/usr/bin/curl -v -H "Accept: application/json" -H "Content-type: application/json" -X POST -d '{"id":1,"jsonrpc":"2.0","method":"GUI.ShowNotification","params":{"title":"Boblight","message":"Disabled"}}' http://localhost:9191/jsonrpc ;

What are the addon settings for slow? I tried changing some stuff, but starting with everything at 0 its kinda hard.