Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The wiki is always a good place to start: http://wiki.xbmc.org/index.php?title=Lis..._functions
(2014-07-11, 14:49)wolfgr Wrote: [ -> ]
(2014-07-11, 02:29)teeedubb Wrote: [ -> ]
(2014-07-10, 20:50)wolfgr Wrote: [ -> ]guys is there a way to map a key from my windows pc remote,to enable/disable Boblight?or even to bring addon setings like b\B key from keyboard does.

You can start stop it with a remote or keyboard using a jsonrpc command, see
http://forum.xbmc.org/showthread.php?tid...pid1624387

See here for creating a toggle script to switch between on and off (its for audio but same principal)
http://forum.xbmc.org/showthread.php?tid...pid1750578

(2014-07-10, 22:10)spambus Wrote: [ -> ]since it is not possible to have lights during audio playback

would it be possible to create that when xbmc plays music, the boblight addon randomly changes colors to the beat of the music. or to some preset colors

What OS are you using? You can have bovlight during music playback with Linux via boblight-X11

thanx teeebub got it workin,thnx.A little offtopic question,what command like"RunScript" can i use to play a file from library,using a mapped remote button?Is there a list of commands somewhere?

Is that your equivalent of the boss button for watching porn?
Is there a maintained version of the boblightd for windows? I've recently moved from xbmcuntu to windows and boblight is the only thing that isn't working.

I've not been able to find any recent downloads for it (if it's because my google kung-fu is broken then I apologise)

Thanks

Gordon
(2014-07-14, 17:19)gcthompson Wrote: [ -> ]Is there a maintained version of the boblightd for windows? I've recently moved from xbmcuntu to windows and boblight is the only thing that isn't working.

I've not been able to find any recent downloads for it (if it's because my google kung-fu is broken then I apologise)

Thanks

Gordon
you could use use the native KickStarter LightPack app, Prismatik.
Thanks for the assistance. I found a working version of boblightd on this very forum:

http://forum.xbmc.org/showthread.php?tid=151559

I'll get my coat.
Can anyone advice me here.

I always used atmowin, but since I have a bigger TV, thus more LED I bought a new seduboard and need to use boblight.
But I can't get the colors right.

All LEDs work, but don't turn off when e.g it is dark, and colors don't match.
When watching avatar every led is blue. When watching a music video, the colors are mixed but do not resamble to colors on the videoclip.
Does they keymap solution still work under Gotham 13.1?
The addon itself is working, the lights are changing correctly but with "b" or "B" I can not bring up the settings.

XBMC.ActivateWindowAndFocus(MyPVR, 35,0, 14,0) is set by the keyboard.xml to start at the press of b but I commented that out. Now nothing happens when pressing "b" or "B".

This my ~/.xbmc/userdata/keymaps/script.xbmc.boblight.keymap.xml
PHP Code:
<keymap>
  <
fullscreenvideo>
    <
keyboard>
      <
b>Addon.OpenSettings(script.xbmc.boblight)</b> <!-- shortcut key b to boblight settings -->
      <
B>Addon.OpenSettings(script.xbmc.boblight)</B> <!-- shortcut key B to boblight settings -->
    </
keyboard>
  </
fullscreenvideo>
</
keymap
Any ideas?
(2014-08-09, 17:27)kiesel Wrote: [ -> ]Does they keymap solution still work under Gotham 13.1?
The addon itself is working, the lights are changing correctly but with "b" or "B" I can not bring up the settings.

XBMC.ActivateWindowAndFocus(MyPVR, 35,0, 14,0) is set by the keyboard.xml to start at the press of b but I commented that out. Now nothing happens when pressing "b" or "B".

This my ~/.xbmc/userdata/keymaps/script.xbmc.boblight.keymap.xml
PHP Code:
<keymap>
  <
fullscreenvideo>
    <
keyboard>
      <
b>Addon.OpenSettings(script.xbmc.boblight)</b> <!-- shortcut key b to boblight settings -->
      <
B>Addon.OpenSettings(script.xbmc.boblight)</B> <!-- shortcut key B to boblight settings -->
    </
keyboard>
  </
fullscreenvideo>
</
keymap
Any ideas?

Do you want to open the settings or toggle boblight on and off?
ive been trying for hours to resolve this but i keep running into this error
im openelec latest version. any idea i run into "LIBUSB_ERROR_NOT_FOUND"

(InitLog) start of log /storage/.boblight/boblightd.log
(PrintFlags) starting boblightd -c /storage/.xbmc/userdata/addon_data/service.multimedia.boblightd/boblight.conf
(CConfig::LoadConfigFromFile) opening /storage/.xbmc/userdata/addon_data/service.multimedia.boblightd/boblight.conf
(CConfig::CheckConfig) checking config lines
(CConfig::CheckConfig) config lines valid
(CConfig::BuildConfig) building config
(CConfig::BuildConfig) built config successfully
(main) starting devices
(CClientsHandler:Tonguerocess) opening listening socket on 127.0.0.1:19333
(CDevice:Tonguerocess) LightPack: starting
(CDevice:Tonguerocess) LightPack: setting up
(CDeviceLightpack::SetupDevice) LightPack: found Lightpack at bus 4 address 2, serial is 95230303231351207011
(CDeviceLightpack::SetupDevice) ERROR: LightPack: error detaching interface 0, error:-5 LIBUSB_ERROR_NOT_FOUND
(CDevice:Tonguerocess) ERROR: LightPack: setting up failed, retrying in 10 seconds
(CClientsHandler:Tonguerocess) 127.0.0.1:60945 connected
(CClientsHandler:TonguearseMessage) 127.0.0.1:60945 said hello
(CClientsHandler:TonguearseSet) 127.0.0.1:60945 priority set to 128
(CClientsHandler:TonguearseSet) 127.0.0.1:60945 priority set to 255
(CClientsHandler:Tonguerocess) 127.0.0.1:60946 connected
(CClientsHandler:TonguearseMessage) 127.0.0.1:60946 said hello
(CClientsHandler:TonguearseSet) 127.0.0.1:60946 priority set to 128
(CDevice:Tonguerocess) LightPack: setting up
(CDeviceLightpack::SetupDevice) LightPack: found Lightpack at bus 4 address 2, serial is 95230303231351207011
(CDeviceLightpack::SetupDevice) ERROR: LightPack: error detaching interface 0, error:-5 LIBUSB_ERROR_NOT_FOUND
(CDevice:Tonguerocess) ERROR: LightPack: setting up failed, retrying in 10 seconds
(CDevice:Tonguerocess) LightPack: setting up
(CDeviceLightpack::SetupDevice) LightPack: found Lightpack at bus 4 address 2, serial is 95230303231351207011
(CDeviceLightpack::SetupDevice) ERROR: LightPack: error detaching interface 0, error:-5 LIBUSB_ERROR_NOT_FOUND
(CDevice:Tonguerocess) ERROR: LightPack: setting up failed, retrying in 10 seconds
(CDevice:Tonguerocess) LightPack: setting up
(CDeviceLightpack::SetupDevice) LightPack: found Lightpack at bus 4 address 2, serial is 95230303231351207011
(CDeviceLightpack::SetupDevice) ERROR: LightPack: error detaching interface 0, error:-5 LIBUSB_ERROR_NOT_FOUND
(CDevice:Tonguerocess) ERROR: LightPack: setting up failed, retrying in 10 seconds
(CDevice:Tonguerocess) LightPack: setting up
(CDeviceLightpack::SetupDevice) LightPack: found Lightpack at bus 4 address 2, serial is 95230303231351207011
(CDeviceLightpack::SetupDevice) ERROR: LightPack: error detaching interface 0, error:-5 LIBUSB_ERROR_NOT_FOUND
Post it in the openelec forum please. (seems there is the libusb dependency missing).
didnt got anywhere with openelec so i switched to xbmcbuntu

now im running into this problem

not sure whats going on. lightpack works just fine on my mac
just not my htpc in the living room Sad


(PrintFlags) starting boblightd
(CConfig::LoadConfigFromFile) opening /etc/boblight.conf
(CConfig::CheckConfig) checking config lines
(CConfig::CheckConfig) config lines valid
(CConfig::BuildConfig) building config
(CConfig::BuildConfig) built config successfully
(main) starting devices
(CClientsHandler:Tonguerocess) opening listening socket on 127.0.0.1:19333
(CDevice:Tonguerocess) LightPack: starting
(CDevice:Tonguerocess) LightPack: setting up
libusbx: error [_get_usbfs_fd] libusbx couldn't open USB device /dev/bus/usb/004/002: Permission denied
libusbx: error [_get_usbfs_fd] libusbx requires write access to USB device nodes.
(CDeviceLightpack::SetupDevice) LightPack: found Lightpack at bus 4 address 2. Couldn't get serial.
libusbx: error [_get_usbfs_fd] libusbx couldn't open USB device /dev/bus/usb/004/002: Permission denied
libusbx: error [_get_usbfs_fd] libusbx requires write access to USB device nodes.
(CDeviceLightpack::SetupDevice) ERROR: LightPack: error opening device, error -3 LIBUSB_ERROR_ACCESS
(CDevice:Tonguerocess) ERROR: LightPack: setting up failed, retrying in 10 seconds
(CClientsHandler:Tonguerocess) 127.0.0.1:52749 connected
(CClientsHandler:TonguearseMessage) 127.0.0.1:52749 said hello
(CClientsHandler:TonguearseSet) 127.0.0.1:52749 priority set to 128
(CClientsHandler:TonguearseSet) 127.0.0.1:52749 priority set to 255
(CDevice:Tonguerocess) LightPack: setting up
libusbx: error [_get_usbfs_fd] libusbx couldn't open USB device /dev/bus/usb/004/002: Permission denied
libusbx: error [_get_usbfs_fd] libusbx requires write access to USB device nodes.
(CDeviceLightpack::SetupDevice) LightPack: found Lightpack at bus 4 address 2. Couldn't get serial.
libusbx: error [_get_usbfs_fd] libusbx couldn't open USB device /dev/bus/usb/004/002: Permission denied
libusbx: error [_get_usbfs_fd] libusbx requires write access to USB device nodes.
(CDeviceLightpack::SetupDevice) ERROR: LightPack: error opening device, error -3 LIBUSB_ERROR_ACCESS
(CDevice:Tonguerocess) ERROR: LightPack: setting up failed, retrying in 10 seconds
Permission denied <- you have either to diddle the permissions of usb devices, put your user which runs boblightd in a group which has write access to usb devices or last but worst run the deamon as root.
after 2 days i finally gave up and went with windows where everything is easy and compatible
its not that same but for now im just enjoying my ambient lights

openelec and xbmcbuntu gave me a real pain =/

thanks for your input though
(2014-08-15, 16:54)Furby8704 Wrote: [ -> ]after 2 days i finally gave up and went with windows where everything is easy and compatible
its not that same but for now im just enjoying my ambient lights

openelec and xbmcbuntu gave me a real pain =/

thanks for your input though

what are you using on windows? what hardware? signature is outdated.
(2014-08-15, 17:46)bry- Wrote: [ -> ]
(2014-08-15, 16:54)Furby8704 Wrote: [ -> ]after 2 days i finally gave up and went with windows where everything is easy and compatible
its not that same but for now im just enjoying my ambient lights

openelec and xbmcbuntu gave me a real pain =/

thanks for your input though

what are you using on windows? what hardware? signature is outdated.

Windows 8.1 Pro x64
Same Hardware

used xbmclauncher to boot straight into xbmc
and used ambibox for the lights. their plugin work great with xbmc too