Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
You all seem to be blind and confued. billion times i said that am using the same hardware config file, and i WAS changin this Addon settings and nothing changes just boblight stop wokring. Also I KNOW that this is NOT boblightd god damn. i know this is client. Boblight in OpenElec also is client, it just also includes boblightd itself.

Dont think others is stupid just because you don't understand a thing. Teeedub - i bet your setup is shitty like everybody's else. You just didn't saw real boblight.

I said: this thread's fist topic images, shows clearly that this ADDON makes bad settings and sends them to boblight. Only blinds cant see how bad it works.
I suggest you calm damn and watch your language.
(2014-09-05, 22:32)Martijn Wrote: [ -> ]I suggest you calm damn and watch your language.

I suggest you to fuck off. Bunch of noobs.

This shitty addon even shitty works on linux...
Banned, good call.
Hi, I installed my ambilight system with the following components: ( strip LED type smd 5050 and ws2801 ics , Arduino Mega + 12V 5amp power supply ) .

My TV is 55 " and uses a total of 165 LEDs ( 57 top, 33 left , 33 right , 21 bottom left, bottom center padding 10 and 21, bottom right ) .
OS LinuxMint 17 with XBMC addon Boblight .

The problem I have is that when performing a test video colors within xbmc , when displaying a single color it projects well to the wall , but when the screen is divided into two colors (left / right) only projects a color in both divisions , also when the screen is divided into four colors projected only two colors.

Not really it may be, I have doubt whether it can be a problem with HSCAN coordinate and Vscan or prefix of boblight.conf . How to know if the prefix assigned by the boblight config maker ( generator boblight.conf file) is the same arduino sketch ?. How do locate the arduino sketch ?

this is my configuration of boblight.conf :

https://mega.co.nz/#!oJlTUIyS!IJFTBWhmq1...Db9eTWCW-Y

Link to Boblight Config Maker:
http://www.tweaking4all.com/home-theatre...fig-maker/

Link to Ambilight Test Video:
https://mega.co.nz/#!kId3BTiQ!Gz7dtXPWJG...xkdseICgBk

If anyone can help I would appreciate.
Sorry ... got it sorted.
It solved; was wrong configuration number of LEDs . Every 3 leds equals 1 for the strips . Placed more than normal settings boblight ConfigMaker .
is it possible to run boblight without xbmc on Mac osx?
i have the boblightd on a rasbmc and wanted to start only the client on mac osx
Quote:1. Currently boblight is only driven when the videoplayer is running. We hope to be able to extend it to the menu and even music playback in the future- though this will need major changes in the XBMC core so it wouldn't be the near future Wink.

Is there any news on that?

I just build an 100 led ambilight that work flawlessly, and I was kinda disappointed when I realized that it did not work with projectM (music visualization).

Does the changes needed in xbmc core are/will be integrated in Kodi?
If you're using Linux you can use boblight-x11 for menus full screen viz.
There is no news on that front. It would need major changes in the core and nobody of us active developers is up to the task.
(2014-11-11, 23:58)teeedubb Wrote: [ -> ]If you're using Linux you can use boblight-x11 for menus full screen viz.

I use openelec, and I can't find a way to install boblight x11

Edit: In fact boblight x11 is already installed in openelec,

I just needed to disable xbmc-boblight addon and rename boblight.X11.sample file to boblight.X11 in boblightd addon folder.

Thanks a lot
First of all a BIG BIG THANK YOU TO DEVELOPERS of Boblight and Boblight addon. I've been using them for past 2 years now and I couldn't be happier Smile

Recently I have bought an Android device (powered by RK3288 - but that's not the case here) and I wanted to run my Ambilight on that new device. I had a big trouble with locating and running the Boblight on it until
I found this modified Boblight XBMC Add-on that has been supposedly working on Android devices : https://github.com/Eyal87/script.xbmc.boblight

After installing it - YES! FINALLY! It works! But the happines was there only for the couple minutes as I found out that the addon works, but it kills the XBMC performance. The whole UI seems to be slower, the leds
are changing but too slowly, even on the Fast preset. I'm not sure what could cause that behavior but I was wondering if maybe any of you guys could check the source and see if there can be done anything about it ?

Regards!
How about askingthe guy who made that version of the addon. its not supported by me - this thread is only for the official addon (also the Eyal87 guy didn't upstream any changes to me).
I'll try to reach him, anyways thank you for your hard work Memphiz!

I've also tried a different approach. I have a linux machine which is running boblightd and was running my ambilight before (as I mentioned in the past post). I have edited the boblight.conf file and removed the interface line so it would accept the connections from different IP's.

Code:
(InitLog)                       start of log /root/.boblight/boblightd.log
(PrintFlags)                    starting boblightd
(CConfig::LoadConfigFromFile)   opening /etc/boblight.conf
(CConfig::CheckConfig)          checking config lines
(CConfig::CheckConfig)          config lines valid
(CConfig::BuildConfig)          building config
(CConfig::BuildConfig)          built config successfully
(main)                          starting devices
(CClientsHandler::Process)      opening listening socket on *:19333
(CDevice::Process)              ambilight: starting with output "/dev/ttyACM0"
(CDevice::Process)              ambilight: setting up
(CDevice::Process)              ambilight: setup succeeded

After rebooting I have used the boblight-constant FF0000 to check if all is working fine.

After making sure that boblightd is acceppting connections from all ip's at port 19333 I tried to setup my Android XBMC Boblight service addon and enabled the Use remote boblightd. For some reason it doesn't work and I did make couple time sure that the IP address of my Linux machine and the port is proper. Is there any way to check why Boblight addon can't connect to my boblightd ? I checked the logs but there's nothing about trying to make a connection.

One more time thank you for your help!

EDIT: This must be something either with the Kodi for Android (beta) or the Addon itself. I have tested it with the Android app called BobDroid and it worked like a charm Smile If you need any informations, logs etc. I'm here to help Smile Cheers!