Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
http://mirrors.kodi.tv/releases/android/...bi-v7a.apk (we are not in the playstore yet). Also have a look in our wiki (wiki) (if you are unsure on how to install an apk)
Hello and sorry if my question is answered before, I read all quickly.

I have installed in my openwrt router boblightd and in my androidTV last boblight in xbmc.

When I start boblightd (boblight server) in my router this is the output:

[email protected]:~# (InitLog) start of log /root/.boblight/boblightd.log
(PrintFlags) starting boblightd -f
(CConfig::LoadConfigFromFile) opening /etc/boblight.conf
(CConfig::CheckConfig) checking config lines
(CConfig::CheckDeviceConfig) ERROR: /etc/boblight.conf no devices defined
(CConfig::CheckColorConfig) ERROR: /etc/boblight.conf no colors defined
(CConfig::CheckLightConfig) ERROR: /etc/boblight.conf no lights defined

This is my config for testing purposes before I receive my arduino:

port 19333

name arduino
output dd bs=1 > /dev/null 2>&1
channels 6
type popen
interval 10000

name red
rgb FF0000

name green
rgb 00FF00

name blue
rgb 0000FF

name light00
color red arduino 1
color green arduino 2
color blue arduino 3
hscan 9 19
vscan 85 100

name light01
color red arduino 4
color green arduino 5
color blue arduino 6
hscan 0 10
vscan 85 100

name light02
color red arduino 7
color green arduino 8
color blue arduino 9
hscan 0 8
vscan 71 86

What is the problem on my daemon server config?

(2014-12-19, 12:34)Memphiz Wrote: [ -> ]http://mirrors.kodi.tv/releases/android/...bi-v7a.apk (we are not in the playstore yet). Also have a look in our wiki (wiki) (if you are unsure on how to install an apk)

Here's the log with Kodi, quite different : http://xbmclogs.com/show.php?id=376835

The errors says it can't connect to boblightd, so now it sounds logical. I just have to wait for my Raspberry and Lightberry pack I guess. Unless I try it with a Raspbmc virtual machine, if it is possible...
Solved, I switch from boblight-daemon_412-1_ar71xx.ipk to boblight-daemon_412-2_ar71xx.ipk and working.
Hey guys, hoping for a little assistance, I put together my first Arduino Boblight tonight, and it was all going marvellously. I used the following code

/* t4a_boblight
* (C) 2014 Hans Luijten, www.tweaking4all.com
* t4a_boblight is free software and can be distributed and/or modified
* freely as long as the copyright notice remains in place.
* Nobody is allowed to charge you for this code.
* Use of this code is entirely at your own risk.

#include "Adafruit_NeoPixel.h"


#define STARTCOLOR 0xFFFFFF  // LED colors at start
#define BLACK      0x000000  // LED color BLACK

#define DATAPIN    6        // Datapin
#define LEDCOUNT   150       // Number of LEDs used for boblight
#define SHOWDELAY  200       // Delay in micro seconds before showing
#define BAUDRATE   460800    // Serial port speed, 460800 tested with Arduino Uno R3
#define BRIGHTNESS 90        // Max. brightness in %

const char prefix[] = {
  0x41, 0x64, 0x61, 0x00, 0x95, 0xC0};  // Start prefix
char buffer[sizeof(prefix)]; // Temp buffer for receiving prefix data

// Init LED strand, WS2811/WS2912 specific

// These might work for other configurations:
//   NEO_KHZ800  800 KHz bitstream (most NeoPixel products w/WS2812 LEDs)
//   NEO_KHZ400  400 KHz (classic 'v1' (not v2) FLORA pixels, WS2811 drivers)
//   NEO_GRB     Pixels are wired for GRB bitstream (most NeoPixel products)
//   NEO_RGB     Pixels are wired for RGB bitstream (v1 FLORA pixels, not v2)

Adafruit_NeoPixel strip = Adafruit_NeoPixel(LEDCOUNT, DATAPIN, NEO_GRB + NEO_KHZ800);

int state;                   // Define current state
#define STATE_WAITING   1    // - Waiting for prefix
#define STATE_DO_PREFIX 2    // - Processing prefix
#define STATE_DO_DATA   3    // - Handling incoming LED colors

int readSerial;           // Read Serial data (1)
int currentLED;           // Needed for assigning the color to the right LED

void setup()
  strip.begin();            // Init LED strand, set all black, then all to startcolor

  strip.setBrightness( (255 / 100) * BRIGHTNESS );

  setAllLEDs(BLACK, 0);
  setAllLEDs(STARTCOLOR, 5);

  Serial.begin(BAUDRATE);   // Init serial speed

  state = STATE_WAITING;    // Initial state: Waiting for prefix

void loop()
  case STATE_WAITING:                  // *** Waiting for prefix ***
    if( Serial.available()>0 )
      readSerial = Serial.read();      // Read one character

      if ( readSerial == prefix[0] )   // if this character is 1st prefix char
        state = STATE_DO_PREFIX;
      }   // then set state to handle prefix

  case STATE_DO_PREFIX:                // *** Processing Prefix ***
    if( Serial.available() > sizeof(prefix) - 2 )
      Serial.readBytes(buffer, sizeof(prefix) - 1);

      for( int Counter = 0; Counter < sizeof(prefix) - 1; Counter++)
        if( buffer[Counter] == prefix[Counter+1] )
          state = STATE_DO_DATA;     // Received character is in prefix, continue
          currentLED = 0;            // Set current LED to the first one
          state = STATE_WAITING;     // Crap, one of the received chars is NOT in the prefix
          break;                     // Exit, to go back to waiting for the prefix
        } // end if buffer
      } // end for Counter
    } // end if Serial

  case STATE_DO_DATA:                  // *** Process incoming color data ***
    if( Serial.available() > 2 )       // if we receive more than 2 chars
      Serial.readBytes( buffer, 3 );   // Abuse buffer to temp store 3 charaters
      strip.setPixelColor( currentLED++, buffer[0], buffer[1], buffer[2]);  // and assing to LEDs

    if( currentLED > LEDCOUNT )        // Reached the last LED? Display it!
      strip.show();                  // Make colors visible
      delayMicroseconds(SHOWDELAY);  // Wait a few micro seconds

      state = STATE_WAITING;         // Reset to waiting ...
      currentLED = 0;                // and go to LED one

      break;                         // and exit ... and do it all over again
  } // switch(state)

} // loop

// Sets the color of all LEDs in the strand to 'color'
// If 'wait'>0 then it will show a swipe from start to end
void setAllLEDs(uint32_t color, int wait)
  for ( int Counter=0; Counter < LEDCOUNT; Counter++ )      // For each LED
    strip.setPixelColor( Counter, color );      // .. set the color

      if( wait > 0 )                        // if a wait time was set then
      strip.show();                     // Show the LED color
      delay(wait);                      // and wait before we do the next LED
    } // if wait

  } // for Counter

  strip.show();                         // Show all LEDs
} // setAllLEDs

Prefix was calculated with the processing script mentioned earlier in this post to be 41 64 61 00 95 C0 with 150 LEDs.

However, using the boblight config generator and changing the prefix accordingly. The first 50 LED's appear to work perfectly, no matter how many I change it to, everything after that flashes wildly in different colours! The NeoPixel test script for the arduino however works flawlessly.

Any suggestions and help greatly appreciated.
Since it is not possible to copy the libboblight.so into the /data/data/org.xbmc.kodi/files/libboblight.so folder without root, can the apk file be altered to have the file in there in the beginning? On my HTC One, where I have root, the boblight plugin installed and worked right away. In the /data/data/org.xbmc.kodi/lib folder were a lot of other Kodi related files, so getting files there is possible. Just not afterwards, which sucks, if one does not have root.
Unlikely to happen tbh. I really have a hard time to understand how android is intended to be used from a developer point of view here. I think its considered a security flaw to download a binary library and load it from an app. Otherwise i have no idea why our app is not allowed to write into that directory without root Sad *sucks*
Is or would there be e version for openelec on cubox?
the cubox devs work on rendercapture support. Once its done the boblightaddon will work automagically on that platform.
Thanks for the info, does this mean that then the connection between boblight and boblightd will work like on openelec x86 64?
That connection already works ... but the leds wouldn't work yet. Once the RenderCapture support for the cubox platform is developed into kodi it just would start working then.
When i try to install boblight (previous steps went fine) i get this confusing error:

[email protected]:~/boblight-read-only/boblight-read-only$ make && sudo make install
make all-recursive
make[1]: Entering directory `/home/jelle/boblight-read-only/boblight-read-only'
Making all in src
make[2]: Entering directory `/home/jelle/boblight-read-only/boblight-read-only/src'
source='lib/boblight_client.cpp' object='libboblight_la-boblight_client.lo' libtool=yes \
DEPDIR=.deps depmode=none /bin/bash ../depcomp \
/bin/bash ../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I.. -c -o libboblight_la-boblight_client.lo `test -f 'lib/boblight_client.cpp' || echo './'`lib/boblight_client.cpp
libtool: compile: g++ -DHAVE_CONFIG_H -I. -I.. -c lib/boblight_client.cpp -o .libs/libboblight_la-boblight_client.o
../libtool: line 984: g++: command not found
make[2]: *** [libboblight_la-boblight_client.lo] Error 1
make[2]: Leaving directory `/home/jelle/boblight-read-only/boblight-read-only/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jelle/boblight-read-only/boblight-read-only'
make: *** [all] Error 2
[email protected]:~/boblight-read-only/boblight-read-only$
if this is ubuntu do apt-get install build-essentials or what its called (you are missing a c++ compiler on that system)
can we use boblight with a capture card to read any hdmi source like hyperion?? if so how would i go about doing so??
You would need to write a boblight-client which grabs the image from the capture card. Basically you need some sort of programmers API for that card to get the frames and scale them down to something small (like 80x80 pixels) and then feed them to boblightd. (look at boblight-x11 code to get an idea what needs to be done...).