Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
X11 is linux only
Hi
this is my first post so sorry if what I am about to ask sounds stupid.

I used to use Mediaportal 1 on a Windows 10 Machine I have dedicated for TV Watching only. With Mediaportal I had atmowin with a SEDU Board set up and running.
Because Kodi reacts faster and loads faster i switched to Kodi and boblight.
But now everythime before the leds actually work - i have to open ambilight, terminate the programm and then start boblight and kodi.

Is there a way around this?

If you need more info let me know.
Is there any kind of workaround to get Milkdrop running with Boblight? I really miss that from my amBX setup Sad
I dont know if this has been asked before...

I currently run Kodi on a Windows 10 machine, an arduino for boblight controlled via the boblight script.

After Nvidia announced his Nvidia Shield and because of the possibilities there are coming with it, I thought about replacing my W10 Pc.

Is it possible to use Boblight with the android version? I am a bit unsure about it because I have to run the script on Windows...How does it work with Android then? Is it enoughh to connect the arduino to the Nvidia Shield and install the addon?

Cheers quintz
Hello, trying to find out how to toggle using a key press to easily switch the lights on/off.

Tried:
221252 (thread)

Which gives an error, in the log:
PHP Code:
22:18:01 T:8952   DEBUGCPythonInvoker(48C:\boblightd\boblight.toggle.py): entering source directory C:\boblightd
22
:18:01 T:8952   ERROREXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - 
NOTEIGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            
Error Type: <type 'exceptions.ValueError'>
                                            
Error Contentsclose_fds is not supported on Windows platforms if you redirect stdin/stdout/stderr
                                            Traceback 
(most recent call last):
                                              
File "C:\boblightd\boblight.toggle.py"line 4in <module>
                                                
pid subprocess.Popen('pidof boblightd'shell=Trueclose_fds=Truestdout=subprocess.PIPE)
                                              
File "C:\Program Files (x86)\Kodi\system\python\Lib\subprocess.py"line 667in __init__
                                                raise ValueError
("close_fds is not supported on Windows "
                                            
ValueErrorclose_fds is not supported on Windows platforms if you redirect stdin/stdout/stderr
                                            
-->End of Python script error report<-- 

Also tried:
1624387 (post)

Which seems to run but nothing happens!

Anyone got a solution which would work under windows?
On Opelelec 6 boblightd causes lots of skipped frames.

See: http://openelec.tv/forum/85-boblightd/78...mes#151796

Can anyone dig into this please? I don't want to have to roll back to legacy OE 5.
(2015-11-02, 00:25)kitehigh Wrote: [ -> ]Hello, trying to find out how to toggle using a key press to easily switch the lights on/off.

Tried:
221252 (thread)

Which gives an error, in the log:
PHP Code:
22:18:01 T:8952   DEBUGCPythonInvoker(48C:\boblightd\boblight.toggle.py): entering source directory C:\boblightd
22
:18:01 T:8952   ERROREXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - 
NOTEIGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            
Error Type: <type 'exceptions.ValueError'>
                                            
Error Contentsclose_fds is not supported on Windows platforms if you redirect stdin/stdout/stderr
                                            Traceback 
(most recent call last):
                                              
File "C:\boblightd\boblight.toggle.py"line 4in <module>
                                                
pid subprocess.Popen('pidof boblightd'shell=Trueclose_fds=Truestdout=subprocess.PIPE)
                                              
File "C:\Program Files (x86)\Kodi\system\python\Lib\subprocess.py"line 667in __init__
                                                raise ValueError
("close_fds is not supported on Windows "
                                            
ValueErrorclose_fds is not supported on Windows platforms if you redirect stdin/stdout/stderr
                                            
-->End of Python script error report<-- 

Also tried:
1624387 (post)

Which seems to run but nothing happens!

Anyone got a solution which would work under windows?

I created my own addon to do this. I've only tested this on Linux, but it should work just fine on Windows. Give it a try!
(2015-11-15, 17:46)cozmo Wrote: [ -> ]On Opelelec 6 boblightd causes lots of skipped frames.

See: http://openelec.tv/forum/85-boblightd/78...mes#151796

Can anyone dig into this please? I don't want to have to roll back to legacy OE 5.

I did some more testing and it's definetely not boblightd that's causing the skipped frames, it's XMBC Boblight.
Could someone (@Memphiz) please look into this?
(2015-11-21, 21:55)cozmo Wrote: [ -> ]I did some more testing and it's definetely not boblightd that's causing the skipped frames, it's XMBC Boblight.
Could someone (@Memphis) please look into this?

Maybe it's related to this? https://github.com/xbmc/xbmc/pull/4856
render capture is out of scope of the addon and needs to be maintained/fixed by the responsible platform developer.
Hey guys Smile

I have problems in running the boblight addon on my Android TV Boxes.. Its both: Nvidia Shield and HiMeda H8 Octa. I tried 15.2 and 16 Beta 2 - When I install the addon it says I need the library. I then try to install the library. The download bar is blazing fast and it seems Kodi cant install the library? Because every time when I restart Kodi he wants me to download the library again! Kodi says Boblight is running but it doesnt work. (Can I install the library manually?)

I am only using the network daemon! Boblight Service is on a vu+ solo 2 which was working perfectly before with my Windows HTPC and the Kodi Boblight Addon.

I then found this thread here: https://github.com/bobo1on1/script.xbmc..../issues/32

I downloaded and installed the version from you @Memphiz from 27th November 2014 - Its 2.0.11 as it seems... With that version it looks like he downloads the library correctly and I can get the lights to work.. BUT.. not really well.. Static light works perfectly, but when I play movies I only see "orange" - Settings are correct - Everything as default. I also tried to force movie mode without success.

As said before.. Everything was working fine on my windows client before.. So the problem is not my Boblight Server..

I really really hope to get help Smile Smile as I really love this addon
does it work of you disable hardware acceleration in sertings-video-acceleration?
Hi Memphiz...

Thanks for your answer! YES it works after disabling the hardware acceleration Smile The question is, is it not possible to get it to work WITH acceleration? Smile
In that case it really depends what kind of HW acceleration is used on your box. Android has multiple possible HW Accelerators. It could also be a flaw in the android firmware itself for your box. Possible yes. Is it guaranteed to work at the moment - obviously not. Is someone working on it - i doubt it. (android sucks in that area for sure...).

Its not a thing that the boblight addon can fix - it needs to be fixed in core (especially the rendercapture interface for all those HW decoders).
Okay thank you.. Both Himedia and Shield have the issue.. So I think it must be a android problem in general, because both use different SoCs.. But anyway.. Chances will be less than 1% i think Wink

But Shield play smooth without Hardware Acceleration too... But sometimes I got the already discussed 12fps framedrops

But maybe you could fix the library download with the 2.0.13 version in repo? Downloading the customized 2.0.11 from past year, downloading library with that version and then doeing a upgrade works.