Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Thank you...disabling Mediacodec surface fixed the issue

I have a question.
I have buy Lightberry HD and I have Sony KD-55X9509C TV with Android TV. On this TV I have Kodi 16.1
If I install the boblight plugins in kodi to my TV, boblight can control the leds? Or a raspberry is necessary?
I have the USB model: https://lightberry.eu/shop/shop/lightberry-hd/


Sorry for my poor English...
(2014-02-10, 22:12)schumi2004 Wrote: [ -> ]
(2014-02-10, 19:11)bry- Wrote: [ -> ]
(2014-01-16, 19:42)teeedubb Wrote: [ -> ]Sorry man, my script will be of no use then.

@teeedubb - you have info on the script. I have a buddy with OE that would like to try and use it.

is it possible to only have the lights on when media is playing?

To turn boblight off and on via remote?

Try this:
toggle_boblight_service.py (place in preferred folder)
import xbmc

cmd =  '{"jsonrpc": "2.0", "method": "Addons.SetAddonEnabled", '
cmd += '"params": { "addonid": "script.xbmc.boblight", "enabled": "toggle" }, "id": 1}'

Keymap entry:

I've been trying in vain to set up a toggle of boblight on my remote. Once I've nailed it, I can use it with the shutdown of OE as well as I'm having issues the the LEDs not turning off when i shutdown at night. Even when I manually kill boblightd, the lights stay on the last colour they showed as the addon itself is still running. I'm running the latest version of OpenElec and have following the steps above and assigned it to a button on my remote.
Watching the log files as I push the button, outputs the text shown below. Python seems to have executed the script without issue but the LEDs remain on.

00:49:45 T:139863790938176   DEBUG: OnKey: 252 (0xfc) pressed, action is RunScript(special://profile/scripts/toggle_boblight_service.py)
00:49:45 T:139861195998976   DEBUG: Thread LanguageInvoker start, auto delete: false
00:49:45 T:139861195998976    INFO: initializing python engine.
00:49:45 T:139861195998976   DEBUG: CPythonInvoker(22, special://profile/scripts/toggle_boblight_service.py): start processing
00:49:45 T:139861195998976   DEBUG: -->Python Interpreter Initialized<--
00:49:45 T:139861195998976   DEBUG: CPythonInvoker(22, special://profile/scripts/toggle_boblight_service.py): the source file to load is "special://profile/scripts/toggle_boblight_service.py" ("/storage/.kodi/userdata/scripts/toggle_boblight_service.py")
00:49:45 T:139861195998976 WARNING: CPythonInvoker(22): Script invoked without an addon. Adding all addon modules installed to python path as fallback. This behaviour will be removed in future version.
00:49:45 T:139861195998976   DEBUG: CPythonInvoker(22, special://profile/scripts/toggle_boblight_service.py): setting the Python path to /storage/.kodi/userdata/scripts:/storage/.kodi/addons/script.module.beautifulsoup4/lib:/storage/.kodi/addons/script.module.httplib2/lib:/storage/.kodi/addons/script.module.myconnpy/lib:/storage/.kodi/addons/script.module.beautifulsoup/lib:/storage/.kodi/addons/script.module.pyxbmct/lib:/storage/.kodi/addons/script.common.plugin.cache/lib:/storage/.kodi/addons/script.module.pytz/lib:/storage/.kodi/addons/script.module.actionhandler/lib:/storage/.kodi/addons/script.module.t9.search/lib:/storage/.kodi/addons/script.module.buggalo/lib:/storage/.kodi/addons/script.module.googleapi/lib:/storage/.kodi/addons/script.module.addon.signals/lib:/storage/.kodi/addons/script.module.t0mm0.common/lib:/storage/.kodi/addons/script.module.autocompletion/lib:/storage/.kodi/addons/script.module.six/lib:/storage/.kodi/addons/script.module.chardet/lib:/storage/.kodi/addons/script.module.simplejson/lib:/storage/.kodi/addons/script.module.youtube.dl/lib:/storage/.kodi/addons/script.module.addon.common/lib:/usr/share/kodi/addons/script.module.pil/lib:/storage/.kodi/addons/script.module.simple.downloader/lib:/storage/.kodi/addons/script.module.uritemplate/lib:/storage/.kodi/addons/script.module.requests/lib:/storage/.kodi/addons/script.module.urlresolver/lib:/storage/.kodi/addons/script.module.oauth2client/lib:/storage/.kodi/addons/script.module.yaml/lib:/storage/.kodi/addons/script.module.routing/lib:/storage/.kodi/addons/script.module.hubparentalcontrol/lib:/storage/.kodi/addons/script.module.parsedom/lib:/storage/.kodi/addons/script.module.elementtree/lib:/storage/.kodi/addons/script.module.metahandler/lib:/usr/lib/python27.zip:/usr/lib/python2.7:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/lib/python2.7/site-packages:/usr/lib/python2.7/site-packages/gtk-2.0
00:49:45 T:139861195998976   DEBUG: CPythonInvoker(22, special://profile/scripts/toggle_boblight_service.py): entering source directory /storage/.kodi/userdata/scripts
00:49:45 T:139861195998976    INFO: CPythonInvoker(22, special://profile/scripts/toggle_boblight_service.py): script successfully run
00:49:45 T:139861195998976    INFO: Python script stopped
00:49:45 T:139861195998976   DEBUG: Thread LanguageInvoker 139861195998976 terminating

Any suggestions or help anyone can provide would be great as having to pull the plug on the LEDs when I forget to go into the Addon menu and manually switch off boblight before shutting down is getting tedious!

Equally, it would be a "nice to have" if I could output a message on screen notifying the user that Boblight has been disabled when the button on the remote is pushed although at this stage, just being able to turn it on and off would suffice.

Thanks for any help you can offer.
Hey guys, very quick summary. Used to have RPi+Kodi(OpenELEC)+Lightpack. Worked really well, apart from random crashes and limited capabilities. Thought I'd upgrade to the ODROID-C2 (Android) and the difference is monumental. However, I've had trouble getting Lightpack to screen-capture. Prismatik is useless and all it does is crash the thing. Got the Odroid last week and didn't have time to fiddle, but today I thought I'd give it a shot.

After a few hours of playing around I've managed to setup my old RPi to basically be a Boblight server to my Odroid running Kodi(Android). The rainbow swirl boot was almost orgasmic. I didn't know what to do with my hands. But being the pessimist that I am I held my excitement and thought I need to test it. AVI files are playing and capturing perfectly, no issues whatsoever. However, anything MP4/MKV/etc only has a static colour.

Any idea why?
disable some android specific surface rendering stuff (can't recall the exact name) - its mentioned a couple of posts back in this thread by martijn iirc.
(2016-06-08, 07:15)Memphiz Wrote: [ -> ]disable some android specific surface rendering stuff (can't recall the exact name) - its mentioned a couple of posts back in this thread by martijn iirc.

I had to disable MediaCodec (Surface) and Amcodec for it to work. I'm sure I'm losing a bit of power without the Amcodec but only one left is MediaCodec. While boblight+lightpack work perfectly, I get stuttering/unwatchable issues with some files. Some x265 720p files run perfectly, others don't. I thought it had to do with the audio. 2ch work well, but 6ch are unwatchable. But then I've got higher bitrate 6ch audio and it works fine other than the stuttering at the start.

Very weird, but at least it's a start.
I moved my equipment into the closet. I can't run my light packs over 20 feet of USB.

Can I setup boblight server on a raspberry pi connected to my lights And setup the client on my main htpc back in the closet?

Otherwise. I think I'm screwed.
yes you can
Has anybody got this to work with version 17 of Kodi?
I'm using Kodi 15.2 on Openelec 6.0.3, with a Lightpack ambient lighting system. I have both Bobligt addons installed (Required for Openelec).

I have previously been running Boblight and Lightback OK on Openelec 4, but I just can't get it to run on the latest build. I'm using the same config file as before but I get absolutely nothing from Boblight except for the blue power light on the back. There are no error messages, and also no lights at all. I even tried setting the lights to always on, and that didn't do anything either.

I'm not very familiar with Linux, or Boblight, so I'm not sure where to begin looking for the problem.

I've tried reinstalling from scratch and nothing changed.
does anyone know if the frame drop problem on shield tv happens with spmc too?
Been awhile since using my boblight setup and come to find that it is no longer working when a video is played. I have made a few hardware changes and updated to Windows 10 so I'm thinking those things may be to blame.

Boblight connects and shows the startup rainbow then goes to the soft white color that I have it set when not playing videos but when I play a video everything goes black. I enabled debugging in the config file and am seeing that Kodi is throwing all black color codes to boblight.

I can use the Bobdroid app on my phone and set colors and everything just fine so it is definitely related to something with Kodi and playing videos and may not even be the addons fault.

With all of that said, I am using Kodi 16.0 on Windows 10 with the daemon also on the same machine. I upgraded my CPU from an AMD Kaveri to an Intel I5-6600k and have been using the built in graphics chips for both CPUs. I am guessing that the intel graphics drivers don't play nice with however Kodi is getting the video color values.

Thanks in advance for any help or suggestions.
Is there a way to tell what color boblight is currently reading?

For instance, I am not happy when the tv shows a dark blue, boblight usually shows something closer to cyan. If I know what boblight is reading as the color, I can manually change that color in the conf file to something better.

Any ideas? Can I hack the add-on to have it print statements out to the log?
You could enable debug loggin on the boblightd side like the post before yours did it.


I am not showing any color informaiton. I have logging enabled in the boblight conf file as well as in kodi. I am getting some boblight debug info such as:

Quote:13:36:18 T:140541179320064 DEBUG: ### [Kodi Boblight] - settings() - handleCategory(tvshow)
13:36:18 T:140541179320064 DEBUG: ### [Kodi Boblight] - settings() - handleGlobalSettings
13:36:18 T:140541179320064 DEBUG: ### [Kodi Boblight] - settings() - handleStaticBgSettings
13:36:18 T:140541179320064 DEBUG: ### [Kodi Boblight] - settings() - handleStereoscopic(False) - disableon3d (False)

But nothing color related. What am I missing?