Kodi Community Forum

Full Version: [RELEASE] Official XBMC boblight Addon
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Thats too bad, i'd love it if i could get things working with just one box, but i happen to have a spare raspPI laying around, and i got that working. However i'm using libreelec and it seems kind of wasteful to have kodi running on a pi that is just used to run boblightd (or hyperion.) Does anyone have a suggestion on an distro that would work without wasting resources to just run kodi that will never be seen. This RasPI will headless.

I'm guessing that the boblightd code could be ported by a motivated android developer (maybe it is worth looking in to it myself. Even if it is just to run as a boblight server and not a capture of any kind (we will let kodi handle the capture) We have access to the a usb serial device (you might have to be root, which isn't a problem at least for my devices)

Just thinking out loud, anyone interested in using an android hosted boblightd, or interested in writing the code themselves?
the problem is letting a daemon run on android ... its different then simply starting an android app. So before you start you should checkout what is possible on android at all...
I've written daemons before that gets called whenever a usb device is inserted with a specific HID id. It's not as hard as you might think. But porting the hyperion code from c to java wouldn't be that much harder either. Maybe if i get some free time in the next few weeks i can give it a crack. Is there anyone out there other than myself that would be interested in an android port?
well i was able to get my boblightd (or in this case the compatible hyperiond) on a headless build of raspbian, this time with a direct connection to the gpio pins eliminating the need for the the arduino (1 less device in the chain) now to work on getting a port of hyperion or boblight written for android, and i will be down to just a android tv box and an arduino. Hmmm not sure how much better it would be since it is still 2 devices. still it would be nice to support more devices. Who knows how far i will get or how long it will take, i guess we will see.
i wouldn't port it to java ... you can build with the native toolchain for android like kodi does to build c and c++ code...

You have written a daemon for android? Really? its not about writing really. Android is a restricted system - i doubt you can start a daemon with non rooted android devices. Everything is sandboxed and i am not even sure if you are allowed to open a listening tcp port.
I think this has gotten a little off the topic of this post, but yes i've written services that respond to device intents and open sockets. Opening tcp ports for listening is definitely possible without root. connecting to and writing to a serial port is also possible without root. There are permissions that can be granted to those things through the standard permissions. There are plenty of non-root apps that do both of these. not sure if there are any that do both but there isn't any reason it why it couldn't be done (at least from my previous experiences.) I did see some stuff online that ports below 1024 are restricted to root but actual port #s doesn't matter.

As for compiling c++/c code with jni, i don't have any experience with it, so it is possible that these things are restricted from jni, if they are, then porting the code to java would be needed as i know it is possible from android's java sdk.

You might be concerned by the fact that the add-on requires a binary that requires root. I'm not sure why, but my guess would be that it has to screencap and i think that is restricted. honestly i don't know why without going through the code myself, doing some more research, or having the author explains it. but if it comes to permissions of a jni library/app it can always be written in java since i know it works there.

but even if it comes down to having root, i think we are requiring the user to have root just to get the plugin binary working, so extending this requirement doesn't require anything that is already required.

I don't really know if i have the time to do it but i don't know why someone couldn't with enough motivation. Sorry, i really didn't mean to get in an argument about it but i wanted clarify things

If i start and make any progress i will open a new topic about it and then report here if it gets done.

Like i said no promises on development, but if we are talking tcp and serial connections it is possible. so i know with an arduino/adalight and an android box (which is how i was setting things up) is possible (that's where i would start) but i really want to know if anyone has interest in this or if i would be working on this for me solely

If anyone else wants to correct me i won't be offended.
Well just as a last comment from me on this - the libboblight.so (binary needed by the client addon) doesn't need root ... beside that i agree that this should be a different thread in case it gets rolling Smile
(2016-10-23, 22:39)Memphiz Wrote: [ -> ]the libboblight.so (binary needed by the client addon) doesn't need root ...
are you sure about that? without root you don't have access to the FrameBuffer
It is not accessible to apps without root.
Code:
[email protected]:/dev/graphics # ls -la
crw-rw---- system   graphics  29,   0 1970-04-22 09:38 fb0
crw-rw---- system   graphics  29,   1 1970-04-22 09:38 fb1
Is this something that has changed recently. I know when i run kodi on my android box it requests root access before loading the binary. You may not need root access for other platforms but i think android is different because of its suid access restrictions. As far as i understand access to FB is seen as a security risk by google
.
Wait....

I figured out why mine was requiring root. i was using a fork. https://github.com/Eyal87/script.xbmc.bo...c.boblight this version actually sets up a boblightd/hyperiond on the device that is compatible with adalight (i think that is the only device that he ported) Basically what i wanted to do eliminating the need for the rasp pi. So he has an actual binary that grabs the image data and writes to the serial All done in python (i think). . It looks like it is all done through the player and not the FB which explains why it doesn't work in other apps or in the menu(that last one could be intentional). I think more code would need to be written to support other devices, but all i have is an adalight, so i care a little less about the other devices. I wonder though if i do work on a NDK build of boblightd/hyperion it might be cool to run it as a service to add support for any app. I don't know maybe that is pie in the sky. I'll revisit all of this when i actually have my device installed on my tv (i've kinda jumped the gun using what things i already had).

You are right the official kodi add-on does not require root that's great. I'm sorry to doubt you. I humbly bow to your superior knowledge. My wife tells me i have to actually acknowledge things when i am wrong. :-) This is the last you'll hear from me in this post.. I'll start a new post for development if it ever happens.thanks to everyone for the help getting me setup in the first place. I feel like i have a much stronger grasp on how it all works. it's very interesting. funny thing is my tv has ambilight (Phillips) it is just a bar of light on each side. Addressable completely surrounding the tv is much better (and brighter).
Hi,

boblight Binary addon for the new ARMv8A 64bit build of Kodi beta4 is missing, any guides on how to get it?

Thanks.
all of the binaries as far as i know are located here: http://mirrors.kodi.tv/build-deps/addon-...bboblight/ . i don't see it there (or maybe i'm not looking in the right location), you might need to compile it yourself. Have you ever been able to get a module for it?
There is no support to load 64bit binaries from addons yet - i need to talk to whoever is doing those builds
(2016-10-26, 08:52)Duduke Wrote: [ -> ]Hi,

boblight Binary addon for the new ARMv8A 64bit build of Kodi beta4 is missing, any guides on how to get it?

Thanks.

Could you please try this boblight version?

https://dl.dropboxusercontent.com/u/3037...2.0.17.zip

And please post a log file after starting the addon so i can see if it fetches the correct file. This is untested. I just compiled the arm64v8A Version of libboblight.so on our jenkins slave, packaged it into the correct location and changed the addon so it downloads the right zip when 64bit runtime is detected.

In case this is confirmed working i will update the addon in our repo.
It still can't download the correct .so

LOG:
http://pastebin.com/CeXh6QhH

Edit by memphiz: moved log to pastebin
I've tried manually downloading the libboblight.so.zip from http://ftp.halifax.rwth-aachen.de/xbmc/b...roidarm64/ and extracting it to Android/data/org.xbmc.kodi/files/.kodi/addons/script.xbmc.boblight/resources/lib, but it still cannot find it...
1. please don't post logs into the forum directly but use something like pastebin.com
2. i only take full logs uncut
3. post a log from your second approach please.