Kodi Community Forum

Full Version: [AppleTV1] No 'Add source' option under 'Videos'
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've just bought an Apple TV 1st gen, with XBMC already installed. I'm a complete newbie to it, and have been trying to figure out how to get MKV files from my laptop to the XBMC on my Apple TV.

I followed this guide: http://forum.xbmc.org/showthread.php?tid=63123 - to enable sharing from Windows 7.

My problem is that I can't see an 'Add source' option under the 'Videos' tab, but it is under every other tab. From searching Google I see a possible solution might be to switch from 'Library mode' to 'File mode' but I can't see how to switch to 'File mode'!

All the images I've seen show 'Library mode' as an option in the sub menu when pressing left on my ATV remote control, but the option isn't there when I access the sub menu.

Any suggestions what I could do? :confused2:
Sounds like you are on a pre-eden build where the lib mode is no longer on the left tab. You need to "files" and add the source there
There is no 'Add source' option under the 'Videos' file menu though, that's the problem. I've made sure the 'Show "Add source" buttons in file lists' option has been selected in the settings.
Just checked with a Dec 10th nightly and a totally fresh slate of settings, and the "add videos" button does show up. Maybe you need to update the nightly build that is on the ATV1.
While in the videos window, try this:

Press the left on the appletv remote and see if library mode is enabled (if the option is there), if it is disable it.

OR

Press and Hold the Menu button while on the videos window and a context menu should come up saying add source.
Bandit_Kaine Wrote:While in the videos window, try this:

Press the left on the appletv remote and see if library mode is enabled (if the option is there), if it is disable it.

He's using pre-Eden which no longer has different "modes" and he mentioned in his first post that he tried exactly that.
Ned Scott Wrote:Just checked with a Dec 10th nightly and a totally fresh slate of settings, and the "add videos" button does show up. Maybe you need to update the nightly build that is on the ATV1.

Would that involve uninstalling XBMC from my ATV and then reinstalling?
Bandit_Kaine Wrote:Press and Hold the Menu button while on the videos window and a context menu should come up saying add source.

Just tried this now, it did bring up another menu, but still no "add source" option. This is very annoying!
You could dlete your profile directory. When you run XBMC it will create a new profile with default settings. See http://wiki.xbmc.org/index.php?title=Profile_directory for the location of the profile directory. I'm not sure how you delete this on an ATV.

JR
jhsrennie Wrote:You could dlete your profile directory. When you run XBMC it will create a new profile with default settings. See http://wiki.xbmc.org/index.php?title=Profile_directory for the location of the profile directory. I'm not sure how you delete this on an ATV.

JR

Sounds like a plan, but I've no idea how it could be done on ATV either haha.

If I performed a factory restore on the ATV would that delete XBMC? And are there certain restrictions as to which ATV software XBMC will work?
XBMC successfully installed, AND now there is an 'Add source' option under Videos Big Grin

I still have issues though, which will hopefully be easier to answer.

When I navigate down to 'Windows network (SMB)' I get an error saying 'Error 2: share not available' even though I have made the 'Video' file from MakeMKV available to share with 'Everyone' as this guide http://forum.xbmc.org/showthread.php?tid=63123 shows me to do.

Any suggestions?
cymruoasis Wrote:XBMC successfully installed, AND now there is an 'Add source' option under Videos Big Grin

I still have issues though, which will hopefully be easier to answer.

When I navigate down to 'Windows network (SMB)' I get an error saying 'Error 2: share not available' even though I have made the 'Video' file from MakeMKV available to share with 'Everyone' as this guide http://forum.xbmc.org/showthread.php?tid=63123 shows me to do.

Any suggestions?

Try restarting the whole appletv, sometimes that happens to me and restarting seems to fix it most of the time.
cymruoasis Wrote:When I navigate down to 'Windows network (SMB)' I get an error saying 'Error 2: share not available' even though I have made the 'Video' file from MakeMKV available to share with 'Everyone' as this guide http://forum.xbmc.org/showthread.php?tid=63123 shows me to do.

There is/was some issue with SMB sharing from Windows to Apple TVs. Something to do with a newer version of the SMB protocol being used. Whether this is the problem in your case I don't know, but it would be worth asking in the ATV forum.

JR