Kodi Community Forum

Full Version: Audio over HDMI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So, apparently there have been numerous threads about audio over HDMI, however none seemed to help me solve my problem Sad

Please, won't you help me make my installation of XBMC all it can be?

Problem: I have menu sounds working, however music and emulators will not output sound.


Operating System: Arch Linux
XBMC Version: 10.1

XBMC Audio Settings:

Code:
Audio Output: HDMI
Speaker Configuration: 2.0
Audio Output Device: HDMI
Passthrough Output Device: HDMI

aplay -l

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aplay -L

Code:
Discard all samples (playback) or generate zero samples (capture)
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    Front speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=PCH,DEV=0
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
hdmi:CARD=PCH,DEV=1
    HDA Intel PCH, HDMI 1
    HDMI Audio Output

.asoundrc

Code:
# ALSA device configuration file - per user

ctl.!default {
        type hw
        card 0
        device 7
}

pcm.!default {
        type hw
        card 0
        device 7
}

So, what am I doing wrong?
XBMC Audio Settings:

Code:
Audio Output: Analog
Speaker Configuration: 2.0
Audio Output Device: Custom
Passthrough Output Device(Custom audio device):     plughw:0,7
or
Code:
Custom audio device:     plughw:0,3
bsmim Wrote:XBMC Audio Settings:

Code:
Audio Output: Analog
Speaker Configuration: 2.0
Audio Output Device: Custom
Passthrough Output Device(Custom audio device):     plughw:0,7

Thank you for the response. This gets the music playing. Why would I have to use Analog instead of HDMI to get HDMI playback though?

Is XBMC mixing the signal first because of the Analog arguement?

MAME still doesn't give me sound though... But that should be outside of XBMC.