Kodi Community Forum

Full Version: Simply can't get smooth 1080p on Acer Revo 3700
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there.

I've been using XBMC for quite a while now and have recently started watching 1080p Blu Ray rips on my Acer Revo 3700 and cannot get the playback to be completely smooth. I know the revo is capable of it because so many people have praised it's 1080p support but I simply can't seem to manage it. My setup is as follows.

- Acer Revo 3700
- Onkyo HT-X22HDX 5.1 (My revo is hooked up to this through HDMI for video and SPDIF for sound. Single HDMI output to TV this way as I also have PS3, 360 etc..)
- LG LE427900
- 2 x 2TB External Harddrives (where media is stored)

I'm not sure what part of my setup is causing the problem. The main issue arises from skipping frames and general jerkiness most frequently during panning shots and close ups. I've tried XBMC for Windows, XBMC Live and Openelec (the specific build for ION machines) which I'm using at the moment but they all seem to suffer from the similar problem. I always have VDPAU on and all picture processing functions on my TV are turned off. It helps slightly to have the adjust refreshrate to match video setting on in XBMC settings along with the Resample Audio setting.

The only way I can get slightly smoother picture quality is to enable TruMotion on my tv but this is obviously not ideal as it is detrimental to the picture quality. I want to be able to play full 1080p with TruMotion turned off. I've tried using the 24p setting on XBMC but just running films at 60HZ actually seems better despite my TV having a TruCinema 24p setting. I'm not sure if I'm being a huge idiot and missing something or for some reason my Revo isn't up to the task anymore (although it is only 1 year old). I'm also not sure if storing my rips on an external harddrive is causing this problem but surely the transfer rate over USB 2.0 is up to scratch?

I hope I have provided information on all the variables that could affect the playback but if I've missed some details I'll be more than happy to provide them. I just can't work out if this is software/hardware related.

So basically.. does anyone have any ideas or could help me out?

Cheers in advance

Think you may have found the likely culprit (considering all the other things you've tried):
Quote:I'm also not sure if storing my rips on an external harddrive is causing this problem but surely the transfer rate over USB 2.0 is up to scratch?

Try copying a problem file to the drive in the Revo (unless your boting from USB pen). What drive have you got inside?
Thanks for the reply.

I'm booting Openelec so not sure how to copy a video over to the internal HDD at the moment but I remember doing so a while back when I was running Windows and it not making much difference (it's the standard 320GB Hitachi drive that came with the Revo). I realise that playback may be smoother off of the internal HDD with Openelec or XBMClive but being an absoloute Linux noob I've no idea how to transfer a video without a GUI to test this out Sad
Hi dan,

I have a simular set-up and all works fine for me now. My revo used to jitter quite badly, are all you drivers up to date?

I find if I leave my revo on stby or it pause a film for too long it stutters.


Good luck

just had a thought...... have you tried a different television?...... or taken the amp out the loop.... maybe a delay or something in your amp?
I run OE on my 3700 and it's perfect (it was also perfect when I ran W7 on it as well).

Are you running a daily build of OE because that should help?

More info here -