Kodi Community Forum

Full Version: EVGA GT520 HDMI - no audio
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Does anybody know how to get the EVGA GT520 to output audio over HDMI? I've gone in and unmuted in alsamixer through terminal, but I'm still getting an initialization failure when trying to play anything. I'm using XBMCbuntu Eden Beta 3. Any help would be greatly appreciated!
Check with alsa -l (letter L) which device number your card gets.

then go to system settings and set the sound and passthrough option to custom and insert plughw:0,3 (example)

0 is the card number stated when running aplay -l
3 would be one of the associated device numbers. You may have to try a few. I am running a gtx260 and had to use plughw:0,7 with my setup.

Check if your connected receiver/tv can accept dolby-dolby digital and/or DTS and select/deselect accordingly in the sound menu.

The sound menu (in my case) does give the the options as well (for xample hdmi device #3) however choosing one of these options did not yield anything in my case.
You might want to take a look at these guides and see if they help you.

http://wiki.xbmc.org/index.php?title=HOW...controller

http://wiki.xbmc.org/index.php?title=HOW...,_or_GT240
alexandergoll, your instructions worked... partially... plughw:0,3 worked to enable stereo sound for 2-channel audio files, but with DTS and Dolby-digital checked, my m2ts DD videos don't play audio. I know my receiver supports both DD and DTS, so I'm a bit confused. With DD/DTS unchecked however, I'm able to hear what sounds like surround just fine in video (used the gunfight scene in The Matrix to verify). Could it be possible that XBMC is doing the decoding of surround audio and passing it to my receiver via LPCM? :confused2:
(2012-02-15, 15:51)alexandergoll Wrote: [ -> ]Check with alsa -l (letter L) which device number your card gets.

then go to system settings and set the sound and passthrough option to custom and insert plughw:0,3 (example)

0 is the card number stated when running aplay -l
3 would be one of the associated device numbers. You may have to try a few. I am running a gtx260 and had to use plughw:0,7 with my setup.

Check if your connected receiver/tv can accept dolby-dolby digital and/or DTS and select/deselect accordingly in the sound menu.

The sound menu (in my case) does give the the options as well (for xample hdmi device #3) however choosing one of these options did not yield anything in my case.


Worked on my GT520 card!

Had to put audio to digital out tho, not HDMI but still no dts, but dd 5.1 works now
There are some audio issues with this card that are fixed in kernel 3.1.