Kodi Community Forum

Full Version: No Audio over HDMI
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So I have spent the last few days trying to fix this problem.

My hardware is as follows:
Mobo: Asus AT3IONT-L (720p video plays just fine on this board, the audio is the problem)
Ram: 2 gb DDR3 ram

XBMC Live 10.1

My problem is this:
I get NO audio output over HDMI.
However plugging into the standard 3.5mm audio jack works.

After updating alsa using this:
sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get install linux-alsa-driver-modules-$(uname -r)

After a reboot the XBMC user interface stops loading, the terminal will flicker every couple of seconds like it is trying to do something but nothing happens. The terminal does not flicker before the reboot/alsa install.

I HAVE SEARCHED several threads with people saying that they have fixed the HDMI audio problem but that was some time ago (different unspecified driver revisions, new drivers may be the issue)

Several people have listed this link as instructions for fixing this problem, I have tried almost everything on this page. The audio over HDMI was still not working.

I have tried setting up the audio device in the Settings menu
for both Audio Out and passthrough

I have tried adding this file which some people have claimed to fix the problem but only after updating the alsa drivers which as I mentioned earlier borks the install of XBMC live
[i]add file "sudo nano /etc/asound.conf" for menu sound[/i]

pcm.!default {
   type plug
   slave {
       pcm "hw:0,3"
       rate 48000

I have tried setting these options in:
enable_msi=0 probe_mask=0xffff,0xfff2

I have tried updating the alsa PPAs and Packages like so
add-apt-repository ppa:team-iquik/alsa
add-apt-repository ppa:ubuntu-audio-dev/ppa
apt-get update
apt-get upgrade

I have also tried both "alsamixer" and the XBMC audio mixer to unmute S/PDIF and all other outputs with no luck

I have also checked that my user is part of the audio group and that "aplay -l" specifies the HDMI output audio on my NVidia as "Card 0" "Device 3"

I plugged my Xbox into my monitor via the same HDMI cable and the audio worked just fine, so that rules out the Monitor or HDMI cable as potential causes (I rather doubted it but it doesn't hurt to make sure)

So Im stuck, ANY help would be greatly appreciated.
Im going to reinstall XBMC live on the computer to start with off fresh install.
To get help, you need to post more info about your setup, specifically:
  • Graphics chipset
  • Output of aplay -l

And maybe some other stuff. Anyways, each setup is unique so copying a config file from the wiki isn't going to work all the time.

Edit: Take a look at This page. It has info specific to your board regarding HDMI audio.
This is exactly what I see when I type "aplay -l"

#$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC887 Analog [ALC887 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC887 Digital [ALC887 Digital]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
   Subdevices: 1/1
   Subdevice #0: subdevice #0

As for the GPU, Asus's website make's no mention of the specific chipset other than its an Nvidia ION.

I will try this in /etc/asound.conf
pcm.!default {
  type plug
  slave.pcm "dmix:0,3"

That still leaves the mess with ALSA
Upon running those commands to update ALSA the XBMC UI fails to load from then on
Unless of course there is no need to update ALSA.

Some progress finally, but not there yet.

After setting the "audio output" to HDMI and "audio output device" and "passthrough device" to "plughw:iec958,1" I get audio in the menu. ie the little click/swoosh sound when scrolling through options.

I also had "boost volume level on downmix" set to OFF

However when I try to play a video (MKV, AVI) I get nothing, no audio whatsoever until I stop the movie then the audio returns to the menu navigation.

If I enable "DTS Capable receiver" and "Dolby Digital (AC3)" with the audio passthrough device set to "hdmi" I get static when playing a MKV with DTS audio and Stuttering audio when Playing an AVI file with AC3 audio.

any other types of videos (xvid in avi container for example) with different audio codecs just produce an error saying "Failed to initialize audio device"

if I change the passthrough device to iec958 I get no audio during playback not even static.

Any ideas?

should I try updating to the latest drivers from nvidia? (just alittle hesitant because I dont want to bork the setup again and have to reinstall for the 7th time)

I used this to update the Nvidia drivers last time:

Blacklisted nouveau by adding following into "/etc/modprobe.d/blacklist.conf" after running the first command (added the following into the end of file)

sudo apt-get purge nvidia*

sudo apt-get install nvidia-current

sudo modprobe nvidia

sudo nvidia-xconfig
If you are getting the "unable to initialize audio device" error when you play a video, try disabling the navigation sounds in the skin settings. If there is no checkbox for that, add the following in your /usr/bin/xbmc script (or /usr/local/bin/xbmc).


right after:

that ALSA over HDMI stuff simply suckz .. I'm no friend of pulseaudio, but there it is very simple to fix (took me lots of days too to find that simple soultion):


So long

shmal Wrote:If there is no checkbox for that, add the following in your /usr/bin/xbmc script (or /usr/local/bin/xbmc).


right after:


When you say right after do you mean in the next line?
like so


or on the same line like so:


I tried both and so far all it managed to do was disable my audio entirely even in the menus, I still had either no/static audio while playing a movie or the Error "failed to initialize audio device".

with these settings in SYSTEM - AUDIO OUTPUT:
Audio output                     = HDMI
     Speaker Configuration                  = 2.0
     Boost Vol on Downmix                        = Yes
     - Dolby Digital (AC3) Capable receiver   = Yes
     - DTS Capable receiver                       = Yes
     Audio Output device                          = Custom (plughw:iec958,1)
     Passthrough output device                = TRIED ALL 3 Options
                                       (for custom I used "plughw:iec958,1")
It seems that getting audio over HDMI is not the problem if I can get menu sound over HDMI it seems like a issue when XBMC tries to transfer the "Passed-Through" audio to the Soundcard when trying to hand off 5.1 channel audio or AC3 any other audio stream like MPeg(1/2/3) it just says audio device failed to initialize.

I did try that pulseaudio fix that lastcoder mentioned and it did not fix the problem either.