Kodi Community Forum

Full Version: problems with library scraper and all
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
okay, so im on the verge of a breakdown having spent the better part of the weekend trying to figure this all out. yesterday i managed to setup a mysql shared database so i can start and stop content from room to room.

my setup is 2 atvs and 2 htpcs (one as the server).

now when this was setup, to test it, i managed to scrape 1 movie, which is in the db. however going back to it to rescan my movie collection, xbmc can no longer connect to remote server. i have tried reinstalling the utube plugin, changing scraper, nfo files to the movies imdb page... im at wits end, so i leave it to u wiser folks to help me find a solution, pretty pls, as this setup i sent the weekend working on is useless as i cant add stuff to the library Sad

Don't think you can add upnp:// as a source for your movies/tvshows.

It must be something like smb:// nfs:// etc..
ah that might explain some things? xbmc just sets that address when i select a source....
ok so i changed all of my sources to direct links (S:\...)

however im still getting the issue on all scrapers, can someone help me interpret what i might do next? seems from the log its doing something diff now but there are still 1 or 2 errors that need resolving. additional guidance appreciated

Not a debug log, but the problem is that mysql does not support using win32 paths.

You cannot use upnp paths as they're not stable (different URL on each run). Further, you can't use win32-style paths in mysql won't deal with them.

Use smb:// or similar for sharing your files.
Thanks for your reply but um...could someone post a link where I can find out more about SMB:? I'm not very familiar with it.... Sad or do I just SMB://S:/Folder_name/Folder_name/

? Is that just it?
No. Whatever "S" is is likely a smb share anyway (i.e. you've enabled file sharing on one of your htpc's). You may be able to browse for it in XBMC -> Add Source -> Browse perhaps.
S is my drive Smile so the directory for my movies is

S:/public/shared videos/movies

The videos are stored on an NAS with sharing fully enabled on those folders. The HTPC pulls from that NAS & its always on & the sql database is on the hosting HTPC (the HTPC didnt have enough space and was having issues with the external drive so I went for an NAS Which is working ok)
Right, your NAS is likely sharing those files using smb. Again, just browse for your NAS from the Add Source dialog.
ok so i did that, and am still getting the dialog box. i just started up xbmc and i got it again,
here is the log


i noticed im getting:
21:31:13 T:6548 ERROR: XFILE::CFile::Exists - Error checking for upnp://7076436f-6e65-1063-8074-0090a9b55719/0%243%2434%2474%241035R1449.nfo
21:31:14 T:6548 WARNING: XFILE::CFileCurl::CReadState::FillBuffer: curl failed with code 22

i assume this is where the problem starts... which i cant figure out because i removed all the shares excet one, which the source is set directly to s:/ubli...etc

any thots?
Delete your videodb and start over. It has left over paths in it.

Also, turn on debug logging if you want to seriously debug something.
hey jm thanks for the time and energy. so i did that, deleted all the dbs started over, and now this happens Sad


sorry i couldnt use pastebin its too big for the free account, i also enabked debugging mode.

thanks again, im new to mysql so im more than lost atm ><
anyone? I really am Shtumped Sad
no solution but I am having the same problem and have been for weeks.

Tried Installing YouTube, deleting video dbs, deleting tmdb and youtube xml metadata everything I have seen I have tried and still the same problem.