Kodi Community Forum

Full Version: "Play Disc" -> Eject -> "Play Disc" disappears.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
As title, XBMC PVR 11.0 Eden Beta 3.

Installed on Ubuntu minimal 10.10 x64.

Is this a known problem?

I've noticed "Play Disc" is never even normally there in the main screen. Occassionally appears every now and then (few days?) then above behaviour happens.

Same results on 2 different boxes with 2 different versions of Ubuntu, also witnessed on Beta 2.

Edit - hmmm, my post appears a little rude with no please\thank you. This was a bug report\requesting confirmation of it being a bug, not asking for help Smile I don't use the feature particularly so have no interest in it personally.
I'm also looking for an on screen button to eject an audio cd.
I have no access to the physical eject button of the slot-in drive (hidden behind a front bezel).
The following thread comments on a "little triangle button" on the main screen, but my XBMCbuntu EDEN (installed to a ssd from cd) has no such triangle.
http://forum.xbmc.org/showthread.php?tid=96570

How do I get a eject on screen button?
If you are using the default Confluence skin in Eden, when you insert a CD/DVD disc into your drive, a new menu item labeled "PLAY DISC" is dynamically added to the main menu between the "PROGRAMS" and "SYSTEM" options. If you go to the "PLAY DISC" option, you can select its submenu item labeled "Play/Eject" to eject your disc. When the drive is empty, the "PLAY DISC" entry is removed dynamically from the main menu.

Hope that helps.
I have the same problem with Eden Relase... The play disc button appears only when their is a disc in the tray before i boot xbmc. I tried with XBMCBuntu and the OpenElec 2 beta.
Nobody has the same problem?

Nic
So you're saying that when XBMC is running you put a disc in your machine and the Play Disc button doesn't appear?
Yes exactly. I put a disc, then I see that the drive is working, but then nothing! the play disc button doesn't appear... But if I start XBMC when a disc is already in the drive, the play disc menu appears. If I remove and reinsert the disc, the menu does not reappear.
I get this behaviour with XBMCBuntu Eden official release (version 11.0 Git unknown) on a AsRock ION 330. I've tried with the confluence and Xeebo skins.
I also tried with OpenElec 1.95.1. With the 64 bit version, I have the same behaviour. With the 32 bit version, the menu appears, but DVD playback doesn't work.

Everything was working with Dharma so I don't think my computer is the problem.

Anyone experience something like this? Can it be a permission things with the dvd drive in Ubuntu?

Nic
I can concure this.

but for me its abit differents.
I can put a disk in and play appears, but if I use the eject from meny, and try to put a new disk in, the play meny does not appears. not untill you do a reboot on xbmc.

Regards Alf Tonny B├Ątz