Kodi Community Forum

Full Version: MCE Remote Suspend button does not work!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I have a Zotac ZBOX AD04 with a MCE remote

This is what it looks like
http://www.hardwareheaven.com/reviewimag...bundle.jpg

/etc/lirc/lircd.conf contains
Code:
include "/usr/share/lirc/remotes/mceusb/lircd.conf.mceusb"

I installed Ubuntu 11.10 mini and then XBMC PVR Xvba. The remote runs fine, I can browse menus and wake-up the machine from standby.

BUT nothing happens when I press the Suspend key on the remote!

In IRC somebody suggested that I put the following into
.xbmc/userdata/keymaps/keyboard.xml

Code:
<keymap>
   <global>
      <keyboard>
        <key id="XF86Sleep">XBMC.Suspend()</key>
      </keyboard>
   </global>
</keymap>

But that doesn't do anything.

When I press the suspend key, this appears in the xbmc.log:
Code:
12:46:46 T:7754496   DEBUG: SDLKeyboard: scancode: 96, sym: 009f, unicode: 0000, modifier: 0
12:46:46 T:7754496   DEBUG: GetActionCode: Trying Hardy keycode for 0xf200
12:46:46 T:7754496   DEBUG: Previous line repeats 3 times.
12:46:46 T:7754496   DEBUG: OnKey: 0 (f200) pressed, action is

So this button is being recognized, but no action is defined for it. And why "f200" ?
Is XF86Sleep wrong? When I run "xev" in terminal, it tells me that XF86Sleep is the name of the suspend button.

This is the whole log file (starting xbmc->pressing that button)
http://pastebin.com/iiSRmBCn

Anybody can help me? Thanks!

edit: It works now!
Had a wrong configuration file
Hi cyberman,

Which configuration file did you change? Because it looks like its the same problem I have and can't figure out what to change/configure.

Can you help me? or if someone else knows it.