Kodi Community Forum

Full Version: advancedsettings = Watchlist broke?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello!

Sorry if the title is misleading but i've been trying to find information about this.

I finally got my Database up yesterday, added the Advancedsettings.xml under my XBMC machines, iwth the correct ip and stuff, and booted them up and "Watchlist.script" stops working and my xbmc is so slow i can not even navigate the menus?

I understand if the information given is a bit short but i dont know what the problem is.. The advancedsettings.xml is written as is in the wiki.

Thank you. (I cant even get debug log going)

Oh and yes, this happens on all skins.
This is almost certainly a problem with the connection to MySQL. Temporarily remove the advancedsettings.xml then start XBMC and enable debug logging. Then put the advancedsettings.xml back, start XBMC, let it run for a minute or so then close/kill it and post the log on http://pastebin.com/

JR
Thanks for the help, i got the Debug log, and it was just riddled with "20:29:22 T:1644 ERROR: Unable to open database: xbmc_video32 [1049](Unknown database 'xbmc_video32')"

So i guess i have to start over with the sql stuff.. Smile
What version of XBMC have you installed because watchlist is only compatible with XBMC Eden11.0 and that uses "xbmc_video60" database
I use Eden.

I am totally lost, been googling about this MysQL stuff for days now and i dont get it straight Sad
can you upload your advancedsettings.xml and your full Debug Log on http://pastebin.com and paste the link here? Maybe there something wrong in there
http://pastebin.com/98FFfDAH Debug

Sorry but i had to take huge chunk out because of the size, but all of it was just about the " ERROR: Unable to open database: xbmc_video32"

http://pastebin.com/vyecc8Z4 .xml

Thanks alot!
Maybe i should elaborate on a few things aswell.

Since my media is on a server, and i dont have and i cannot run XBMC on it (No grfx), i've tried having the Mysql server running there, i've tried having it run on this machine that has XBMC, (Changed the Ip's ofc)

But not sure what to do next. And i cannot find any information whether or not i need XBMC running on the same machine as the mysql server.
Possibly a privilege problem because it can't create one.

Are you sure are priveleges are set in your sql server?

Here's some info:
sync multiple XBMC



Side note:
Best is to install Eden RC2 cause RC1 contained a little bug.
I used "GRANT ALL ON *.* TO 'xbmc';"

If that is correct?
Should be fine...at least if the command was accepted on MySQL shell...
Can you see any database created by XBMC?
Can i check it somehow?
Oh, yeah i have "MyVideos60" and "MyVideos34"

And now when i started, i got up to 60fps and could navigate through XBMC; but still got the same errors in the debug log :S