Kodi Community Forum

Full Version: Revo 3610, Set to IEC audio = Crash
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I installed XMBCbuntu. Installed all okay.

Added a source and all played okay.

Changed sound setting to IEC so it pumps out to my surround sound system.

After restarting the box so changes take effect. XBMC now crashes and relaunches when you play any film.

Any ideas? I've also reverted all the changes and it still crashes.
Same Issue here. Re-install do not help still same issue......
I have the same issue using Asrock ION 330


Since yesterday I did a clean reinstall again and did not enable any addons, only added a source and configured my audio options to IEC958. Movies played without errors, chose reboot in the shutdown menu and now it crashes everytime I try to play a video Sad
I have the exact same issue as well. Had no choice but to switch back to Dharma for the time being.

Zotac ZBOX HD-ID11 (ION2 Chipset)
Mine is also a ION 330, but Zotac.
I tried to re-install a few times and found that the error occurred when I turned up Master volume up in "XBMC Audio Mixer" and then re-booted. So I stopped tuning any settings in XBMC Audio Mixer, and instead I did it in Volume amplification in OSM while playing a video, and then set as default for all movies.

Now all is working again.

Hope that helps.
I reinstalled again and is now using audio via HDMI, no crashes so far, maybe I will try to switch to Optical again and not go into the Audio Mixer. I think it is a critical bug, it makes XBMC absolutely useless since you cannot play anything and you have to reinstall to get rid of the error again.
And here I was wondering wether the ION 1 gpu made problems with the new XBMCBuntu now...wew, glad that it was ""only"" the audio setting.
I can confirm this also, sadly resetting the audio preferences away from the optical connector does not create a work around...

Using the logs above, does anyone have any suggestions? I'm not even sure where to start....
I have had the same issue but I have an AMD Phenom II Gigabyte(GA-MA785GM-US2H) system using built-in Video and running Audio through HDMI. No resolution so far, system still unusable. Is there a way to rollback an installation?
Another ASROCK Ion330 with this issue
I have this issue now. Using Zbox HD id40 and installed xmbcbuntu without issue got everything working using optical audio ic956 also (something like that) anyway after enjoying playing all weekend I just booted into it with this issue. Made no config changes recently. Just stopped working. Crash log in temp shows audio device error or alert at the end of the log.
Can everyone who are having issues upload the crashlog to pastebin or a similar site? There are quite a few people reporting this issue in separate threads. I'll edit this post when I get home with mine.

i had the same issue.
my basic setup was xbmc-live with pulseaudio installed as daemon for network usage and a central mysql db.

i upgraded to eden by the following path, because, my setup on xbmc-live was exaclty that way:
.) format with xbmcbuntu
.) added the sources.xml advacedsettings.xml and password.xml from the old setup
.) installed pulseaudio, pulseaudio-module-zeroconf
.) added pulse as default device to ~/.asoundrc
.) configured xbmc to use user defined device "pulse"
.) added xbmc-user to group pulse-access

anyway - this was doing very well, until yesterday; When i booted up the box, i had to discover the problem described earlier in this thread.
i came across these series of threads, where everybody, seems to have the same problem, and some people are suspecting pulse to be the faulty part.
so i wanted to disable pulse for good and try if it did the trick. so when i opened up my .asoundrc in vi, it showed around 40 new lines, which i never came across before - starting with the following:

state.NVidia {
control.1 {
iface MIXER

at this point i was kind of clueless what to do or think and just moved my .asoundrc to asournrd-bkp to see if a new one was generated somehow and how it got filled with values. i rebooted, the box to xbmc, switched on debug logging and when i tried to play a file... it worked!

there was no new .asoundrc created in the home directory of my xbmc user, i left the audio settings in xbmc as i had them before (analog / userdefined device "PULSE") and even in opebox, the sound is working now.

i dont know the exact background of why this is working for me, but i will let you know as soon as i find out.
and please, for the sake of god, if anyone is as stupid as i am and starts to delete files or something - a least keep them backed up and remember what you did!

This is my XBMC Crash Log


I noticed this:

/home/xbmc/.asoundrc may be old or corrupted: consider to remove or fix it\nALSA lib conf

and my fix has been:

cd /home/xbmc
cp .asoundrc .asoundrc_bck
rm .asoundrc
sudo reboot

My system works well now.
Pages: 1 2