Kodi Community Forum

Full Version: Subtitles over UPnP streams
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7
Hi, I'm running default OpenWrt BB on TPLink MR-3420. But hey I now try to run Kodi as a client and it do not open subtitles as well from miniDLNA, What plays with subs its the TV. There's a new issue to investigate. Any news let us know.
Happy new year for you to buddy. Smile
I have same problem here!

I have kodi on pc as server and watching movies over dlna on LG

The problem is when i used kodi isengard on windows 7 x64 external subtitles worked on my tv but yesterday i build a new server and install fresh version of kodi jarvis on windows 7 external subtitles didn't worked on my tv. Did any one have this problem?

Sorry for bad english.
Hello! I have a LG TV too.
Just update to Kodi 16 and same here, only on windows the problem with external subtitles over UPnP.

Linux Mint working
SPMC on Android (still 15.0) working.
Windows 10 x64 not working

Even on Mint from virtualbox got it working.
probably is the good and old windowze Big Grin

Did you notice a delay of about 20s while the TV loads the video from windows Kodi?

As i said before, with a clean install of windows it works for some time, but after a few weeks it stops, but why?

I'll kepp using minidlna for windows.
As far as i know it is limited to LG SmartTV, good if new reports of working or not on any SmartTV.
It never worked...
I migrate to another UPNP server!
Universal Media Server.
They won't fix this issue in next 10 builds!
Hi!
Free will my friend. Open Source works this way.
Kodi is the most and respectable media server in the world.
UMS works under java. Java, love it or hate it -> hi again
give a try to minidlna for windows, works for me.
http://www.hardware.com.br/comunidade/se...a/1365040/
My post at forumgdh.net its a pt_BR forum. Google is your friend.
cheers.
Hi

I have read all of this thread and i didn't see any solution for me. Can you please help me?

I have a Raspberry 3 with kodi 15.2 (openelec) using as DLNA server (media server) and a TV Sony w700b. I don't see the external subtitle on TV. Works like a charm with external subtitles if the content is on an USB stick but over DLNA it works only with embedded subs.

Do you have a solution for me?
Hello.
Here still the problem only with windows Kodi, from other operating system it works, but my TV is LG-42LA6200.
If you only wants to stream, give a try at raspbian and miniDLNA.
Did you check the UPnP settings at advanced level?
Image
well... i just try openELEC in my notebook booting via PXE from my router. DLNA works fine with external subs to the TV.
Hi. subtitles are back with Kodi 16.1 and windows 10 x64. Thank you Kodi Team.
Hi guys,
i've read the whole thread but i still don't have a solution

Here's my issue:

On my Samsung Smart TV UE40j6200 i cant see only some external subtitles.


Here a better explanation, my folder structure is:

Series/Mr.Robot/Season1/episodes.mkv with .srt subtitles with same name

And i can see this series with subtitles via uPnP DLNA on my smart tv

Same folder structure, with another series, GoT, and there i cant see subtitles

I can't see rly differences between files, still i can't see subtitles for GoT

I've tried with and without the option "Look for external subtitles" and it doesn't change anything, always mr robot correct and got no, the only difference is a huge loading time with the ext subtitles option enabled

My S.O. is Windows 7 and running kodi 16.1 Jarvis downloaded from the official website.

If some1 of u can help i'll be very grateful

P.S. on kodi on PC i can see sub correctly, and if i use samsung smartview i can see the subtitles correctly, only on kodi UPNP it doesn't work


EDIT: I noticed now that on the tools option on my smart TV, on Mr.Root i have the "subtitles" option, while with GoT no. Don't know if it helps or not
Basically the same issue i was getting here. Except my tv is a LG and it NEVER worked on older versions of KODI for windows.
I really dont know why it works in the latest versions. But if one works and another does not for you, maybe try to convert the subtitles (.srt) files to UNICODE, or UTF-8. Can use notepad for that into 'save as' options, or if you want a real editor try notepad++ in the option Encoding -> convert to UTF-8 without BOM.
ok, tonight i'll give it a try and let u know how it went.

I'll convert em to UTF-8 with same extention .srt or i shall change it into something else? (in this case which extension?)

ty vm for the advices
Here is how i use. Same filename and .srt for subtitles, pt_BR mine.

Image
Hi, it's me again, i've tried what u said, to confert in UTF but no results.

Kodi server doesn't send subtitles to the tv.

I can post some logs if it can be usefull for anyone, developers first

Let me know if there are some other tests i can do to help improve this wonderful system Smile
(2013-01-06, 19:44)Forage Wrote: [ -> ]The problem can be twofold, depending on which server you use:
1) Your server might serve the subtitles in a way only Samsung systems understand
2) XBMC does not support external subtitles through UPnP

Serving external subtitles is not part of the UPnP specs, and different vendors have therefore started using different methods. There are basically 2(/3) ways that are being used at the moment. If you can, give Serviio a quick try (it's a painless server for a quick test). At least that server uses both methods so you can determine if it's a server issue.

I do not know XBMC well enough to know if it supports external subtitles through UPnP in the first place, but I assume it is. Not using it myself though.

DLNA does not support subtitles but my Panasonic TV can handle them when using DLNA and KODI.

Is that possible because the PANASONIC has a "DLNA extension" (as the SAMSUNG tv have) and Kodi exploits that?

I'm confused! If i change brands will i have external subs with other TV brands?

How about internal subtitles (inside the video container)?
@marcolopes

This is the second historic thread you have resurrected to ask the same question you have asked elsewhere. In addition to a duplicate that has already been binned.

Any further new posts in other threads and they will be deleted.
Pages: 1 2 3 4 5 6 7