Kodi Community Forum

Full Version: xbmcbuntu eden 11.0 won't play video (crash)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Just upgraded to xbmcbuntu 11 and watch a movie just fine but after trying to use the built in web browser and installing some video add-ons, all movies will not play. When I select a movie it gets some scrambled lines for a second and it has an X in the middle of the screen. After that it flashes the xbmc logo and goes back to the home screen.
xbmc is connected(wired) to a Windows 7 PC that stores all the movies, and like I said, worked just fine until this happened.

I tried uninstalling those add-ons but no luck

Log file:
http://pastebin.com/4km4h6y6

Any ideas? I'm not sure where to look. I couldn't tell from the log file what happened.
Are you using audio via Optical cable or have you changed the volume in the Audio Mixer?

I have the same problem, take a look at http://forum.xbmc.org/showthread.php?tid=126485
New debug file.
I guess it was crashing and then restarting so that first log file did not show anything. I had to use the xbmc.old.log to see the problem.

I am using audio over HDMI but have had to set it to analog output to work in older version of eden.

here are the last few lines
17:07:12 T:2681789296 ERROR: PulseAudio: Failed to connect context
17:07:12 T:2681789296 ERROR: PulseAudio: Failed to create context
17:07:12 T:2681789296 ERROR: Unable to open audio mixer

full file:
http://pastebin.com/7jGbqAM9
Crash log from Today:

http://pastebin.com/eU9reDr1

I can't get it fixed using any settings withing xbmc.

What do I need to do to troubleshoot this?
(2012-03-29, 03:14)cank Wrote: [ -> ]I can't get it fixed using any settings withing xbmc.

What do I need to do to troubleshoot this?

I am not a developer. It sounds like you may have found a bug. This is the xbmc bug reporting process:
http://wiki.xbmc.org/index.php?title=HOW...bug_report

I searched the bug trac for Eden crashes. I found 2 closed bugs for crashes, reported in Eden RC1 & RC2, but both were fixed in the Eden release. Feel free to search for yourself, I could have missed something. If you are not running the release version, you should upgrade to that. If you are, you should consider creating a bug for your crash. You wiill need to first install gdb, so your crash logs will include the backtrace. Then recreate the problem and attach your new crash log to that bug submission.
On my Zotac box (Nvidia ION 2) I uninstalled Pulse and set up ALSA according to this guide:
http://wiki.xbmc.org/index.php?title=HOW...controller

It was working fantastically with Eden up until I upgraded to the final release. Now I'm getting crashes every time I try to play a file, so I don't claim this will solve your issue, but if you think your problem is related to Pulse this might be a way to eliminate that variable.
I fixed the problem by going to the command line (alt-ctrl-f2) then type 'rm .asoundrc' to remove the config file for the sound. You should be able to playback movies now, but you get a sound error. Then I just reconfigured audio input in the settings and it works again. I do have to say that I have simple analog 2.0 audio.
@cank: I suggest you upgrade to this: http://forum.xbmc.org/showthread.php?tid=134252