Kodi Community Forum

Full Version: Allwinner A10 : Is XBMC ported to MALI-400MP ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Ok, same error... Any Idea what this means?

/usr/lib/libpython2.7.so: file not recognized: File format not recognized
Can you paste the whole config.log somewhere?

sorry for the late reply. Here is the complete config.log:



just installed a fresh Ubuntu 12.10 64Bit and I get the same error while cross compiling.

Any clues, help? Sad
Ok. Here we are. I think this is a error, because of a wrong python version. iirc Linaro 12.10 - your rootfs - uses Python 3.x. In the depends.mk the used Python Version is fixed to 2.7.
So go to your rootfs and check wich version of python is installed. Do you have a /usr/lib/libpython2.7.so?
You can either try to get 2.7 to your rootfs or change the values in depends.mk to your version, e.g. export PYTHON_VERSION=3.2
Maybe this helps.

And don't forget to have libpython* python* python*-dev installed:



BTW: Seems that i solved some merge conflicts in my git repo a little bit dirty and implemented a few buggy lines/files. I'll clean out Frodo-branch the next days and push it once again. Clean and with a readable commit-history. Just for your info.

you are right there is no /usr/lib/libpython2.7.so*

I did a chroot /mnt/rootfs-a10 /bin/bash. Now I will install the python dev packages.

Do I have to install all the packages outlined in the howto on linux-sunxi.org on the rootfs as wellHuh

A few more questions about your great xmbca10 repo:

Is a git pull sufficient to get all changes of your git repo instead of downloading the whole repo again? It is very slow. Sad

Do I have to switch to the frodo branch prior compiling and how?

Sorry but I'm a noob on this.

Best Regards,

Yepp there is only libpython3.3-dev available. I will try to change the depends.mk.
You have to do at least a "apt-get build-dep xbmc" on your rootfs to ensure, that all dependencies are installed. Follow the steps on linux-sunxi.org/XBMC to prepare your rootfs the right way.
The listed packages in the wiki will not be the same as you will get. It was just my c&p a time ago. Try "export PYTHON_VERSION=3.3"

I'm a very noob to git. So I'll start from the beginning. Erase the Frodo branch, and re-push my local branch. It's forked from empat0 with 3 additional commits.
At now the default branch on github is redirected to the Frodo branch. Else, do a "git checkout Frodo" before compiling. It should work, but there will be a cleanup. Maybe tonight.

Ahh I knew I missed something. Of Course the rootfs has to have all the packages as well. I will try that and see how it goes.

Thanks a lot for all your help so far.
Ok, I skipped the cross compiling and compiled it successfully under linaro quantal alip on the gooseberry. Took hours to complete but now I have XBMC frodo. Smile


It is very slow when trying to access music from my nas. It's a lot faster under android. I must have missed something, I can't believe it is that slow running natively under Linux.
There was made some workaround to use the android-binaries via libhybris. It seems, that this library isn't affected by the weightp=1 bug.
Would be good if someone can give it a try: http://linux-sunxi.org/CedarX/libve
Hi Rellla,
I made an image running XBMC using android-binaries via libhybris.
You can find it here: http://hackbmc.blogspot.it
I tested the performance on a couple of videos that were played blurry with artifacts with linux drivers and now they are played correctly.

could this be the breakthrough we are all waiting for? or are there still other critical issues to be addressed
It's surely no breakthrough, but at least a nice workaround if there aren't any other issues.
Support of Allwinner is not existing yet - although there is kind of a "mini"-contact, and we don't know of something like a license to use and distribute the binary blobs at all.
Hi there!
I found source codes but I don't know if they are valid or so.
For anyone interested.
i tried to boot the HackBMC version 0.02 image from warner83 with mele a2000. I swaped the script.bin with one from a mele image, but it fails. I changed the screen0_output modes with bin2fex to 1080p50 (should work on my tv). Do i have to change something else?