Kodi Community Forum

Full Version: MCE Remote LEFT, RIGHT, UP, DOWN etc. Issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Forum!
I have a strange issue with XBMC V11 (Windows XP). Non eHome.

I have a Windows MCE Remote control and it works in Windows. e.g. When I press the UP Key it transforms to VK_UP and is recognised by Windows as UP (Key UP).
When I want to use it in XBMC it (the up commend) transforms to escape. I can reproduce by using ShowKey. It will display exactly what is pressed: say I press left on the physical keyboard it displays VK_LEFT and correctly translates to the <left> key in ShowKey. if I press the left button on the remote it says exactly the same => VK_LEFT BUT it translates to <escape>! This for almost all keys (0... 9 works).

Any clue?

What does the debug log show when you press the arrow keys? Enable debug logging from System settings, System, Debugging, and restart XBMC then wait a minute or two for all the startup tasks to finish. Press left, then right, then up then down, then exit XBMC (using the mouse if possible to avoid more keystrokes).

Open the debug log by pressing Windows-R and in the Run dialog type:


(including the quotes). Click OK and the log should open in Notepad. Copy and paste the log into http://pastebin.com/ and post the link it gives you here. I'll have a look at the log and see if I can spot the problem.

thanks for picking this up.

Here is the pastebin:

In the meantime I did some additional reasearch. 1. on XP it uses ite remote controller service to "translate" to keystrokes (it's version 1.0). Nethertheless it seams that this works fine for Windows, so an up on the remote would be understood by Windows (on the desktop) as VK_UP. 2. I tried with XBMCbuntu live and it works out of the box.

I assume it must be some kind of issue with characters? leading special chars or utf, ansi or else? Just guessing...

Thanks again
Hi Martin,

you might want to try additional settings in XBMC first:
1. Try what happens if you set the remote being understood as "key strokes": System / Settings / System / Input devices (or sth like that, I use German version), activate "Remote sends keyboard strokes" (or sth. like that)
(I personally didn't use this setting as it makes it difficult to navigate in the case of entering any text)

2. You might want to try out the XBMC MCE Remote Add-on: System / Settings / Add-ons / Search: Type in MCERemote
(I didn't try this one out)

If this doesn't help, you might want to give EventGhost a try (you have to deactivate above add-on before): here you can freely configure which remote key is translated into "what" and even you can address all the (sometimes reserved) buttons on your remote http://www.eventghost.org/

Hope this could help you.

Kind regards from Switzerland - Christoph

Hi Christoph (Hoi Chrischtoph) Wink
1. tried that before, no change
2. that will only work as far as I understood if you have eHome drivers (usb, mce remote) might be wrong here

Will have a look at eventghost. THANKS.

Best Regards
Martin (CH)
Hoi Neighbour! Smile

Yes - 2) needs eHome drivers.

If you need assistance on EG (kind of tricky at start to find the right device driver to address), let me know please.
It's OT here unless others also would like to know more about it...

Kind regards from Lucerne / Zoug

The log shows:

DEBUG: SDLKeyboard: scancode: 01, sym: 001b, unicode: 0000, modifier: 0

so XBMC is receiving a VK_ESCAPE. XBMC and Showkey respond to the keyboard in very similar ways (deliberately so) so I have no idea why you're seeing a difference.

Dear JR
yes, that's right. It's strange, because ShowKey shows KeyID 37, VK_LEFT and then as "input" / COPY <escape>... I will upgrade to VISTA / 7 (depending on the drivers) and revert back with status.

Thanks for your help
VISTA did the job. New ite driver, everything flawless.

Thank you all for your support and have a great day.