Kodi Community Forum

Full Version: Acer Revo R3700 - Only 5.1 Audio Plays
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I have just upgraded from Dharma (XBMC Live) to Eden (XBMCbuntu) and now have an issue with audio. After searching the forums I seem to have the opposite issue that others have.

I can play movies with 5.1 audio and the movie and audio play perfectly. However if I try to play a movie with MP3 audio, the picture plays fine but no audio. If I play an MP3 file then I also get no audio.

I have an HDMI connection to my TV, and use the optical cable from the Revo to connect to my Amp. Everything worked fine in Dharma.

Audio Output - Optical/Coax
Speaker Configuration - 5.1
Boost volume level on downmix - check
Dolby Digital (AC3) capable reveiver - check
DTS capable receiver - check
Audio output device - Defaults (ALSA)
Passthrough output device - ice958

Checked in alsamixer and only the mic lines are muted.

Would appreciate any suggestions as to how I can fix this.
What happens if you switch "Dolby Digital (AC3) capable receiver" off? See my thread at:

http://forum.xbmc.org/showthread.php?tid=126445

And thank you for posting your settings, they (mostly) solved my problem!
Thanks for the reply. If I switch off "Dolby Digital (AC3) capable receiver" then I still get no audio from MP3.

Glad my settings were of some use to you. Smile
JayW,

Try this:
http://forum.xbmc.org/showthread.php?tid...pid1063134

Hopefully that helps!

Good luck.
(2012-04-01, 19:52)Rubbernuts Wrote: [ -> ]JayW,

Try this:
http://forum.xbmc.org/showthread.php?tid...pid1063134

Hopefully that helps!

Good luck.

Thanks for the link. If I crank my amp up to full I can actaully hear the MP3 audio now, although quiet.

My aplay -l looks like:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

I am not using HDMI for my audio though. I have an optical cable to my amp.
JayW,

In this case, I would set your output to PLUGHW:0,1

You may have to play with the first option where I set mine to HDMI to something else. In your case, just set the output to the CUSTOM and then cycle through the settings available to you instead of HDMI.

Note that you will have to stop playback and restart playback for this to work.

Also note that the + and - keys on your keyboard could have adjusted the playback level in XBMC. (By your backspace key.)

Give me an update.

--Rubber
All working now. Thanks for taking the time to help Rubbernuts.

The + key next to the backspace did it. It was set right down. All audio working now as before the upgrade. Smile

Excellent news JayW!!!

Glad I could help!

Now sit back crack a brew and enjoy the Sunday!

Edit: Did you have to change the HDMI setting to something else? If so, what did you choose?
I didn't need to change the audio output settings. It's working now so I'll leave them alone!
I'm having the exact same problem but on a Lenovo Thinkcentre mini PC

I get crystal clear 5.1 - 7.1 surround sound but it never plays back Stereo.

Here's my aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: CMI8738 [C-Media CMI8738], device 0: CMI8738-MC6 [C-Media PCI DAC/ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 1: CMI8738-MC6 [C-Media PCI 2nd DAC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CMI8738 [C-Media CMI8738], device 2: CMI8738-MC6 [C-Media PCI IEC958]
Subdevices: 0/1
Subdevice #0: subdevice #0

I've been through all the options one by one in Audio Output Device and even tried PLUGHW:0.1 and plughw:0.1
My pass through device is iec958...

Messed with the alsamixer but nothing is obviously wrong there.

I also tried the old .asoundrc trick in the home directory, but nothing seems to work

Any help would be great!

In the previous XBMC Dhama, it worked no problem with help of the .asoundrc file. Oh by the way I'm running XBMCbuntu live installed to my Lenovo ThinkCentre. I decided to switch from running XBMC on top of Ubuntu.
Try PLUGHW:0,1 comma not period between 0 and 1.

try 0 1 and 2 in place of the last number between starting playback of files
Hi Cubicgarden,

In alsamixer I made sure everything except the mic channels weren't muted. Then held the + key (next to backspace) the turn the volume up full. I believe the upgrade to Eden must turn this down as like you all was working fine in Dharma. The + volume key must have nothing to do with 5.1 sound levels.
Thanks All for trying to help... But still no sound Sad

I have switched to comma formatting
Tried PLUGHW:0,0, PLUGHW:0,1. PLUGHW:0,2 and playing back stereo files inbetween
Even started restarting the whole machine between changes

On the Alsamixer, I turned everything on including the Mic channels. Tried the +key to turn the volume to the top but still nothing.
Yes when playing back multichannel sources, it indicates the passthrough is being used and there is no control over the volume (this is normal)

But still I can't get stereo out or even sound effects like the popping bubbles... Sad

Considering installing Ubuntu and installing XBMC inside of it like I did before instead of using XBMCbuntu Sad
So I FINALLY got stereo sound working...

I set the Audio output device to iec958 (ALSA) instead of anything else.
I also enabled every single thing in aplay -l, and installed Ubuntu-desktop (sudo apt-get install ubuntu-desktop)

Not sure if the last step is what did it or not, but dare not mess with it to see if that was what was missing Smile