Kodi Community Forum

Full Version: Eden and Video Scraping
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm having some issues with the scraping of my entire movie database.

I'm using the scarped that comes with Eden, The MovieDB.
Every time I do a scan to add media in any directory, it tends to change the names of the movies.

For example I've this Italian commedy directory and there are

Amici Miei - Atto 1
Amici Miei - Atto 2
Amici Miei - Atto 3

And this are how the movie are actually called.
When it scraps for data and covers, it changed the first two in something else, and find the wrong cover for the 3rd movie.
And does this scrap all over the database, chaning names when I don't want!

Inside the scrip there is an option called: "KEEP ORIGINAL TITLE" ... and guess? It doesn't work.

Any idea how to solve this mistery?
Are they folders or files?

If you refresh them (from video info) it should allow you to choose which one to match to. My bet is it's the - (themoviedb treats it as "except" in the search query - i.e. find movies containing "Amici Miei" but not containing "Atto 1")
(2012-04-02, 23:30)jmarshall Wrote: [ -> ]Are they folders or files?

If you refresh them (from video info) it should allow you to choose which one to match to. My bet is it's the - (themoviedb treats it as "except" in the search query - i.e. find movies containing "Amici Miei" but not containing "Atto 1")

I do have many folders but not single folders for single movies.

I can understand your argument but when I used Dharma, the scraper NEVER mistook a movie for another and never changed the names on his own.

It's okey if he can't find a movie or use another movie by mistake, but not that he force change the names in the library and the option from the scraper doesn't seems wot work at all
Are you confused with showing things in files mode perhaps versus library mode, and you've got the option "use library title for files" enabled (settings->video->file lists) ?

XBMC has always used whatever the scraper returned as the title in library mode (whether it be completely accurate or completely wrong - we take the best match available based on the sometimes unreliable search that websites provide).
(2012-04-02, 23:49)jmarshall Wrote: [ -> ]Are you confused with showing things in files mode perhaps versus library mode, and you've got the option "use library title for files" enabled (settings->video->file lists) ?

XBMC has always used whatever the scraper returned as the title in library mode (whether it be completely accurate or completely wrong - we take the best match available based on the sometimes unreliable search that websites provide).

Found the culprit.
Following your settings-video-file list there was the metadata stuff active Smile
Now it shows the proper names.

Thanks!
Great. Note that you're viewing things in files mode, not library mode - this is where the confusion is. You'll notice they're still "wrong" in library mode, so refresh them from there and pick the right movie.