Kodi Community Forum

Full Version: XBMCbuntu remote will not wake up the computer
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I am having a challenge getting the remote to work correctly on my Zotac machine with XBMCbuntu. I am reading commands from a forum post to fix my issues, but being I am a windows person and not a Linux guru, when I type a Linux command and it doesn't work I literally have zero clue why. The issue I am having is my remote will suspend the machine but it will not wake it up. I did the following command that worked in xbmclive for rc.local file, but it doesn't work in XBMCbuntu:

'echo USB0 > /proc/acpi/wakeup'

so reading more posts I saw a post to add the following information, and one machine it does wake up the machine, but my Zotac it doesn't:

'echo enabled > /sys/bus/usb/devices/2-3/power/wakeup'

I look at this command and the '2-3' I am not sure what that exactly means and what the different numbers are, and doing a google search I am not getting any answer to help resolve my problem. When logged into putty on my windows machine and connected to my xbmc machine and do a 'lsusb' I get the following information:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 004 Device 002: ID 1784:0008 TopSeed Technology Corp. eHome Infrared Transceiver
Bus 004 Device 003: ID 046d:c518 Logitech, Inc. MX610 Laser Cordless Mouse

my remote is the Bus 004 Device 002, so I tried changing the 2-3 to 4-2 but it still is not waking up. At this point I am not sure how to fix this problem, and being not very Linux knowledgeable(I will admit it) I really don't know how to fix the command so it will work with my remote to wake it up from the power button on my remote control. If anyone would be of assistance to help me resolve this issue it would be much appreciated. Thank you.
I can't be the only one that has had this issue.
'echo enabled > /sys/bus/usb/devices/4-2/power/wakeup' is correct, I believe, from reading your lsusb output.

You could try different USB ports, one at a time, in the other line in the rc.local file, i.e. change USB0 to USB1, USB2, etc, trying suspend/resume after each change until you hit the right one.
Try this post http://forum.xbmc.org/showthread.php?tid...#pid835642

The new forums has messed up the formatting so the bold and underlines dont show,keep an eye out for the [u] + [b] tags
Thanks, I will try the suggestions.
I had trouble setting up wake with my Zbox too, but for me the more common problem is that I can't get the machine to stay suspended. Sometimes it wakes up right away when I try to put it to sleep, and sometimes it stays asleep until I leave the room and I come back to find it awake. I'm of the opinion that that issue is related to my flirc though. I have been successful waking the device with only the USB0 line added to the rc.local file. What kind of IR receiver are you using? And what is your result from 'cat /proc/acpi/wakeup' ? Does disconnecting the IR receiver and attaching a USB keyboard allow you to sleep/wake properly?

For me, I've found that as long as USB0 is enabled in wakeup, I can wake the machine with my remote even without a line for '/sys/bus/usb/devices/X-Y/power/wakeup' . Also, what model is your Zotac? Mine's a ZBOX HD-ID34BR, and on my system, I have better results if I use a USB 2.0 port and not a 3.0 port. And at least on my system, all four ports seem to be on hub USB0. None of the other numbers let me wake it up regardless of which port I have the receiver connected to.

Also, perhaps a dev can answer this faster than I can check my logs, is the stuff in rc.local run as root?
(2012-04-06, 23:43)digitalb0y Wrote: [ -> ]I had trouble setting up wake with my Zbox too, but for me the more common problem is that I can't get the machine to stay suspended. Sometimes it wakes up right away when I try to put it to sleep, and sometimes it stays asleep until I leave the room and I come back to find it awake. I'm of the opinion that that issue is related to my flirc though. I have been successful waking the device with only the USB0 line added to the rc.local file. What kind of IR receiver are you using? And what is your result from 'cat /proc/acpi/wakeup' ? Does disconnecting the IR receiver and attaching a USB keyboard allow you to sleep/wake properly?

For me, I've found that as long as USB0 is enabled in wakeup, I can wake the machine with my remote even without a line for '/sys/bus/usb/devices/X-Y/power/wakeup' . Also, what model is your Zotac? Mine's a ZBOX HD-ID34BR, and on my system, I have better results if I use a USB 2.0 port and not a 3.0 port. And at least on my system, all four ports seem to be on hub USB0. None of the other numbers let me wake it up regardless of which port I have the receiver connected to.

Also, perhaps a dev can answer this faster than I can check my logs, is the stuff in rc.local run as root?

I have a Zotac Mag HD-ND01, let me try with just the command cat/proc/acpi/wakeup command. I am using the TopSeed Technology Corp. eHome Infrared Transceiver IR receiver.
(2012-04-06, 23:43)digitalb0y Wrote: [ -> ]is the stuff in rc.local run as root?

Yes.
(2012-04-06, 23:48)amcfarla Wrote: [ -> ]
(2012-04-06, 23:43)digitalb0y Wrote: [ -> ]I had trouble setting up wake with my Zbox too, but for me the more common problem is that I can't get the machine to stay suspended. Sometimes it wakes up right away when I try to put it to sleep, and sometimes it stays asleep until I leave the room and I come back to find it awake. I'm of the opinion that that issue is related to my flirc though. I have been successful waking the device with only the USB0 line added to the rc.local file. What kind of IR receiver are you using? And what is your result from 'cat /proc/acpi/wakeup' ? Does disconnecting the IR receiver and attaching a USB keyboard allow you to sleep/wake properly?

For me, I've found that as long as USB0 is enabled in wakeup, I can wake the machine with my remote even without a line for '/sys/bus/usb/devices/X-Y/power/wakeup' . Also, what model is your Zotac? Mine's a ZBOX HD-ID34BR, and on my system, I have better results if I use a USB 2.0 port and not a 3.0 port. And at least on my system, all four ports seem to be on hub USB0. None of the other numbers let me wake it up regardless of which port I have the receiver connected to.

Also, perhaps a dev can answer this faster than I can check my logs, is the stuff in rc.local run as root?

I have a Zotac Mag HD-ND01, let me try with just the command cat/proc/acpi/wakeup command. I am using the TopSeed Technology Corp. eHome Infrared Transceiver IR receiver.

I tried just doing doing the command by itself with other command removed:

'echo USB0 > /proc/acpi/wakeup'

and it goes to a suspended state, but will not wake up.
(2012-04-06, 23:48)amcfarla Wrote: [ -> ]let me try with just the command cat/proc/acpi/wakeup command.

Sorry, I should have been more clear. cat just prints the contents of a file. So when you run 'cat /proc/acpi/wakeup' I was asking if you could paste the result here to verify that USB0 is in fact getting enabled at startup by what's in your rc.local file.
(2012-04-07, 00:00)digitalb0y Wrote: [ -> ]
(2012-04-06, 23:48)amcfarla Wrote: [ -> ]let me try with just the command cat/proc/acpi/wakeup command.

Sorry, I should have been more clear. cat just prints the contents of a file. So when you run 'cat /proc/acpi/wakeup' I was asking if you could paste the result here to verify that USB0 is in fact getting enabled at startup by what's in your rc.local file.

this is what I am getting with that command you suggested(unfortunately my expertise is in windows so I am little fuzzy with all this) but it looks like USB2 is disabled.

[email protected]:~# cat /proc/acpi/wakeup
Device S-state Status Sysfs node
SMB0 S4 *disabled pci:0000:00:03.2
USB0 S4 *enabled pci:0000:00:04.0
USB2 S4 *disabled pci:0000:00:04.1
US15 S4 *disabled pci:0000:00:06.0
US12 S4 *disabled pci:0000:00:06.1
NMAC S5 *enabled pci:0000:00:0a.0
PBB0 S4 *disabled pci:0000:00:09.0
HDAC S4 *disabled pci:0000:00:08.0
XVR0 S4 *disabled pci:0000:00:0c.0
XVR1 S4 *disabled
P0P5 S4 *disabled
P0P6 S4 *disabled pci:0000:00:15.0
P0P7 S4 *disabled pci:0000:00:16.0
P0P8 S4 *disabled pci:0000:00:17.0
P0P9 S4 *disabled pci:0000:00:18.0
PWRB S4 *enabled
Ok. It's probably ok that USB2 is disabled, but you could see if anything changes by adding:

echo USB2 > /proc/acpi/wakeup

to your rc.local file directly below the similar USB0 line, saving and rebooting. Then a 'cat /proc/acpi/wakeup' should show both USB hubs as enabled for wakeup and you can see if that allows you to wake the system with your remote. Also, see if a regular USB keyboard in place of your IR receiver can wake it up. If so, the trouble is with hardware/drivers/compatibility/etc. and not because something is incorrectly configured with your rc.local and wakeup files.
I tried adding both of these to the rc.local file, but still did not have success:

echo USB0 > /proc/acpi/wakeup
echo USB2 > /proc/acpi/wakeup

did the cat /proc/acpi/wakeup command, and it shows it is enabled:

[email protected]:~# cat /proc/acpi/wakeup
Device S-state Status Sysfs node
SMB0 S4 *disabled pci:0000:00:03.2
USB0 S4 *enabled pci:0000:00:04.0
USB2 S4 *enabled pci:0000:00:04.1
US15 S4 *disabled pci:0000:00:06.0
US12 S4 *disabled pci:0000:00:06.1
NMAC S5 *enabled pci:0000:00:0a.0
PBB0 S4 *disabled pci:0000:00:09.0
HDAC S4 *disabled pci:0000:00:08.0
XVR0 S4 *disabled pci:0000:00:0c.0
XVR1 S4 *disabled
P0P5 S4 *disabled
P0P6 S4 *disabled pci:0000:00:15.0
P0P7 S4 *disabled pci:0000:00:16.0
P0P8 S4 *disabled pci:0000:00:17.0
P0P9 S4 *disabled pci:0000:00:18.0
PWRB S4 *enabled


But I did discover with the keyboard plugged in, hitting a button on that brings it out of the suspend state, but the remote still doesn't work.

Just to make sure, do you have:

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax"

in your /etc/default/grub file? If so, maybe LIRC is the next thing to look at?
Any progress on this? I have pretty much the exact same issue as AMCFARLA. The command "cat /proc/acpi/wakeup" shows all of my USB ports enabled and using a simple USB keyboard will wake the system from Suspend mode. However, neither a mouse or the remote will wake it (like AMCFARLA, the remote will put it into Suspend/Sleep mode, but it can't wake it). I also have a TopSeed receiver so that this maybe a driver/hardware issue.
Pages: 1 2