Kodi Community Forum

Full Version: [Solved] Static Image Instead of Fanart ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
guys is there any way to set a static background image instead of fanart in movie list view? searched every where seems i couldn't find the answer! Confused

That would be Settings>Skin Settings>Backgrounds>Movies>Toggle Single Image Switch. If needed path to custom image.

This can be a bit tricky for new users... the option 'Movie' background shouldn't be mistaken for 'Home - Movies' the background menu is quite large and scrolls.
thanks patk... but what i want to do is .. disable the fanarts for all the movies and use a image instead but changing the backgrounds>movies>single image does not disable the fanarts in list view.. i not sure what i'm doing wrong!
If I'm missing a fanart... e.g. the movie doesn't have one, then it's replace with a default (this can be a series of images or just one, (specified or default) and would be in the skins settings, background... Movies and Videos (again don't confuse the 'home - movies and home - videos or the video and movies settings). I have some images of theater seats T! defaults to... (I believe an close up image of popcorn is the default) If you do have images... Transparency is all about fanart... it will show them. If you have fanart/folder.jpg in the root of a folder.... it might use them as backdrops. I suppose you could delete all your fanart in the user/thumbnail directory and get rid of all local folder fanart to ensure the default image. Next scrape would bring more..

Perhaps if you elaborate on what you're trying to achieve, there may be other solutions.. . Ronie works quite hard to ensure T! is showing plenty of artwork.
(2012-04-07, 18:19)PatK Wrote: [ -> ]Perhaps if you elaborate on what you're trying to achieve, there may be other solutions.. . Roni works quite hard to ensure T! is showing plenty of artwork.

thanks for your help... basically I just want the movie list view without fanart as the background, may be its just me, when scrolling through the movies, fanart is so bright and kind of takes away the focus looking at the movie list (names), even if I reduce the transparency effect, fanarts are too bright to look at the names.. It’s not a big deal, preferably diming the background a bit might resolve the issue I have... thanks anyway! Cool
it's not possible (and never will) to disable fanart in Transparency!
(2012-04-09, 22:08)ronie Wrote: [ -> ]it's not possible (and never will) to disable fanart in Transparency!

ronie you doing a great job... transparency is one of the best theme I have used, as I said my issue not a big deal.. but I don't like the word "not possible" though..
Wink
(2012-04-09, 23:29)Senthil Wrote: [ -> ]
(2012-04-09, 22:08)ronie Wrote: [ -> ]it's not possible (and never will) to disable fanart in Transparency!

ronie you doing a great job... transparency is one of the best theme I have used, as I said my issue not a big deal.. but I don't like the word "not possible" though..
Wink

impossible then? ;-)
(2012-04-09, 23:29)ronie Wrote: [ -> ]impossible then? ;-)


impossible... lol.. take it easy.. let me help you, the appropriate word would be "it wont look good" or "not deigned that way" Cool


if anyone interested in disabling fanart in transparency, here is how !

find and edit MyVideoNav.xml file located here C:\Users\(username)\AppData\Roaming\XBMC\addons\skin.transparency\720p

replace code "Fanart_Image" with "HideBackGroundFanart" without quotes

1. Hide Fanart

Code:
<visible>![Container.Content(Movies) + Skin.HasSetting(MoviesExtraFanart) + !IsEmpty(Control.GetLabel(6102))] + ![[Container.Content(TVShows) | Container.Content(Seasons)] + Skin.HasSetting(TVShowsExtraFanart) + !IsEmpty(Control.GetLabel(6105))] + ![Container.Content(Episodes) + Skin.HasSetting(TVShowsExtraFanart) + !IsEmpty(Control.GetLabel(6106))] + !IsEmpty(ListItem.Property(HideBackGroundFanart)) + ![[Control.IsVisible(592) | Control.IsVisible(598)] + !Window.IsVisible(MovieInformation)]] + ![Player.HasVideo + Skin.HasSetting(VideoBackgrounds)]</visible>

!IsEmpty(ListItem.Property(HideBackGroundFanart))

2.Bring-up Background image for movies (the image you setup in skin settings)

Code:
<imagepath background="true" fallback="special://skin/backgrounds/background-movies.jpg">$INFO[Skin.String(Custom_Back_Movies_Folder)]</imagepath> <aspectratio>scale</aspectratio> <include condition="Skin.HasSetting(AnimateBackgrounds)">backgroundanimation</include> <include>VisibleFadeEffect</include> <visible>IsEmpty(ListItem.Property(HideBackGroundFanart)) + IsEmpty(Fanart.Image) + [substring(Container.FolderPath,videodb://1/) | substring(Container.FolderPath,videodb://4/)] + ![Control.IsVisible(592) + !Window.IsVisible(MovieInformation)] + ![Player.HasVideo + Skin.HasSetting(VideoBackgrounds)]</visible>

IsEmpty(ListItem.Property(HideBackGroundFanart))

3.Bring-up Background image for videos (the image you setup in skin settings)

Code:
<imagepath background="true" fallback="special://skin/backgrounds/background-videos.jpg">$INFO[Skin.String(Custom_Back_Videos_Folder)]</imagepath> <aspectratio>scale</aspectratio> <include condition="Skin.HasSetting(AnimateBackgrounds)">backgroundanimation</include> <include>VisibleFadeEffect</include> <visible>[IsEmpty(ListItem.Property([b]HideBackGroundFanart[/b])) + IsEmpty(Fanart.Image) + !substring(Container.FolderPath,videodb://1/) + !substring(Container.FolderPath,videodb://2/) + !substring(Container.FolderPath,videodb://3/) + !substring(Container.FolderPath,videodb://4/) + !substring(Container.FolderPath,videodb://5/)] + ![Player.HasVideo + Skin.HasSetting(VideoBackgrounds)]</visible>

IsEmpty(ListItem.Property(HideBackGroundFanart))


Great... transparency without fanart just the way i like it! Rofl