Kodi Community Forum

Full Version: Library mode greyed out
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Now before you all go and say to search the stickies for a solution, I'd just like to say I have tried all advice and instructions found there.

All my media is on a QNAP NAS in a public folder. I have successfully created a movie and TV library in XBMC on ATV2 after adding the sources. I use Media companion to scrape all the info of the TV shows & movies prior to getting xbmc to scan for new content.

The big issue I am having is to create a music library in xbmc. I added the source via a smb share and I can manually browse/play all music this way. When I try to enable Library mode in the left pop out menu, I cant as this option is greyed out.

I have tried removing and adding the source as different kinds of shares, ie ftp etc, but still no joy. I even tried the old "turn it off and turn it back on" approach, but that has had no joy either.

I have all but given up, so have come here and hope someone can help

a small excerpt from the log file:

14:53:19 T:93859840 ERROR: SQL: The database disk image is malformed
Query: select count(idSong) as NumSongs from songview
14:53:19 T:93859840 ERROR: GetSongsCount() failed
14:53:20 T:93859840 ERROR: ADDON: extension 'downloader/' is not currently supported for service addon
14:53:21 T:93859840 ERROR: Previous line repeats 1 times.

please see for full log:

Code:
http://pastebin.com/vdvxQUMv

and for the log.old see:

Code:
http://pastebin.com/y3i3hp3f



thanks in advance!
Update:

As I am a novice at this, I normally just read the forums and follow similar advice given to others, so after spending time with google and these forums,

I decided to remove the following db files from /var/mobile/library/preferences/XBMC/userdata/Datebase

Mymusic16.db
Mymusic17.db
Mymusic18.db

Removed the source and associated files

Restarted xbmc and added only one album to source. Scanned item to library and was then able to select library mode.

Just to add, I had previously removed the source and only added this same album and was not able to select library mode.

So removing the .db files seems to have worked so far.

Am in the process of adding entire music source (+20K songs) and will report back on progress.
so far so good.

All operating as i was expecting.

Mymusic18.db has been recreated, but I am guessing this is due to the new library.

While thinking about it, there are about 6 Myvideo.db files. Are all of these really required?
Good to hear that it worked out! I had seen your post before, but totally blanked on the malformed SQL error.

You should only need the highest number. Since older builds of XBMC for iOS were in testing the DBs got updated often. Whenever that happens XBMC will make a copy to prevent hurting the original incase the upgrade goes bad. Since we're now on stable builds it will stay on Myvideos60.db, and the older ones are no longer needed.
Thanks Ned

It's always great to get feedback, on things. I will always try to figure things out on my own, and only start a thread when I can't. I know you guys have your hands full enough with sorting out everyone else's niggles, and I do hate being a burden on resources.

While I have your attention though, and at risk of hijacking my own thread, I was under the assumption that XBMC looked to the local folder first for .tbn's, nfo's and fanart before scraping. Is this the case?

Say for arguments sake I used XBMC to do an initial scrape of all media and allowed it to get tbn's and fanart etc.
Then I discovered programs such as mediacompanion and magic mp3tagger.

Would removing the sources and deleting all associated files in the GUI also delete all tbn's and fanart etc located in /userdata/thumbnails?

Then when re-scraping video's and tagging mp3's with the third party app's this info is stored locally, so why the need for a local cache on the ATV2.

I have seen from another thread how to tell XBMC to look to my NAS for these, but I hate wasting space, even if it's less than a gig.
It will look for those files first, but XBMC then uses them to populate its database and image files. The way XBMC is set up is that it will only work with a central database like that.
(2012-04-09, 12:12)Ned Scott Wrote: [ -> ]The way XBMC is set up is that it will only work with a central database like that.

fair play. Just as well it can be located external to the ATV2

Thanks for your guidance!
Hey there Ned

Just a quick one,

XBMC is not looking at the folder for a local thumb first. I am getting intermittent results with thumbnails.

Please see this thread for more info on my problem

http://forum.xbmc.org/showthread.php?tid=129660