Kodi Community Forum

Full Version: Play/pause key from Xtreamer ultra remote on XBMC eden problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just installed xbmcbuntu 11.10 on my xtreamer ultra. Everything works quiet nice except for play/pause button on the remote. I had openelec 10.0.2 before and it worked ok, so this is not a hardware problem.
When I started debug logs, here is what I see when I press the button:

Code:
20:11:50 T:3017414416   DEBUG: LIRC: Update - NEW at 96790:000000037ff07b91 00 PlayPause mceusb (PlayPause)

So it does receive the key press, but doesn't propagate it to XBMC. I tried to add following xml configuration file to the XBMC, but it didn't help:

Code:
<keymap>
  <global>
    <keyboard>
      <play_pause>PlayPause</play_pause>
    </keyboard>
  </global>
</keymap>

What am I doing wrong here?

Thanks!
I think I figured it out.
Instead of changing XBMC configuration, I configured LIRC to send Play instead of PlayPause. In XBMC pressing Play during video playback pauses the video, so mapping Play/Pause to Play does the job.
Would you be so kind as to provide me with an idiots guide to setting this up? I am experiencing this exact same problem.
In /usr/share/lirc/remotes/mceusb/lircd.conf.mceusb
Change the line:
PlayPause 0x00007b91
to:
Play 0x00007b91

OP