Kodi Community Forum

Full Version: TV Updates, Movies don't - any clues?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Eden clean build (yes, clean, no dharma components left)
DB imported from Dharma export (250 shows, 500 movies)
All play fine.
Adding tv shows get detected and shows in files, library, smart playlists and recently added (Aeon MQ3)
Adding movies shows in files, nowhere else.
Sources are set (from shared SMB)

So the shares work (files browse and play), update process works (new TV shows appear as expected) but movies don't, any clues??Huh
Please upload a debug log
Yep debug_log (wiki), post to pastebin then link back to it in this thread.
Yes, this happened after I downloaded an update yesterday, it seems to be a new bug. I have confirmed this on a second XBMC machine I have which had not been updated and still worked. I updated it and it stopped working as well.

My version is reported as;

XBMC 11.0 Git:Unknown (Compiled : Apr 7 2012)

The IMDB and TVDB scrapers both work, but the TMDB scraper is broken. I don't know whether a bug has already been logged, I can't find one on the bug tracker.
Turn on debugging and update your library. Many times I have ended up with an episode or sometimes a movie that had 'garbage' or ascii characters in the filename for some reason, and it would throw a 'silent' error when it hit that file, and just stop checking further. Renaming the file, and suddenly it started finding things again.
Hi Glave

I am certain that this issue has nothing to do with the library.

Just to clarify the situation.

I have 3 machines with XBMC, all using the same NAS for the library.

I inadvertantly updated one yesterday (apt-get upgrade) but didn't pay enough attention to notice that XBMC was being updated.

From that point on I was unable to scrape the TMDB (Unable to connect to remote server)

Initially I did not link the problem to the XBMC update and spent several hours searching google and trying different stuff.

The IMDB and TVDB scrapers both work fine.

Then I noticed on my second box that apt-get was reporting that XBMC was one of the updates in the pipeline.

Hmmm. I fired up XBMC and went to "Files" and "Movies" in the library, hit "Scan" and it worked fine. No problem at all.

I closed XBMC and did the apt-get upgrade.

When it was done, I opened up XBMC, the automatic scan started and failed with "Unable to connect to remote server"

The library is unchanged.

My third PC is still on the old version but I cannot access it right now, however I'm sure that it will still be working fine.

Here is the relevant part of the debug log;

VideoInfoScanner: No NFO file found. Using title search for '/store/archive/video/Movies/Pirates of the Caribbean 2: Dead Mans Chest (2005).avi'
12:02:42 T:140524858918656 DEBUG: FindMovie: Searching for 'Movie' using The MovieDB scraper (path: '/usr/share/xbmc/addons/metadata.themoviedb.org', content: 'movies', version: '3.0.9')
12:02:42 T:140524858918656 DEBUG: scraper: CreateSearchUrl returned <url>http://api.themoviedb.org/3/search/movie?api_key=57983e31fb435df4df77afb854740ea9&query=pirates%20of%20the%20caribbean%202%3a%20dead%20mans%20chest+2005&language=en</url>
12:02:42 T:140524858918656 DEBUG: FileCurl::Open(0x7fce7e4c3310) http://api.themoviedb.org/3/search/movie...anguage=en
12:02:42 T:140524858918656 INFO: easy_aquire - Created session to http://api.themoviedb.org
12:02:44 T:140524858918656 WARNING: FillBuffer: curl failed with code 22
12:02:44 T:140524858918656 ERROR: CFileCurl::CReadState::Open, didn't get any data from stream.
12:02:44 T:140524858918656 ERROR: Run: Unable to parse web site

It just occured to me to check the URL that the VideoScanner is scraping from the above log.

This is the URL;

This is what is returned;
{"status_code":7,"status_message":"Invalid API key - You must be granted a valid key"}

I installed Wireshark and did a dumpcap on the interface.

I am receiving "401 Unauthorised" back from the TMDB in response to the GET request HTTP 392 GET /3/search/movie?api_key=57983e31fb435df4df77afb854740ea9query={query removed}language=en HTTP/1.1 HTTP 520 HTTP/1.1 401 Unauthorized (text/html)

I removed the search string (query removed) from the above to make it more readable