Kodi Community Forum

Full Version: XBMC dropping afp shares - cannot reconnect
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I have a multi room setup of XBMC spread across two macs running Lion and two AppleTV (1st Gen) running Crystalbuntu. All of these machines are running XBMC Eden.

One of the macs is setup as the server with fixed IP address (also called Jack) and all of my content attached on external USB drives. These drives are all shared by afp. MySQL runs on this mac. All of the other machines are correctly configured to look for this MySQL database and they all pick up the library and everything works great...for a while.

On a number of occasions I have turned on one of the AppleTV devices and attempted to play a video from the library only to see a message pop up saying something like "File is no longer available, would you like to remove it from the library". I say no of course. If I go to the Videos>Files menu and attempt to browse to the share I can load up the zeroconf menu and see my server (Jack (AFP)) but when I select it no afp shares are available. Nor can I enter the share address manually. If I restart the AppleTV then 9 times out of 10 I can play videos from my library and browsing to the zerconf>Jack (AFP) folder I can see all of my AFP shares without any problem.

This leads me to believe that something within XBMC or the underlying OS is locking up the afp protocol which can only be rectified by a reboot.

Does anybody have any thoughts on this?



I'm way behind you technically, but I'm experiencing similar problems. My setup is somewhat similar too. Using a ATV1 with USB Crystalbuntu. It had been working and stuttering before the USB Crystalbuntu and I though all my problems were behind me since once installed, it worked great for a month or two. Rebooted the ATV tonite and tried to access my remote media drive which is a USB Fantom that has performed flawlessly. It is connected via USB to my iMac downstairs in my home studio.

All my home wifi and hard-wired devices are accessing the internet just fine. Went downstairs and I can access the Media drive on my iMac and watch any movie on the drive without a hiccup. I came back up and powered down the ATV and rebooted. Looks like everything is going OK... but do you guys get a switch from a black linux screen to a purple one and then black again?

In the end, the XMBC logo comes up and Sam's name is on the credit page, then the Confluence screen comes up. Go to the "Files" section and it looks OK, select the "Media-1" drive. Getting the "connection timed out" and "cannot connect to remote server" popups. This was working a week ago and nobody has messed with anything, or changed anything on my home network. Using my MBP running wirelessly in the next room right now.

Like I said... I'm not a tech-head, I follow instructions from the excellent genius-level people around here and thats how this old grandpa gets it done LOL! Googling the issue seems to turn up a LOT of similar situations with dozens of possible solutions. Maybe its a bug, maybe its the way we _should_ be configuring things that is not spelled out so you can't make a mistake. I'll keep messing with it, but hopefully somebody will post a checklist or whatever so we can go through everything.

Hi Mike,

I gave up on the AFP sharing in the end and migrated across to NFS shares. Since then everything runs almost flawlessly. Sometimes the NFS shares get confused but a reboot of the iMac and each xbmc install seems to resolve the issue. Its a fairly rare occurrence and not too much of a pain.

I would suggest you download NFS Manager for your mac and give it a go. If you get stuck then post back here and I can post my settings.



I'll download NFS Manager for the iMac, but can you give me a step-by-step on the install or conversion? Do I have to make a new Crystalbuntu USB stick or modify my ATV1 any further? Do I need to put my media on another drive? See what I mean? I'm a novice LOL.

Andy or anyone...

I downloaded NFS Manager, and a window opens telling me to drag it where I want it. Is there a "How-To" on what you do with NFS manager so I can try it out and see if this resolves the problems I'm having with ATV1 trying to find my network and media drive?