Kodi Community Forum

Full Version: none of my installs can see smb share
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi

I have a server in my loft running windows storage server 2008 essentials, its got 4 tb of media on it shared via smb.

None of my xbmc installs can see it. I have tried my laptop ( running windows 7 and eden ) my main xbmc machine ( live machine updated to eden) and May ipad2 ( eden ), when i go to add a source nothing comes up when you select smb.

If i add the sources directly to the sources file in userdata it works fine, all media plays, scrapes everything.

Also my laptop will quite happily browse to the server and it can see all the files.

It just seems to be a problem when browsing to the smb share with xbmc. It DID work at first but i have reinstalled the software on the server due to hdd failure but i dont no if it stopped working then.
So far i have tried re-setting the router (homehub3) but that made no difference.

Sometimes when i try and browse to a share on xbmc it says error2Confusedhare not available other times it does nothing.

Hope that makes sense.

Please help.

Matt
Browsing for SMB servers has been the source of much pain ever since Microsoft released Lan Manager about twenty years ago. To be fair to Microsoft it usually works OK, but the symptoms you describe are exactly the sort of thing I've seen intermittently for years.

The best way to use an SMB source is to open the Add source dialog, click the Browse button and select "Add network location" (you'll need to scroll down to see this). Enter the server and share names and username/password if required and click OK, and the list in the Browse dialog will now contain an entry like "smb://server/share/". Sources created in this way have the greatest resilience to the woes to which SMB is prone.
Another tip is to give your server a static IP adres and use that in the add source instead of host name
Thank you both,

Ill have a look when ive finished filling this bastard big skip.

Matt
(2012-04-18, 18:52)Martijn Wrote: [ -> ]Another tip is to give your server a static IP adres and use that in the add source instead of host name

this made my life 100x easier when I was setting up my smb shares
It also makes accessing shares quicker because it doesn't need to go through that whole Name resolving stuff too
I thought this might be a good thread to piggyback on. I'm using SMB to share a few different devices. Macbook Pro 10.6.8, Windows Vista, and recently Pogoplug. My windows install of XBMC 10.1 installed March 2011, can see all of my devices via SMB and connect just fine. Mac and IOS (iphone 4 and ATV2) on latest stable Eden versions, can't see any SMB shares, although they used to. When I go to add a share via Zeroconfig, the mac and ios versions see the Macbook (samba), but not the Vista machine or the Pogoplug.

Also when I try to manually add the pogoplug share per the instructions above, either by device name, or by IP address, using the username and password that works on SSH as root, it doesn't let me connect either way.

They can see and connect to the macbook via zeroconfig though. But I'm really trying to get a connection to the Pogoplug.

Any ideas? I've been working on this for a while and will try anything at this point. I'm pretty stumped.