Kodi Community Forum

Full Version: How to switch the default movie scraper (TMDb) to something else?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Here's my config:
ubuntu 11.10
XBMC 11.0
+ "KinoPoisk scraper" from seppius-xbmc-repo version 1.0.45 - the movie scraper in Russian.

it didn't work out-of-the-box (after new scraper installation), so google offered me to try to change the <moviesdefault> key in guisettings.xml
cat /home/xbmc/.xbmc/userdata/guisettings.xml | grep moviesdefault

It didn't help. When I ask XBMC to scrap some movie info I see in logs (<loglevel> is 1):
DEBUG: FindMovie: Searching for 'Городской ковбой 1980' using The MovieDB scraper (path: '/home/xbmc/.xbmc/addons/metadata.themoviedb.org', content: 'movies', version: '3.2.0')
DEBUG: scraper: GetSearchResults returned <results></results>

So it doesn't even trying to request through that Kinopoisk scraper. Although the guys on the Russian support forum use it with no problem (but there're no posts about using it together with XBMC 11, maybe something has changed in the last update?).
To make sure it's not something wrong with the scraper itself, I also tried to install (and than force usage of the new scraper in <moviesdefault>) a few other scrapers - no result. It keeps asking ONLY themoviedb.org

Then I tried to "kill" the TMDb (as it's not possible to just disable it in UI) by `chmod a-r -R` on its add-on folder. The result: when I ask to scrap movie info XBMC says: "the server is unavailable" and again - no sight of any alternative scrapers in logs.

Any thoughts how to convince the beast to use MY scrapers? Smile
edit the "source"
change scraper to whichever you like
thank you. already solved it, forgot to mark the thread.
can you explain howHuh?

what is the source? or where?