Kodi Community Forum

Full Version: Ubuntu Server 12.04 install of XBMC fail with "Unable to open display"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Installed Ubuntu Server 12.04 32bit with only SSH as extra
Installed then XBMC, but when I try to run xbmc.bin I get "Unable to open display"

Tried to download NVidia driver 290.10 and later 295.49, but both failed to install

Please advise how to progress, thanks

(Used all night without any progress, need some sleep now while the snow is falling... Sad )
install fluxbox and start it with startx to ensure you have a display that can be opened.
Still the same

Fatal error, no screens found

[email protected]:~$ startx

X.Org X Server 1.11.3
Release Date: 2011-12-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.42-23-generic i686 Ubuntu
Current Operating System: Linux xbmc 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic-pae root=UUID=2f013ed9-18d6-46db-a1e7-f16d08a0005f ro
Build Date: 20 April 2012  05:12:21AM
xorg-server 2:1.11.4-0ubuntu10.1 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.24.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat May  5 15:00:43 2012
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
FATAL: Module nvidia_current not found.
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:     system's kernel log for additional error messages.
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) Failed to load module "nouveau" (module does not exist, 0)
(EE) Failed to load module "nv" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
         at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

ddxSigGiveUp: Closing log
Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: No such file or directory
xinit: server error

Maybe the problem is that I have to much ram? (Having had problem with PAE before)

Giving up, will try 64bit now
Are there some differences in support for 64bit vs 32bit version i XBMC and AudioEngine?
After some googling I find this was working:
xinit /usr/bin/xbmc --standalone
We run into each other again..... Big Grin

It looks like the nvidia driver isn't being used, and it might not be using the gpu to decode and taxing the CPU. Let us know if you're having issues. I reinstalled with the 12.04 server (i386 version) and installed everything from scratch. It went smooth, but ran into a couple of problems.

I stuck with the 32 bit kernel because I have 2 gigs of RAM, only use the computer for xbmc, and if xbmc was built on 32 bit for xbmcbuntu, I figured I'd stick with that.

Thank you Wiz561, but I feel stuck now Sad

I started up first with a new install of 12.04 server i386, but could not get sound working. aplay -l return no soundcard. Had some problem before with PAE version, I decided to try 64bit version, but no luck here either. Had big problem too with "Unable to open display" when I try to start xbmc

/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
Error: unable to open display
FEH.py: cannot connect to X server