Kodi Community Forum

Full Version: [XBMCbuntu] mkv playback screen is green
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
XBMCbuntu 11.10
ATI Radeon HD4200 Integrated Video

I just did a clean install, and tried playing back some of my .mkv video files off of my NAS and the screen is either green during playback or a combination of pink and green vertical lines. The audio seems to work fine. All of my videos played fine before the xbmcbuntu install. I wanted to know if anyone had this experience and where to begin troubleshooting. Thanks for the help,
Here is the portion of the xbmc debug log for the video I just tried from when I press play until the first error in the log...

20:45:37 T:3043022592 NOTICE: DVDPlayer: Opening: smb:// Beautiful Mind/A Beautiful Mind.m4v
20:45:37 T:3043022592 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
20:45:37 T:3043022592 DEBUG: CRenderManager::UpdateDisplayLatency - Latency set to 0 msec
20:45:37 T:3043022592 DEBUG: LinuxRendererGL: Cleaning up GL resources
20:45:37 T:2474974064 DEBUG: Thread CDVDPlayer start, auto delete: 0
20:45:37 T:2474974064 NOTICE: Creating InputStream
20:45:37 T:2474974064 DEBUG: CFileSMB::Open - opened Movies/A Beautiful Mind/A Beautiful Mind.m4v, fd=10000
20:45:37 T:2474974064 DEBUG: ScanForExternalSubtitles: Searching for subtitles...
20:45:37 T:2474974064 DEBUG: OpenDir - Using authentication url smb://192%2e168%2e1%2e101/Movies/A%20Beautiful%20Mind
20:45:37 T:2474974064 DEBUG: ScanForExternalSubtitles: END (total time: 31 ms)
20:45:37 T:2474974064 NOTICE: Creating Demuxer
20:45:37 T:2474974064 DEBUG: Open - probing detected format [mov,mp4,m4a,3gp,3g2,mj2]
20:45:37 T:3043022592 DEBUG: ------ Window Init (DialogBusy.xml) ------
20:45:38 T:2474974064 DEBUG: Open - av_find_stream_info starting
20:45:38 T:2474974064 DEBUG: Open - av_find_stream_info finished
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'smb:// Beautiful Mind/A Beautiful Mind.m4v':
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: Metadata:
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: major_brand : mp42
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: minor_version : 0
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: compatible_brands: mp42isomavc1
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: creation_time : 2012-03-20 02:01:40
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: encoder : HandBrake 4510svn 2012031801
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: Duration: 02:15:18.08, start: 0.000000, bitrate: 990 kb/s
20:45:38 T:2474974064 INFO: ffmpeg[93851B70]: Chapter #0.0: start -0.066733, end 83.416667
20:45:38 T:2474974064 NOTICE: Opening video stream: 0 source: 256
20:45:38 T:2474974064 NOTICE: Creating video codec with codec id: 28
20:45:38 T:2474974064 DEBUG: CDVDFactoryCodec: compiled in hardware support: CrystalHD:yes OpenMax:no VDPAU:yes VAAPI:yes
20:45:38 T:2474974064 DEBUG: FactoryCodec - Video: - Opening
20:45:38 T:2474974064 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
20:45:38 T:2474974064 DEBUG: FactoryCodec - Video: ff-h264 - Opened
20:45:38 T:2474974064 NOTICE: Creating video thread
20:45:38 T:2474974064 NOTICE: Opening audio stream: 1 source: 256
20:45:38 T:2474974064 NOTICE: Finding audio codec for: 86018
20:45:38 T:2474974064 DEBUG: FactoryCodec - Audio: PassthroughFFmpeg - Opening
20:45:38 T:2474974064 ERROR: CDVDAudioCodecPassthroughFFmpeg::Open - FFmpeg SPDIF muxer does not support this codec
Alright I solved the problem by disabling VAAPI in the xbmc settings. I do have VDPAU enabled.