Kodi Community Forum

Full Version: [SOLVED] XBMCUbuntu - Buffering when playing mkv file from USB HDD
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi There,

Regards from Buenos Aires, Argentina!

I'm having issues when I'm playing a 1080 mkv from an external USB drive. Every 10 seconds or so, it will start buffering, which is very annoying. The same thing happens with 720 mkv but every 30 minutes and just once.

I've been reading the forum but I found this problems to be happening most of the time when playing over the network but not with an external drive.

This is what I have:

1. XBMCUbuntu Compiled Mar 24 2012
2. uname -r: Linux 3.0.0-19-generic-pae
3. uname -m: i686
4. XMBCubuntu via HDD
5. http://pastebin.ubuntu.com/985657/
6. I'm using a Xtreamer Ultra 1
7. It's a fresh install - I've downloaded it yesterday, ran it from a USB drive but haven't installed any plug-in or modified the advancedsettings.xml file
8. Same issue was happening when running Windows 7. I did, however, modify the advancedsettings.xml file when I ran Win 7 and added the <cachemembuffersize>5242880</cachemembuffersize> tag. When that didn't take care of the issue, I though the problem was on Windows itself so I decided to give a shot to XMBCUbuntu

Any help or ideas will be highly appreciated it.
Thanks in advance!
Check your disk read speed. It may indicate that the disk itself is going bad.

Code:
sudo hdparm -Tt /dev/hda
substitute the actual drive location for the /hda part.
What format is the drive?

If it's NTFS then ntfs-3g used to mount it has been known to cause issues in certain applications - like running VM's. Can you try running this same test, but with the drive mounted to something native like EXT4?
Hi Guys,

Thanks for your ideas, but I fixed it. I don't what happened. I had to over-write the BIOS and load the optimal features. I noticed, too, it was set to 8 USB ports when I actually have 6. I don't know if that has anything to do, but I set it to the right parameter and now it's working like a charm!

Thanks for your help!