Kodi Community Forum

Full Version: Help with Boblight/adalight.....
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I need help setup up boblight/adalight.

I've created a adalight following http://www.ladyada.net/make/adalight/ but cant get it to work.
What I've done is connected everything up and double check it. connected 5v power supply and usb. then open Andrino IDE and upload the LEDstream.pde sketch to the andrino board.

Ive tried with Boblight on openelec installing the Daemon and the client and change the config file removing .sample. with no luck.

I've also tried colorswirl and adalight via Processing IDE and it doesnt work.

ive anyone knows something i can trying please help me out.

thanks guys
have you connected the input side of the led stream?
if connections are ok, and ledstream.pde is uploaded on arduino, each time you connect the arduino to the pc, led should pass green / red / blue

Thanks alot for the quick reply.

I've got the arrow on the LEDs pointing away from the Andrino, and when I connect via USB I get RED -> GREEN -> BLUE then off.

Does that sound right to you? or should it be G/R/B like you said?

thanks again
no, that's good, you can test with Processing.
don't forget to install arduino drivers.
Yeah thats the thing I cant get it to do anything with Processing. I've tried running both Colorswirl and adalight pde's

I open processing, open pde, and click run.

am i missing somthing? I have installed the drivers after having trouble uploading the LEDstream to andrino should be good now.
do you get an error in processing when you truy to run ?
WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.2pre2

Average frames/sec: 234, bytes/sec: 15505
Average frames/sec: 621, bytes/sec: 41039
Average frames/sec: 743, bytes/sec: 49043

make any sense to you?

Ok I just tried running Processing on my mac and its working well.

I was trying it on a win7 machine...

So ok, I've got adalight and colorswirl working, do i just connect it to my htpc and run boblight daemon and client??

Were can i read about setting up my config, becuase im running two strands of 40 LEDS together.

I'm guess I need to set it up to work with 40 and where the led start from etc?

thanks so much for your help
run boblight deamonsudo boblightd -f
then activate booblight service addon in xbmc, all should be good.

for the conf file, look in the addon thread, there's a link for a calculator.

i don't know what prefix you need, i only know them for 25/50 led, i bet you'll need a different one.
Thanks again ppic

So now I thought everything would be fine and all go.

But when I try to use this on my HTPC with OE, boblightd services add-on and boblight xbmc add on I get nothing.

When I reboot I get and error that boblight could not connect or something.

please help me out if you know anything.

To calculate the adalight prefix run this in processing (don't forget to change the number of LED ;-))
int N_LEDS = 25; // Max of 65536

void setup()
  byte[] buffer = new byte[6];


  // A special header / magic word is expected by the corresponding LED
  // streaming code running on the Arduino.  This only needs to be initialized
  // once because the number of LEDs remains constant:
  buffer[0] = 'A';                                // Magic word
  buffer[1] = 'd';
  buffer[2] = 'a';
  buffer[3] = byte((N_LEDS - 1) >> 8);            // LED count high byte
  buffer[4] = byte((N_LEDS - 1) & 0xff);          // LED count low byte
  buffer[5] = byte(buffer[3] ^ buffer[4] ^ 0x55); // Checksum

print("Prefix for "+N_LEDS+" LEDS: ");
for(byte b : buffer)
   print(" "+hex(b));


On openelec:
Check that boblightd is correctly configured : look in userdata/addon_data/service.multimedia.boblightd/service.log and fix any errors.

You also need to check the device that matches with your arduino it should be something like /dev/ttyUSB0 but it may change.
To find the right one, connect to your OE in ssh (how to)
- unplug your arduino.
- replug it and run the following command : dmesg | tail.
- You should see which device is the one mapped to arduino serial port (/dev/ttyUSB* or /dev/ttyASM*)

Here is a calculator for boblight.conf: http://sanya.tarhelyszolgaltato.eu/
You may need to swap red and blue colors values. It depends of your led strip.

Also, it seems there is a bug now with boblight addon in the last openelec version. Green light during mkv playback. You may use boblightX11 instead