Kodi Community Forum

Full Version: Unable to import library
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So in an attempt to get a mySQL library up and running, I exported my library - all appears to have gone well there are several folders of tbn files as well as an xml file. However, when I go back into XBMC and go to import from the dialog box it just closes immediately, there is no indication of loading and there is no library created. Any help is appreciated.

did you export as a single file?
I can't see any evidence of the import in the debug log. There should be a line like:

DEBUG: CVideoDatabase::ImportFromXML: Starting import (export version = 1)

Did you attempt an import while recording the log?
Yes, I did import as a single file.

It was recording when I tried, I actually tried twice on it. I was just navigating to the folder (xbmc_videodb_2012-05-29) then I hit ok. But like I said, the dialog box closed immediately and from what you are saying its not doing anything.

Am I supposed to click on the xml file and not the main folder? If so, its not showing when I navigate through the menus on the atv2, however, when I SSH into it, I can see it exists.
I did a test import to check what appeared in the log. I navigated into the folder (xbmc_videodb_2012-05-30 in my case) so my browse dialog was showing:


then clicked OK and everything imported fine. You get a progress bar as it imports so you won't be in any doubt whether it's importing or not.
Yeah that was my problem. I was not navigating into the folder, rather I was navigating to the folder and then clicking ok. When I actually went inside of it and clicked ok, everything worked as intended. Thanks.