Kodi Community Forum

Full Version: [xbmcbuntu] [SOLVED] some buttons not working PHILIPS MCE USB IR Receiver-Spinel plus
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7
(2015-12-10, 20:22)FernetMenta Wrote: [ -> ]No Idea what distro you are using. Why don't you use something like Ubuntu where you just need to install those packages? No need to compile yourself

I stated it above KodiUbuntu 14.0. or kodi live .I dont know what else to call it. the one listed here for download.
Hey all, sorry to resurrect this old thread but it seems to still be relevant.

I have a Zotac CI520 nano 'plus' which has a built-in IR receiver. I fumbled about with mythbuntu a bit, and had issues with XFCE. I finally ended up just installing vanilla Ubuntu 16.04 and then adding the repo's for MythTV and Kodi.

At any rate, I am at a bit of a loss on how to get this remote working with LIRC. All the guides I've read are really old (including this one) and based on the last few posts I read, LIRC 0.9.2 should have the patches I need. Of course, Xenial provides 0.9.0... I haven't been able to find a PPA which is made for Xenial and has 0.9.2+ compiled. I found one for trusty 0.9.2 (https://launchpad.net/~forage/+archive/ubuntu/lirc) and 0.9.3a for vivid (https://launchpad.net/~leamas-alec/+arch...lirc-0.9.3) - but I can't find anything for Xenial.

Is my only option to compile 0.9.2 by hand? I was hoping for a PPA so I don't have to maintain it Smile


Edit - found this post and a lot of the buttons are now working... This seems like a bit of a roundabout way to do it, but it does work. Now I just need to map the rest of the buttons/keys and I think I'm golden.

Edit 2 - The more I dig into this, the more I think that post is not exactly the holy grail I thought it would be. I believe my remote is now acting as a keyboard... which I don't really have an issue with. However, i cannot for the life of me figure out how these buttons in lirc are getting mapped into Kodi... I've tried to build a few mapping files in Kodi and none work.
Pages: 1 2 3 4 5 6 7