Kodi Community Forum

Full Version: Remote control suddenly stopped working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My remote control worked with xbmcbuntu right out the box. Installed XBMCbuntu and the remote worked. No questions asked.

I was watching a TV show just then and by the end my remote control didn't work. Nothing responds at all.

What advice can you offer?
Hi there, i have the same problem, have reported this, and i guess its related to this:
http://forum.xbmc.org/showthread.php?tid=122805

Only thing that have helped me is to reboot. I think its related to a bug in the lirc version.

regards Alf Tonny B├Ątz
I am not using lirc, I have never installed it.

Also rebooting doesn't fix the issue.
Oo my bad. Obviously XBMC comes with LIRC integrated.

So updated my lirc.conf file in /etc/lirc/ and then tested irw. I got responses in the terminal.

After confirming that worked I made a lircmap.xml file (there wasn't one before)

That looks like this:

Code:
<lircmap>
       <remote device="vista_mce">
               <XBMC_button>LIRC_button</XBMC_button>
               ...
       </remote>
  </lircmap>


Still nothing works. What could be the problem?
UPDATE:

I now have the remote working again. Sort of...

The OK button doesn't work!

Quite an important one. I checked the LIRC.conf file and OK isn't mapped. How do I find out the hex value to put into the lirc.conf file for OK?
The whole device seems to function entirely differently now. Think something big has changed.
such as:

Now when I press a button there is a slight delay before the response on screen. If I shorten the "gap" in the LIRC.conf file then it double presses everything.

I can no longer use my remote to type words and letters. Before I could go into my tv shows and press "6" 3 times to skip straight to the "O" section. That does not work any more.

I my reinstall XMBCbuntu from scratch and see if I get functionality back.

If I do I will back up some files for later use if it breaks again.
Hi,
Before create your own Lircmap.xml, you should check the default XBMC Lircmap.xml: https://github.com/xbmc/xbmc/blob/master...ircmap.xml
I have already done that as there was no lircmap.xml

wirc also shows the delay so that it to do with the xml.
Anyone able to fix this yet?

I have tried installing XBMCbuntu from scratch again. No joy. Such a shame this remote is now useless.

LIRC cannot configure it to work properly at all
Which remote control is it (make/model or provide a link to a picture of it)?