Kodi Community Forum

Full Version: Help! Changing thumbnails from posters to banners
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I started messing with my skin and scraper settings and now my newly added tv shows are displayed on Confluence and Constellation as stretched posters. Is it possible for me to change theses retrospectively BACK to banners?

Basically I think I want to rescrape the thumbnails. Is that possible?

Also, is there a killer setup for these two?
You need to turn the setting off in the scraper settings and rescrape those shows (Video Information -> Refresh).
Ahhh, yes!! Many thanks JM, I now have perfect thumbnails once more. :-)

For any others, here is what you need to do :-

1. Make sure that Confluence skin is setup correctly :-
System --> Skin --> General Settings --> Use "Posters" instead of "Banners" for TV-Shows = UNCHECKED

2. Make sure that your TV-Show Scraper is setup correctly :-
System --> Addons --> Enabled Addons --> TV Information --> TheTVDB --> Configure --> Prefer Posters = UNCHECKED

3. Refresh TV-Show Information for the shows that have missing/stretched thumbnails :-
TV Shows --> Right-Click --> TV Show Information --> Refresh --> All Episodes = YES --> Ignore & Refresh = YES --> Select Show and wait for download to complete

NOTE - I found that I needed to iterate step 3 until the banner was displayed, despite having the above settings it seemed to still prefer posters at first. If this happens, then keep refreshing until you get the thumbnail you want.
Good thread just what I was looking for.

Have some other questions...

How do I do refresh for all TV shows and at the moment I have Aeon Nox skin and it has a "Lanscape" viewing option, how do I get lanscape icon?

Thanks!
lol i asked this yesterday too Smile
What I really dont understand is why you can have them all and let XBMC/settings choose which to use? I.e. TvTunes uses banners so my thumbs get stretched out.
TVDB only realistically has two options - POSTERS or BANNERS (and FAN-ART but these don't contain the show-title). The size of these is recommended by http://www.thetvdb.com/wiki/index.php/Category:Images as :-

posters = 680 x 1000
series banners = 758 x 140

So assuming you want to change from posters to banners for all tv-shows, try the following :-

Videos --> Files --> Right-Click on TV-Shows --> Select "Change Content" --> Settings --> Deselect "Prefer Posters" --> OK --> OK

You should now (hopefully) get a message saying "Do you want to refresh info for all items within this path". Simply say YES and it will rescrape all your TV_Shows. If it doesn't, then try resetting the TVDB scraper to force it to refresh for all items.

Best of luck

!! warning !!
I should warn you that by doing this will cause some of the library databases to be rebuilt. If it asks if you want to remove the library and start-over, say NO otherwise you could lose everything (incl playcounts) in the "files.db". However, saying NO will still result in the tvshow.db to be regenerated, but you will retain the playcounts & bookmarks.
Ideally XBMC would store both the banners and posters and then skins could use either. It's a huge pain when you want to try out a new skin but a certain view uses posters when you currently have banners. There is also no way to only refresh the show banners/posters so when you refresh the library it re-downloads everything which takes a much longer time.
(2012-11-04, 20:02)skaara Wrote: [ -> ]Ideally XBMC would store both the banners and posters and then skins could use either. It's a huge pain when you want to try out a new skin but a certain view uses posters when you currently have banners. There is also no way to only refresh the show banners/posters so when you refresh the library it re-downloads everything which takes a much longer time.

already done
Can you explain how? In my TVDB settings I have "Prefer posters" unchecked and whenever a skin uses posters it displays the banner stretched to poster size or a cropped banner which isn't stretched. Updating the scraper setting and refreshing makes it display properly though.

EDIT: Never mind. I see that this is a feature of the new version of XBMC. Can't wait!